CCNA课程实验-13-PPPoE

目录

实验条件

网络拓朴

需求

  1. OR使用PPPoE的方式向ISP发送拨号的用户名和密码,用户名:SPOTO 密码:SPOTO123,ISP没有告知使用哪种认证方式,拨号成功后自动获取IP信息,以及本地自动生成一条默认路由指向ISP;
  2. 配置PAT实现PC1能ping通ISP上的8.8.8.8;# 配置实现

配置实现

基础配置

模拟运营商ISP配置

  1. 先创建用户库
  2. 再创建虚拟接口模板
    a. 配置虚拟接口模板的IP地址
    b. 指定封装ppp协议
    c. 指定认证协商协议(PAP/CHAP)
    d. NCP阶段, IP地址下发配置
  3. 用BBA组与虚拟接口模板关联
  4. 进入物理接口关联到BBA组
java 复制代码
// 创建用户账号信息
ISP(config)#username cisco password ccie
// 创建ip地址池,可以是一个地址也可以是一个范围的地址
// 该地址池也可以用ip dhcp pool ipspool来创建,和dhcp服务共用池
ISP(config)#ip local pool ccieips 202.101.1.10

// 创建虚拟接口模板
ISP(config)#int virtual-template 1
// 需要在虚拟接口上配置IP地址,而不是在物理接口上
ISP(config-if)#ip address 202.101.1.1 255.255.255.0
// LCP,链路层协商,在虚拟接口封装PPP协议
ISP(config-if)#encapsulation ppp
// 指定认证的协议
ISP(config-if)#ppp authentication pap
// NCP,网络层协商 从地址池中获取地址, 用来下发IP地址
ISP(config-if)#peer default ip address pool ccieips
// 配置空闲时长, 超过自动断开,单位秒
ISP(config-if)#ppp timeout idle ?
  <1-4294967>  Idle timeout value in seconds
// 做以一个优化 因为PPPoE会额外的添加8字节的开销,防止超过MTU导致丢包
ISP(config-if)#ip mtu 1492
ISP(config-if)#no shutdown 
ISP(config-if)#exit

// 用BBA组与虚拟接口模板关联
ISP(config)#bba-group pppoe ISP
ISP(config-bba-group)#virtual-template 1
ISP(config-bba-group)#exit

ISP(config)#int e0/1
ISP(config-if)#no shutdown 
ISP(config-if)#pppoe enable group ISP
ISP(config-if)#exit

ISP的DNS配置

java 复制代码
// 启用DNS服务
ISP(config)#ip dns server
// 添加解析记录
ISP(config)#ip host www.test.local 8.8.8.8
ISP(config)#int e0/0
ISP(config-if)#ip address 8.8.8.8 255.255.255.0
ISP(config-if)#no shutdown
ISP(config-if)#

出口路由器OR基础配置

配置dhcp服务

java 复制代码
OR(config)#ip dhcp pool HOME
OR(dhcp-config)#network 192.168.10.0 255.255.255.0
OR(dhcp-config)#default-route 192.168.10.254
OR(dhcp-config)#dns-server 8.8.8.8 
OR(dhcp-config)#exit
OR(config)#ip dhcp excluded-address 192.168.10.254

OR(config)#int e0/0
OR(config-if)#ip address 192.168.10.254 255.255.255.0 
OR(config-if)#no shutdown
OR(config-if)#

PC1基础配置

java 复制代码
PC1(config)#no ip routing
PC1(config)#int e0/0
PC1(config-if)#ip address dhcp
PC1(config-if)#no shutdown

出口路由器OR配置

PPPOE拨号

  1. 先创建拨号口
    a. LCP
    b. 认证(PAP、CHAP)
    c. 下发默认地址
    d. NCP
    e. 创建拨号池
  2. 进入物理接口与上面创建的拨号池关联
java 复制代码
// 先创建拨号口
OR(config-if)#int dialer 1
// LCP阶段指定封装PPP协议
OR(config-if)#encapsulation ppp
// 修正包大小
OR(config-if)#ip mtu 1492
// ip地址协商
OR(config-if)#ip address negotiated
// NCP阶段 添加一条默认路由到PPPOE服务端
OR(config-if)#ppp ipcp route default
// 创建拨号池
OR(config-if)#dialer pool 1      
OR(config-if)#no shutdown
OR(config-if)#exit

// 进入接口关联拨号池
OR(config)#int e0/1
//OR(config-if)#pppoe enable group global 
OR(config-if)#pppoe-client dial-pool-number 1
OR(config-if)#no shutdown 

创建NAT(PAT端口复用)

java 复制代码
OR(config-if)#int dialer 1
OR(config-if)#ip nat outside
OR(config-if)#int e0/0
OR(config-if)#ip nat inside
OR(config-if)#exit     
OR(config)#ip access-list standard NAT-PAT
OR(config-std-nacl)#permit 192.168.10.0 0.0.0.255
OR(config-std-nacl)#exit
OR(config)#ip nat inside source list NAT-PAT interface dialer 1 overload
OR(config)#do show ip nat translations

PC1测试结果

java 复制代码
PC1#ping www.test.local
Translating "www.test.local"...domain server (8.8.8.8) [OK]

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 8.8.8.8, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/2 ms
PC1#

OR路由器

java 复制代码
OR(config)#do show ip route                                             
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override

Gateway of last resort is 101.1.1.254 to network 0.0.0.0

S*    0.0.0.0/0 [1/0] via 101.1.1.254
      101.0.0.0/32 is subnetted, 2 subnets
C        101.1.1.1 is directly connected, Dialer1
C        101.1.1.254 is directly connected, Dialer1
      192.168.10.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.10.0/24 is directly connected, Ethernet0/0
L        192.168.10.254/32 is directly connected, Ethernet0/0
OR(config)#do show ip nat translations
Pro Inside global      Inside local       Outside local      Outside global
icmp 101.1.1.1:0       192.168.10.1:0     8.8.8.8:0          8.8.8.8:0
OR(config)# 
相关推荐
About_Yu10 天前
第三章 交换机的端口配置与管理
网络·网络协议·智能路由器·cisco
木易王山1 个月前
华为、华三、思科、锐捷交换机路由器设备命令行常见错误信息
网络·华为·cisco·h3c·锐捷·命令行错误
GDXLB3 个月前
计算机网络 Cisco远程Telnet访问交换机和Console终端连接交换机
网络·计算机网络·交换机·cisco
烈火蜓蜻3 个月前
CCIE-10-IPv6-TS
网络·智能路由器·cisco·ipv6·bgp·troubleshooting·bgp-ipv6
sysin.org3 个月前
Cisco ACI Simulator 6.0(5h) - ACI 模拟器
cisco·模拟器·aci
旺旺仙贝5 个月前
中继DHCP配置实验
网络·cisco·路由与交换技术·中继dhcp配置
旺旺仙贝5 个月前
HSRP配置指南
网络·智能路由器·cisco·路由与交换技术·hsrp配置
旺旺仙贝5 个月前
串行线路和静态路由配置
网络·智能路由器·cisco·路由与交换技术·无线路由
烈火蜓蜻6 个月前
CCNP课程实验-Route_Path_Control_CFG
网络·智能路由器·cisco·ccnp课程
Geek极安网络安全6 个月前
【网络技术设备安全】BGP 基础与概述-2-中转 AS 中的 IBGP 路由传递
网络·网络协议·tcp/ip·安全·信息与通信·cisco·思科