HDU1276:士兵队列训练问题 ← STL queue

【题目来源】
http://acm.hdu.edu.cn/showproblem.php?pid=1276

【题目描述】
某部队进行新兵队列训练,将新兵从一开始按顺序依次编号,并排成一行横队,训练的规则如下:从头开始一至二报数,凡报到二的出列,剩下的向小序号方向靠拢,再从头开始进行一至三报数,凡报到三的出列,剩下的向小序号方向靠拢,继续从头开始进行一至二报数。。。,以后从头开始轮流进行一至二报数、一至三报数直到剩下的人数不超过三人为止。

【输入格式】
本题有多个测试数据组,第一行为组数N,接着为N行新兵人数,新兵人数不超过5000。

【输出格式】
共有N行,分别对应输入的新兵人数,每行输出剩下的新兵最初的编号,编号之间有一个空格。

【输入样例】
2
20
40

【输出样例】
1 7 19
1 19 37

【算法分析】
注意理解题意中的"从头开始一至二报数,凡报到二的出列"及"再从头开始进行一至三报数,凡报到三的出列"。它的意思是首先按照"1212121212 ······"报数,报到2的出列。然后在重构后,其余的按照"123123123123123 ······"报数,报到3的出列。

【算法代码】

cpp 复制代码
#include <bits/stdc++.h>
using namespace std;
const int maxn=1e5+5;

int main() {
    int T;
    cin>>T;
    while(T--) {
        bool flag=0;
        int n;
        cin>>n;

        queue<int> q;
        for(int i=1; i<=n; i++) q.push(i);

        while(q.size()>3) {
            int len=q.size();
            for(int i=1; i<=len; i++) {
                int t=q.front();
                q.pop();
                if(i%2!=0) q.push(t);
            }
            if(q.size()<=3) break;

            len=q.size();
            for(int i=1; i<=len; i++) {
                int t=q.front();
                q.pop();
                if(i%3!=0) q.push(t);
            }
        }

        while(q.size()>1) {
            cout<<q.front()<<" ";
            q.pop();
        }
        cout<<q.front()<<endl;
    }
    return 0;
}


/*
in:
2
20
40

out:
1 7 19
1 19 37
*/

【参考文献】
https://blog.csdn.net/Harington/article/details/88995536
https://codeleading.com/article/27134784117/