【总结】nginx源码编译安装报错./configure: error: SSL modules require the OpenSSL library.

问题现象

源码编译安装nginx时,执行./configure ...... --with-http_ssl_module 命令安装https模块,需要用到openssl,由于机器缺少openssl库,报如下错误。

复制代码
......
checking for openat(), fstatat() ... found
checking for getaddrinfo() ... found
checking for PCRE2 library ... not found
checking for PCRE library ... found
checking for PCRE JIT support ... found
checking for OpenSSL library ... not found
checking for OpenSSL library in /usr/local/ ... not found
checking for OpenSSL library in /usr/pkg/ ... not found
checking for OpenSSL library in /opt/local/ ... not found

./configure: error: SSL modules require the OpenSSL library.
You can either do not enable the modules, or install the OpenSSL library
into the system, or build the OpenSSL library statically from the source
with nginx by using --with-openssl=<path> option.

排查分析

因为机器不能连接外网,采用离线安装rpm 包的方式,安装openssl

从网上下载了:

openssl-1.0.2k-26.el7_9.x86_64.rpm

openssl-devel-1.0.2k-26.el7_9.x86_64.rpm

使用以下命令安装:
sudo rpm -ivh openssl-1.0.2k-26.el7_9.x86_64.rpm --nodeps --force
sudo rpm -ivh openssl-devel-1.0.2k-26.el7_9.x86_64.rpm --nodeps --force

openssl安装后,openssl命令正常。但是执行./configure ...... --with-http_ssl_module 还是报一样的错误。

在网上搜罗了一堆方法,改各种文件,都没有生效。

此时,严重怀疑是使用rpm 离线安装openssl库时,由于使用了--nodeps --force 这两个指令,忽略了openssl的依赖库,强制安装。导致openssl某些依赖,没有安装成功,从而导致openssl不可用。

于是再次认真阅读提示信息: or build the OpenSSL library statically from the source with nginx by using --with-openssl= option.

那就尝试一下吧,使用openssl源码静态库的方式来编译nginx。

解决方法

从openssl官网下载源码,使用--with-openssl= 的方式来编译安装。

下载地址:https://www.openssl.org/source/old/index.html

本人使用的centos 7,下载的是1.1.0k这个版本。

下载后解压,假如此处解压的目录是:/data/openssl-1.1.0k

那么执行:./configure --prefix=/data/nginx --with-http_stub_status_module --with-http_ssl_module --with-openssl=/data/openssl-1.1.0k

以上命令,可顺利通过。

接下来,执行:make && make install 就顺利编译通过了。

总结

  • 原因:可能是使用rpm 离线安装openssl库时,由于使用了--nodeps --force 这两个指令,忽略了openssl的依赖库,强制安装。导致openssl某些依赖,没有安装成功,从而导致openssl不可用。
  • 解决方法
    1)下载openssl 源码包
    2)解压到指定目录/data/openssl-1.1.0k
    3)执行./configure 时,添加--with-openssl=/data/openssl-1.1.0k参数

至此,问题成功解决。

相关推荐
天衍四九-1 小时前
【无标题】
前端·spring boot·mysql·nginx·docker
吴声子夜歌5 小时前
Nginx应用与运维——Nginx HTTP模块详解(动态赋值功能模块)
运维·nginx·http
姜鱼问生5 小时前
三层防火墙排查:Nginx 配好了浏览器还打不开
nginx·安全
小白的码BUG之路10 小时前
Docker -- 构建nginx镜像,启动vue项目
vue.js·nginx·docker
yume_sibai10 小时前
04-Nginx部署实战完全指南(前端部署 + 后端代理 + 监控告警 + 故障排查)
运维·前端·nginx
Lsetea19 小时前
curl指定CA目录仍报证书不受信任:--capath与OpenSSL rehash排查
运维·https·ssl·openssl·curl
程序员清风20 小时前
Docker、Nginx 与 Kubernetes 部署 AI 后端服务
nginx·docker·kubernetes
吴声子夜歌1 天前
Nginx应用与运维——Nginx核心配置指令(一)
运维·nginx
Lsetea1 天前
OpenSSL报path length constraint exceeded:CA层级与pathlen排查
运维·https·ssl证书·openssl·证书链
Lsetea1 天前
OpenSSL s_client退出码为0却证书验证失败:严格校验与Shell管道排查
https·shell·ssl证书·openssl·tls