服务器数据恢复—raid5阵列离线硬盘强制上线失败如何恢复数据?

服务器数据恢复环境:

某品牌2850服务器上有一组由6块SCSI硬盘组建的raid5磁盘阵列,上层操作系统为Redhat linux+ext3文件系统。

服务器故障&初检:

服务器在运行过程中突然瘫痪,管理员对服务器中的raid进行检查后发现有两块硬盘离线。管理员对其中一块离线硬盘进行强制上线操作,但是强制上线操作完成后操作系统启动异常。管理员马上将服务器关机,联系我们数据恢复中心寻求帮助。

raid5阵列出现两块硬盘离线的故障情况非常普遍。raid5磁盘阵列支持一块硬盘离线时的冗余保护,一旦多块硬盘离线,磁盘阵列便处于瘫痪状态,且不会自动上线。

市面上绝大多数硬件厂商生产的raid控制器敏感性较强,多数硬盘掉线仅仅是因为电源波动、控制器bug等非硬盘硬件故障所导致,本案例中的情况就是如此。因为经过硬件工程师的初步检测,没有发现有硬盘存在物理故障。即使掉线硬盘不存在物理故障,如果此时进行强制上线的操作,风险还是很大的。一旦上线错误就会导致raid控制器对数据造成不可逆的破坏,进入操作系统后因为文件系统不一致会进行自动修复,进一步加大数据恢复的难度。

服务器数据恢复过程:

1、将服务器中所有硬盘以只读方式进行扇区级全盘镜像备份,在备份过程中发现有多块硬盘存在坏道但没有下线,应该是raid还没有读到硬盘坏道。备份完成后将所有磁盘按照原样还原到原服务器上。

2、基于镜像文件分析所有磁盘底层数据,获取故障raid组成结构信息。根据获取到的raid结构信息重组raid并进行结构验证。

3、北亚企安数据恢复工程师手工修正被破坏的结构,将修正后的数据导出到一台存储上临时存放。

4、使用完好的硬盘在服务器上搭建新的raid5磁盘阵列,将恢复出来的数据迁移到新搭建的raid中。

5、数据恢复工程师和用户方对服务器中的数据进行检测,发现一切正常。本次数据恢复工作结束。

服务器数据恢复结论:

一旦raid5磁盘阵列出现多块硬盘离线、服务器瘫痪的情况切记不要盲目进行强制上线的操作。尽可能将原硬盘全部做镜像,然后寻求专业数据恢复机构的帮助。

相关推荐
_大峰_14 小时前
索尼 A7M4 误删视频恢复实战:基于原始卡镜像重建 MP4 数据
ffmpeg·数据恢复·音视频·mp4·exfat
CHS_Lab17 小时前
苹果(Apple)HFS+格式化恢复方法
数据恢复·视频恢复·苹果·格式化恢复·hfs+·存储格式化恢复
软擎2 天前
轻虾数据恢复科普:硬盘咔哒响、电脑认不出盘,还能自己救数据吗?
电脑·数据恢复
北亚数据恢复2 天前
【服务器数据恢复】RAID5阵列硬盘磁头物理故障修复和数据恢复案例
数据恢复·服务器数据恢复·北亚数据恢复·raid数据恢复
软擎3 天前
轻虾数据恢复科普:采访录音、会议记录误删了又不能重录,手机和录音笔里的录音怎么找回?
数据恢复
荣合技术服务4 天前
服务器数据恢复服务商——荣合科算技术服务
运维·服务器·数据恢复·荣合科算
荣合技术服务6 天前
国庆假期紧急救援:荣合科算成功恢复山西介休某医院影像数据
数据恢复·荣合科算
Tisfy6 天前
两台旧电脑修复 —— 绕过WinXP密码登录、备份和恢复Win7数据、安装Win10
windows·数据恢复·系统重装
东方护航数据恢复(深圳)6 天前
勒索病毒加密数据库怎么办?深圳 0 赎金解密恢复实录【东方护航数据恢复深圳店】
数据库·数据恢复·服务器数据恢复·勒索病毒·数据镜像
软擎7 天前
轻虾数据恢复软件新手指南:第一次数据恢复,从零开始五步走
数据恢复