7-8 计算存款利息

本题目要求计算存款利息,计算公式为interest=money×(1+rate)year−money,其中interest为存款到期时的利息(税前),money是存款金额,year是存期,rate是年利率。

输入格式:

输入在一行中顺序给出三个正实数money、year和rate,以空格分隔。

输出格式:

在一行中按"interest = 利息"的格式输出,其中利息保留两位小数。

输入样例:

复制代码
1000 3 0.025

输出样例:

复制代码
interest = 76.89

代码长度限制

16 KB

时间限制

400 ms

内存限制

64 MB

我的答案:

C语言:

cpp 复制代码
# include<stdio.h>
# include<math.h>
int main()
{
	double interest,money,rate,year;
	scanf("%lf %lf %lf",&money,&year,&rate);
	interest=money*pow(1+rate,year)-money;
	printf("interest = %0.2lf",interest);
	return 0;
}

运行结果:

C++:

cpp 复制代码
#include <iostream>
using namespace std;
int main()
{
	double interest, money, rate, year;
	cin >> money >> rate >> year;
	interest = money * pow(1 + rate, year) - money;
	cout << "interest" << "=" << interest;
	
}

运行结果:

相关推荐
懒羊羊大王&5 小时前
模版进阶(沉淀中)
c++
owde6 小时前
顺序容器 -list双向链表
数据结构·c++·链表·list
GalaxyPokemon6 小时前
Muduo网络库实现 [九] - EventLoopThread模块
linux·服务器·c++
W_chuanqi6 小时前
安装 Microsoft Visual C++ Build Tools
开发语言·c++·microsoft
tadus_zeng7 小时前
Windows C++ 排查死锁
c++·windows
EverestVIP7 小时前
VS中动态库(外部库)导出与使用
开发语言·c++·windows
胡斌附体8 小时前
qt socket编程正确重启tcpServer的姿势
开发语言·c++·qt·socket编程
GalaxyPokemon8 小时前
Muduo网络库实现 [十] - EventLoopThreadPool模块
linux·服务器·网络·c++
守正出琦8 小时前
日期类的实现
数据结构·c++·算法
ChoSeitaku8 小时前
NO.63十六届蓝桥杯备战|基础算法-⼆分答案|木材加工|砍树|跳石头(C++)
c++·算法·蓝桥杯