上传文件报413Request EntityToo Large错误解决办法

产生这种原因是因为服务器限制了上传大小

1、nginx服务器的解决办法

修改nginx.conf的值就可以解决了

将以下代码粘贴到nginx.conf内

php 复制代码
client_max_body_size 20M

可以选择在http{ }中设置:client_max_body_size 20m;

也可以选择在server{ }中设置:client_max_body_size 20m;

还可以选择在location{ }中设置:client_max_body_size 20m;

三者有区别

设置到http{}内,控制全局nginx所有请求报文大小

设置到server{}内,控制该server的所有请求报文大小

设置到location{}内,控制满足该路由规则的请求报文大小

2、apache服务器修改

在apache环境中上传较大软件的时候,有时候会出现413错误,出现这个错误的原因,是因为apache的配置不当造成的,找到apache的配置文件目录也就是conf目录,和这个目录平行的一个目录叫conf.d打开这个conf.d,里面有一个php.conf

目录内容如下:

php 复制代码
#
# PHP is an HTML-embedded scripting language which attempts to make it
# easy for developers to write dynamically generated webpages.
#
 
LoadModule php4_module modules/libphp4.so
 
#
# Cause the PHP interpreter handle files with a .php extension.
#
 
SetOutputFilter PHP
SetInputFilter PHP
LimitRequestBody 6550000
 
#
# Add index.php to the list of files that will be served as directory
# indexes.
#
DirectoryIndex index.php

误就发生在这个LimitRequestBody配置上,将这个的值改大到超过你的软件大小就可以了

如果没有这个配置文件请将

php 复制代码
SetOutputFilter PHP
SetInputFilter PHP
LimitRequestBody 6550000

写到apache的配置文件里面即可。

有好的建议,请在下方输入你的评论。

相关推荐
CV工程师丁Sir3 小时前
ArkWeb 手记 06|window.open 与页面跳转拦截
开发语言·php·harmonyos
可乐鸡翅yeah_3 小时前
HLS 业务 Referer‑Policy 网页元标签引发播放异常排错
前端·javascript·网络·ffmpeg·php·音视频
vipxieliang3 小时前
PHP 依赖注入容器从零实现:控制反转、手动注入与容器管理全解析
后端·php
运维行者_3 小时前
PHP性能监控怎么做?从响应时间到慢函数的6个关键指标
运维·服务器·开发语言·网络·支持向量机·php·接口隔离原则
Do_It_Today4 小时前
php xml 入门学习资料
开发语言·php
Do_It_Today5 小时前
php url路由入门实例
开发语言·php
fundoit5 小时前
资源服务器如何对 JWT 进行验签
java·运维·服务器·spring boot·php·oauth2
专业程序开发源6 小时前
SSM笔记本在线销售系统32649-计算机课程设计、毕业设计
java·spring boot·后端·python·django·php·课程设计
行业研究员6 小时前
AI反电诈怎么做?腾讯云天御风控Agent方案与落地解析
人工智能·php·腾讯云·ai反诈