上传文件报413Request EntityToo Large错误解决办法

产生这种原因是因为服务器限制了上传大小

1、nginx服务器的解决办法

修改nginx.conf的值就可以解决了

将以下代码粘贴到nginx.conf内

php 复制代码
client_max_body_size 20M

可以选择在http{ }中设置:client_max_body_size 20m;

也可以选择在server{ }中设置:client_max_body_size 20m;

还可以选择在location{ }中设置:client_max_body_size 20m;

三者有区别

设置到http{}内,控制全局nginx所有请求报文大小

设置到server{}内,控制该server的所有请求报文大小

设置到location{}内,控制满足该路由规则的请求报文大小

2、apache服务器修改

在apache环境中上传较大软件的时候,有时候会出现413错误,出现这个错误的原因,是因为apache的配置不当造成的,找到apache的配置文件目录也就是conf目录,和这个目录平行的一个目录叫conf.d打开这个conf.d,里面有一个php.conf

目录内容如下:

php 复制代码
#
# PHP is an HTML-embedded scripting language which attempts to make it
# easy for developers to write dynamically generated webpages.
#
 
LoadModule php4_module modules/libphp4.so
 
#
# Cause the PHP interpreter handle files with a .php extension.
#
 
SetOutputFilter PHP
SetInputFilter PHP
LimitRequestBody 6550000
 
#
# Add index.php to the list of files that will be served as directory
# indexes.
#
DirectoryIndex index.php

误就发生在这个LimitRequestBody配置上,将这个的值改大到超过你的软件大小就可以了

如果没有这个配置文件请将

php 复制代码
SetOutputFilter PHP
SetInputFilter PHP
LimitRequestBody 6550000

写到apache的配置文件里面即可。

有好的建议,请在下方输入你的评论。

相关推荐
子非鱼a1 小时前
【WEB】Online ToolWEB
php
PHP实战开发录2 小时前
Nginx上传大文件为什么报413
nginx·php·开发
damoluomu12 小时前
国产企业级 PHP CMS:哪些能免费商用
php
郑州光合科技余经理15 小时前
同城外卖小程序开发:下单成功后,后台导出能不能对上用户端状态
开发语言·前端·git·后端·uni-app·php·ai编程
MyFreeIT16 小时前
Android PHP Manual
php
aixingpan20 小时前
aixingpan.cn API开发文档:api_docs_trichart_natal_progression_sec_transit2接口指南
前端·php
sbjdhjd1 天前
从日志包含到临时文件竞争:文件包含进阶复盘中的 Docker、Windows 与 Session 限制
网络·安全·web安全·网络安全·数据挖掘·php·rce
daxiangxm1 天前
【趣味休息】“围住小猫在线玩”-“困住小猫”,又回来了
数据结构·人工智能·vscode·github·php
星光开发者1 天前
基于Spring Boot的充电桩管理系统的设计与实现-计算机毕设【课程设计】57105
vue.js·spring boot·vscode·mysql·django·php·express
辛迪聊物业数字化2 天前
智慧物业管理平台架构实践:从SaaS物业云到商管系统的全模块落地
大数据·微服务·php