上传文件报413Request EntityToo Large错误解决办法

产生这种原因是因为服务器限制了上传大小

1、nginx服务器的解决办法

修改nginx.conf的值就可以解决了

将以下代码粘贴到nginx.conf内

php 复制代码
client_max_body_size 20M

可以选择在http{ }中设置:client_max_body_size 20m;

也可以选择在server{ }中设置:client_max_body_size 20m;

还可以选择在location{ }中设置:client_max_body_size 20m;

三者有区别

设置到http{}内,控制全局nginx所有请求报文大小

设置到server{}内,控制该server的所有请求报文大小

设置到location{}内,控制满足该路由规则的请求报文大小

2、apache服务器修改

在apache环境中上传较大软件的时候,有时候会出现413错误,出现这个错误的原因,是因为apache的配置不当造成的,找到apache的配置文件目录也就是conf目录,和这个目录平行的一个目录叫conf.d打开这个conf.d,里面有一个php.conf

目录内容如下:

php 复制代码
#
# PHP is an HTML-embedded scripting language which attempts to make it
# easy for developers to write dynamically generated webpages.
#
 
LoadModule php4_module modules/libphp4.so
 
#
# Cause the PHP interpreter handle files with a .php extension.
#
 
SetOutputFilter PHP
SetInputFilter PHP
LimitRequestBody 6550000
 
#
# Add index.php to the list of files that will be served as directory
# indexes.
#
DirectoryIndex index.php

误就发生在这个LimitRequestBody配置上,将这个的值改大到超过你的软件大小就可以了

如果没有这个配置文件请将

php 复制代码
SetOutputFilter PHP
SetInputFilter PHP
LimitRequestBody 6550000

写到apache的配置文件里面即可。

有好的建议,请在下方输入你的评论。

相关推荐
一条破秋裤1 小时前
01_字符设备基本概念_从分类到LED控制链路
开发语言·php
唐青枫1 小时前
别只会给页面加 ROLE_ADMIN:Symfony Security 从登录到资源授权实战
php·symfony
xingpanvip3 小时前
星盘接口开发文档:推算星座接口指南
前端·php
mlidongfeng3 小时前
【学习笔记】【NV】GIN
开发语言·php
专业程序开发源3 小时前
springboot全民健身和饮食健康管理系统29158-计算机课程设计、毕业设计
java·spring boot·后端·python·django·php·课程设计
梦帮科技4 小时前
【3.0修订版】 RNS 代币架构:ERC20 五件套扩展与六钱包分配
数据结构·后端·算法·架构·node.js·区块链·php
quweiie4 小时前
Debian 13 / 宝塔 PHP 8.3开启 FFI 完整实战教程
php·ffi
xixiaoyunya4 小时前
CPU 100% 本身不是问题,它是一个症状
开发语言·php
专业程序开发源4 小时前
springboot外卖系统94294-计算机课程设计、毕业设计
java·vue.js·spring boot·后端·spring·php·课程设计
郑州光合科技余经理16 小时前
海外版外卖加盟:总站与分站配送规则怎么分开管
java·开发语言·前端·后端·uni-app·php·ai编程