Docker升级后,出现Error response from daemon: Unknown runtime specified docker-runc

现象:docker升级版本后,重启docker服务出现:

powershell 复制代码
[root@Docker scripts]# docker start registry
Error response from daemon: Unknown runtime specified docker-runc
Error: failed to start containers: registry

解决办法:

改完之后重启dokcer,容器就可以启动了。

powershell 复制代码
[root@Docker ~]# grep -rl 'docker-runc' /var/lib/docker/containers/ | xargs sed -i 's/docker-runc/runc/g'
[root@Docker ~]# systemctl restart docker

重启容器即可

powershell 复制代码
[root@Docker scripts]# docker start xxx
相关推荐
灯澜忆梦7 小时前
【minio】#1 | 简介与安装
docker·对象存储·minio
江湖有缘17 小时前
3款开源绘图工具整理合集,可Docker一键部署!
docker·容器·开源
TTATTC17 小时前
告别协议选型内耗:深入拆解微服务“内部 gRPC + 边界 REST”混合通信架构与 Envoy 转码实战
docker·开源
光依旧1 天前
PageIndex没翻车,翻车的是我的解析器
docker·langchain·大模型·向量数据库·pdf解析·rag·pageindex
谢亮_vipxieliang2 天前
容器排障实战手册:从日志到内核的分层排障
docker·云原生·容器·eureka
梦想不只是梦与想2 天前
Docker 常用命令
docker
小白的码BUG之路2 天前
Docker -- 构建ruoyi-gateway镜像
docker·容器·gateway
小白的码BUG之路2 天前
Docker -- 构建ruoyi-system镜像
运维·docker·容器
小白的码BUG之路2 天前
Docker -- 构建redis镜像
运维·docker·容器
江湖有缘2 天前
Docker实战 | 使用Docker部署EspoCRM开源客户关系管理平台
docker·容器·开源