nginx开启https配置之后网页无法访问问题处理

背景说明

最近新购服务器部署nginx之后按照之前的方式部署前端项目并配置https之后访问页面显示:无法访问.新的服务器ECS系统和之前相同,nginx安装方式也相同,nginx配置方式也是相同.但是访问还是显示无法访问.下面简单记录一下问题处理过程.

处理过程

1.https访问之后无法访问先确定安全组端口443是否开启.检查了一下是开启的.

2.确定网站证书配置是否正确,正确的配置截图如下:

3.查看nginx是否监听443端口

任意目录下执行命令:

c 复制代码
netstat -nultp

从截图看,443端口没有监听,先停止nginx,然后执行 netstat -nultp 看下nginx 的进程是否还存在,如果不存在了,再重新启动下nginx看下80、443是否正常监听.

查看nginx进程:

c 复制代码
ps -aux | grep nginx

关闭nginx:

c 复制代码
kill -QUIT PID

其中PID是您找到的Nginx进程ID。关闭两个nginx进程

重启nginx:

/usr/local/nginx/sbin下执行:

c 复制代码
./nginx -s reload

如果提示:

/usr/local/nginx/logs/nginx.pid" failed (2: No such file or directory)

可以直接执行:

c 复制代码
./nginx

重新查看443端口是否监听:

这里说下修改完配置文件执行./nginx -s reload不生效的原因:

nginx是编译安装的,reload是在原有的进程pid上重启的,之前的进程没有配置443,重启没有作用,结束进程重新启动nginx调用新的配置文件生成新的进程后端口正常监听!

以上是处理过程记录,如果感觉有帮助欢迎点赞收藏!

相关推荐
虎头金猫5 小时前
4K 视频总卡在公网带宽?用 N1 + OpenList 把网盘播放链路重新理顺
运维·服务器·网络·python·容器·beautifulsoup·pandas
还是大剑师兰特5 小时前
解决nginx错误:http://localhost:7000正常,http://localhost:7000/map 报错404
nginx·大剑师
AI职业加油站7 小时前
AI智能体应用工程师证书:政策红利下的职业新风口
大数据·运维·人工智能·学习·职场发展
此冬歌咏7 小时前
K8s 节点故障实战:优雅驱逐 31 秒,硬故障 331 秒,以及那个永远 Pending 的 Pod
运维·k8s
xing-xing8 小时前
Docker容器中Nginx站点根目录网页配置访问
nginx·docker
-梅8 小时前
linux(8) 软硬链接
linux·运维·服务器
张洛闻Eren8 小时前
k8s云原生【第十课】:水平 Pod 自动扩缩容
运维·数据库·云原生·kubernetes·github
其实防守也摸鱼9 小时前
内网穿透与反向代理:原理、工具与实战指南
android·大数据·运维·安全·网络安全·自动化·渗透
布裘9 小时前
【银河麒麟】V4桌面图标消失,右击鼠标没反应排查
运维·银河麒麟·桌面环境
懂软件的胡子个哥10 小时前
微信机器人为什么需要“回复候选”而不是所有 AI 内容直接发送
运维·微信·自动化·wechatapi·个人微信号二次开发