nginx开启https配置之后网页无法访问问题处理

背景说明

最近新购服务器部署nginx之后按照之前的方式部署前端项目并配置https之后访问页面显示:无法访问.新的服务器ECS系统和之前相同,nginx安装方式也相同,nginx配置方式也是相同.但是访问还是显示无法访问.下面简单记录一下问题处理过程.

处理过程

1.https访问之后无法访问先确定安全组端口443是否开启.检查了一下是开启的.

2.确定网站证书配置是否正确,正确的配置截图如下:

3.查看nginx是否监听443端口

任意目录下执行命令:

c 复制代码
netstat -nultp

从截图看,443端口没有监听,先停止nginx,然后执行 netstat -nultp 看下nginx 的进程是否还存在,如果不存在了,再重新启动下nginx看下80、443是否正常监听.

查看nginx进程:

c 复制代码
ps -aux | grep nginx

关闭nginx:

c 复制代码
kill -QUIT PID

其中PID是您找到的Nginx进程ID。关闭两个nginx进程

重启nginx:

/usr/local/nginx/sbin下执行:

c 复制代码
./nginx -s reload

如果提示:

/usr/local/nginx/logs/nginx.pid" failed (2: No such file or directory)

可以直接执行:

c 复制代码
./nginx

重新查看443端口是否监听:

这里说下修改完配置文件执行./nginx -s reload不生效的原因:

nginx是编译安装的,reload是在原有的进程pid上重启的,之前的进程没有配置443,重启没有作用,结束进程重新启动nginx调用新的配置文件生成新的进程后端口正常监听!

以上是处理过程记录,如果感觉有帮助欢迎点赞收藏!

相关推荐
Lsetea12 分钟前
OpenSSL verify报unhandled critical extension:error 34与关键扩展排查
运维·https·ssl证书·openssl·证书链
guo_wen_qiang39 分钟前
docker的备份与迁移
运维·docker·容器
Ruiery2 小时前
Linux 6.6内核内存管理深度解析(一):物理内存初始化 — memblock 怎么把内存交给 buddy
linux·运维·服务器
Android系统攻城狮2 小时前
Linux Gstreamer深度解析之gst_audio_encoder_get_frame_max调用流程与实战(五十九)
linux·运维·服务器·gstreamer音视频·音视频进阶·gstreamer音视频进阶
忆挽篱笙歌3 小时前
makefil
linux·运维·服务器
程序员老赵4 小时前
Docker 部署 Dolibarr:轻松搭建开源 ERP/CRM 平台
运维·前端·后端
cws2004014 小时前
监控摄像头选型指南
运维·网络·监控
协皓家具4 小时前
2026年广州岛台吧台椅厂家有啥新变化
大数据·运维·python·devops
OsDepK5 小时前
OSMDE_v1.9.0已加入FTP与shell功能
linux·运维·服务器
和裕5 小时前
定制纸箱刀模费全解析:费用定义与可减免合作场景
大数据·运维·网络·人工智能·算法