nginx开启https配置之后网页无法访问问题处理

背景说明

最近新购服务器部署nginx之后按照之前的方式部署前端项目并配置https之后访问页面显示:无法访问.新的服务器ECS系统和之前相同,nginx安装方式也相同,nginx配置方式也是相同.但是访问还是显示无法访问.下面简单记录一下问题处理过程.

处理过程

1.https访问之后无法访问先确定安全组端口443是否开启.检查了一下是开启的.

2.确定网站证书配置是否正确,正确的配置截图如下:

3.查看nginx是否监听443端口

任意目录下执行命令:

c 复制代码
netstat -nultp

从截图看,443端口没有监听,先停止nginx,然后执行 netstat -nultp 看下nginx 的进程是否还存在,如果不存在了,再重新启动下nginx看下80、443是否正常监听.

查看nginx进程:

c 复制代码
ps -aux | grep nginx

关闭nginx:

c 复制代码
kill -QUIT PID

其中PID是您找到的Nginx进程ID。关闭两个nginx进程

重启nginx:

/usr/local/nginx/sbin下执行:

c 复制代码
./nginx -s reload

如果提示:

/usr/local/nginx/logs/nginx.pid" failed (2: No such file or directory)

可以直接执行:

c 复制代码
./nginx

重新查看443端口是否监听:

这里说下修改完配置文件执行./nginx -s reload不生效的原因:

nginx是编译安装的,reload是在原有的进程pid上重启的,之前的进程没有配置443,重启没有作用,结束进程重新启动nginx调用新的配置文件生成新的进程后端口正常监听!

以上是处理过程记录,如果感觉有帮助欢迎点赞收藏!

相关推荐
智能运维指南25 分钟前
2026年ITSM系统怎么选?四款主流方案与五维评估模型
运维·itsm·嘉为蓝鲸
我命由我1234537 分钟前
Git 推送报错:error: src refspec main does not match any
运维·git·gitee·github·运维开发·学习方法·版本控制
骇客野人37 分钟前
测试环境MySQL迁移Vastbase(海量数据库)完整改造与落地实施方案
运维·服务器
迪康Defender1 小时前
终端安全实战:如何高效解决企业U盘泄密与管控难题
运维·网络·安全·web安全·终端安全管理
zly35002 小时前
VMware Converter Standalone 物理机转化为虚拟机后源1硬盘变成了2个硬盘(2个硬盘文件)虚拟机无法启动。
linux·运维·服务器
智能运维指南2 小时前
2026 企业智能运维平台选型:私有化、信创、全链路打通该怎么权衡?
运维·嘉为蓝鲸·aiops平台·一体化运维平台
春天花会开1312 小时前
Supabase 自部署 Edge Functions 超时从 60s 延长到 360s 完整复盘
运维·云原生
当下新鲜事2 小时前
脱硫脱硝塔动力系统科普:四方DL500变频器工作原理解析
大数据·运维·物联网·业界资讯
Lsetea3 小时前
Nginx报No required SSL certificate was sent:mTLS客户端证书排查
运维·nginx·https·ssl·openssl
山岚的运维笔记4 小时前
mysql 专业笔记 -- 第 36 章:MySQL 管理
运维·数据库·笔记·后端·mysql·oracle·dba