nginx开启https配置之后网页无法访问问题处理

背景说明

最近新购服务器部署nginx之后按照之前的方式部署前端项目并配置https之后访问页面显示:无法访问.新的服务器ECS系统和之前相同,nginx安装方式也相同,nginx配置方式也是相同.但是访问还是显示无法访问.下面简单记录一下问题处理过程.

处理过程

1.https访问之后无法访问先确定安全组端口443是否开启.检查了一下是开启的.

2.确定网站证书配置是否正确,正确的配置截图如下:

3.查看nginx是否监听443端口

任意目录下执行命令:

c 复制代码
netstat -nultp

从截图看,443端口没有监听,先停止nginx,然后执行 netstat -nultp 看下nginx 的进程是否还存在,如果不存在了,再重新启动下nginx看下80、443是否正常监听.

查看nginx进程:

c 复制代码
ps -aux | grep nginx

关闭nginx:

c 复制代码
kill -QUIT PID

其中PID是您找到的Nginx进程ID。关闭两个nginx进程

重启nginx:

/usr/local/nginx/sbin下执行:

c 复制代码
./nginx -s reload

如果提示:

/usr/local/nginx/logs/nginx.pid" failed (2: No such file or directory)

可以直接执行:

c 复制代码
./nginx

重新查看443端口是否监听:

这里说下修改完配置文件执行./nginx -s reload不生效的原因:

nginx是编译安装的,reload是在原有的进程pid上重启的,之前的进程没有配置443,重启没有作用,结束进程重新启动nginx调用新的配置文件生成新的进程后端口正常监听!

以上是处理过程记录,如果感觉有帮助欢迎点赞收藏!

相关推荐
Lvan的前端笔记3 分钟前
docker:每个前端项目一个 Nginx 容器还是只有一个Nginx容器
前端·nginx·docker
姜鱼问生18 分钟前
Nginx 缓存命中率监控:从 X-Cache-Status 到实时统计
运维·nginx·缓存
Apipi*40 分钟前
30天速通Linux 第六章信号及信号处理
linux·运维·信号处理
运维行者_2 小时前
网络性能监控怎么做?从自动发现到根因分析的4个环节
运维·服务器·网络·人工智能·支持向量机
此时不提桶,更待何时3 小时前
06-14-A-Kafka集群运维与迁移实战详解
运维·kafka
IT研究所4 小时前
AI-ITR平台如何减少客户问题反复升级?
大数据·运维·人工智能·低代码·自然语言处理·安全架构·企微
AIgorithmGEEK4 小时前
[Linux]从手写报头到内核套路:序列化、反序列化与自定义协议全链路
linux·运维·服务器·网络·序列化·反序列化
Nil2085 小时前
leetcode 139单词拆分
linux·运维·服务器
Starry-sky(jing)5 小时前
BUG: unable to handle kernel paging request 完整排查:dmesg 四要素与三路定罪
linux·运维·服务器·内核·排障
mounter6255 小时前
从硬件互连到操作系统变革:CXL 技术演进与 Linux 内核工程挑战
linux·运维·服务器