nginx开启https配置之后网页无法访问问题处理

背景说明

最近新购服务器部署nginx之后按照之前的方式部署前端项目并配置https之后访问页面显示:无法访问.新的服务器ECS系统和之前相同,nginx安装方式也相同,nginx配置方式也是相同.但是访问还是显示无法访问.下面简单记录一下问题处理过程.

处理过程

1.https访问之后无法访问先确定安全组端口443是否开启.检查了一下是开启的.

2.确定网站证书配置是否正确,正确的配置截图如下:

3.查看nginx是否监听443端口

任意目录下执行命令:

c 复制代码
netstat -nultp

从截图看,443端口没有监听,先停止nginx,然后执行 netstat -nultp 看下nginx 的进程是否还存在,如果不存在了,再重新启动下nginx看下80、443是否正常监听.

查看nginx进程:

c 复制代码
ps -aux | grep nginx

关闭nginx:

c 复制代码
kill -QUIT PID

其中PID是您找到的Nginx进程ID。关闭两个nginx进程

重启nginx:

/usr/local/nginx/sbin下执行:

c 复制代码
./nginx -s reload

如果提示:

/usr/local/nginx/logs/nginx.pid" failed (2: No such file or directory)

可以直接执行:

c 复制代码
./nginx

重新查看443端口是否监听:

这里说下修改完配置文件执行./nginx -s reload不生效的原因:

nginx是编译安装的,reload是在原有的进程pid上重启的,之前的进程没有配置443,重启没有作用,结束进程重新启动nginx调用新的配置文件生成新的进程后端口正常监听!

以上是处理过程记录,如果感觉有帮助欢迎点赞收藏!

相关推荐
归秋14219 分钟前
2026 企业 AI 办公工具选型指南:从评估框架到产品适配
大数据·运维·人工智能
Android系统攻城狮29 分钟前
Linux Gstreamer深度解析之gst_audio_encoder_set_frame_max调用流程与实战(六十一)
android·linux·运维·音视频·gstreamer音视频·音视频进阶·gstreamer音视频进阶
硅基手札2 小时前
【Linux内核专栏 14】网络协议栈
linux·运维·网络协议
工作10年+,存储芯片行业4 小时前
Linux NVMe 中断排查与性能优化:CPU 亲和性
linux·运维·服务器·windows·性能优化·ssd·pcie
快乐の番薯4 小时前
卷王问卷考试系统自动化功能测试
运维·功能测试·自动化
一号弯5 小时前
装完LINUX,请先新建日常用户
linux·运维·服务器
lpfasd1235 小时前
WinSW在Win7上失败真相-实测与修复
windows·nginx
Lsetea6 小时前
OpenSSL verify报unable to get issuer certificate:error 2与partial_chain排查
linux·https·ssl证书·openssl·证书链
许彰午6 小时前
03-Linux环境准备依赖包内核参数与用户组
linux·运维·服务器·数据库
阳光九叶草LXGZXJ6 小时前
达梦数据库-报错-16-MERGE INTO提示:无效的列名[XX]
linux·运维·数据库·sql·学习