nginx: [error] open() “/usr/local/openresty/nginx/logs/nginx.pid“ failed (2:

**错误原因:**nginx: error open() "/usr/local/nginx/logs/nginx.pid" failed (2: No such file or directory),logs目录下缺少pid文件。

解决方法:

使用指定nginx.conf文件的方式重启nginx

root@hadoop100 conf]# /usr/local/openresty/nginx/sbin/nginx -c conf/nginx.conf

root@hadoop100 conf# nginx -s reload

注意:这里的conf 需要改成自己nginx的路径。

相关推荐
一条破秋裤24 分钟前
Linux 线程创建:pthread_create 与基本回收
java·linux·运维
布吉岛的石头32 分钟前
Java 程序员第 49 阶段5:BERT 预训练目标 MLM+NSP 的工程含义
java·人工智能·深度学习·bert·transformer
摇滚侠1 小时前
《On Java 中文版 基础卷》阅读笔记 对象无处不在 03
java·笔记·python
二十雨辰2 小时前
[学成在线]-01项目背景
java
弈栈录3 小时前
Java AI 应用的异步化与高并发设计
java·后端·架构
落魄实习生3 小时前
Agent Scope Java 2.x 系列【2】 ReActAgent
java·开发语言
艸肅3 小时前
Ubuntu 安装 JDK (含手动安装)
java·ubuntu·jdk
m0_734172423 小时前
Python字典计数怎样处理首次出现的键
java
卓怡学长4 小时前
w204基于springbo旅行社签证代理服务系统
java·spring boot·spring·intellij-idea
泡海椒4 小时前
趋势分析报表:jquick-pdf折线图PDF生成实战
java·大数据·运维·服务器·前端·pdf