启动mongodb失败

Failed to start mongod.service:until not found

解决办法:

1创建配置文件:

sudo nano lc1 /etc/systemd/system/mongodb.service

2.在里面追加文本:

Unit

Description=High-performance, schema-free document-oriented databaselc2

After=network.target

表示 MongoDB 服务将在网络服务启动后启动。这是一种依赖关系,确保在网络服务准备就绪后再启动 MongoDB。

Service

User=mongodb #这里可能会启动失败,提示权限不足,改成root即可

ExecStart=/usr/bin/mongod --quietlc3 --config /etc/mongod.conf #这里注意一下路径,需要改成自己的配置文件路径

Install

WantedBy=multi-user.targetlc4

#系统进入了多用户模式,允许多个用户通过网络或本地登录系统并运行各种服务。

3.按ctrl+X退出

4.启动服务

sudo systemctl start mongodb

sudo systemctl status mongodb


lc1nano: 这是一个简单易用的命令行文本编辑器。在这里,它被用来编辑文件。

lc2描述了这个服务单元的用途,即高性能、无模式的文档型数据库。

lc3--quiet 表示以静默模式运行

lc4WantedBy=multi-user.target: 表示将 MongoDB 服务作为多用户模式的一部分进行启动。multi-user.target 是系统中多用户模式的一个目标。

相关推荐
IT古董29 分钟前
《FDE前沿部署工程师实战教程》33 - Enterprise AI Observability:从Agent Trace到全链路智能运维
数据库·人工智能
for_ever_love__32 分钟前
MySQL 主从复制讲透:binlog 原理、搭建步骤与读写分离
java·数据库·mysql·binlog·读写分离·原理·主从复制
Nturmoils5 小时前
GROUP BY 先别想当然,查汇总前把规则跑清楚
数据库
最笨的羊羊5 小时前
Oceanbase数据库系列之:向量数据库核心知识
数据库·oceanbase
fish_xk5 小时前
mysql中的表的约束
数据库·mysql
谢亮_vipxieliang5 小时前
Go Channel 高级模式——从底层原理到扇出扇入实战
java·数据库·golang
ggaofeng7 小时前
自己编写邮件服务器和客户端
数据库
java1234_小锋7 小时前
【技术专题】Mysql8 数据库 - Mysql8 添加,更新,删除数据
数据库·mysql
PaperData7 小时前
2015-2024年各省绿色贸易数据
数据库
小羊没烦恼!7 小时前
系统内部模块(子系统)之间的耦合以及模块(子系统)划分
java·开发语言·前端·数据库·算法·c#