计算机网络-ACL实验

一、NAT实验配置

NAT实验配置

通过基本ACL匹配VLAN 10网段,然后在出口设备NAT转换只要匹配到VLAN10地址则进行转换。

核心交换机

# 配置VLAN和默认路由,配置Trunk和Access接口
interface Vlanif10
 ip address 192.168.10.254 255.255.255.0
#
interface Vlanif20
 ip address 192.168.20.254 255.255.255.0
#
interface Vlanif30
 ip address 10.0.0.2 255.255.255.252

interface GigabitEthernet0/0/1
 port link-type access
 port default vlan 30
#
interface GigabitEthernet0/0/2
 port link-type access
 port default vlan 10
#
interface GigabitEthernet0/0/3
 port link-type access
 port default vlan 20

# 路由
ip route-static 0.0.0.0 0.0.0.0 10.0.0.1

出口路由器

# 配送路由和ACL以及NAT
acl number 2000  
 rule 10 permit source 192.168.10.0 0.0.0.255 

# 配置路由
ip route-static 0.0.0.0 0.0.0.0 12.1.1.2
ip route-static 192.168.10.0 255.255.255.0 10.0.0.2
ip route-static 192.168.20.0 255.255.255.0 10.0.0.2

# 配置接口地址,配置NAT与ACL匹配
interface GigabitEthernet0/0/0
 ip address 12.1.1.1 255.255.255.252 
 nat outbound 2000
#
interface GigabitEthernet0/0/1
 ip address 10.0.0.1 255.255.255.252 

中间路由器:

interface GigabitEthernet0/0/0
 ip address 12.1.1.2 255.255.255.252 
#
interface GigabitEthernet0/0/1
 ip address 23.1.1.2 255.255.255.252 
#
ip route-static 8.8.8.8 255.255.255.255 23.1.1.1

AR3:

interface GigabitEthernet0/0/1
 ip address 23.1.1.1 255.255.255.252 
#
interface LoopBack0
 ip address 8.8.8.8 255.255.255.255 
#
ip route-static 0.0.0.0 0.0.0.0 23.1.1.2

PC1:正常访问8.8.8.8

PC2:没有进行NAT转换,访问超时

二、ACL流量过滤实验

流量过滤

正常配置access接口,划分VLAN,创建高级ACL匹配流量,然后调用过滤策略。

# 创建高级ACL,先匹配拒绝,然后再允许其它的访问流量
acl number 3000
 rule 5 deny ip source 192.168.10.1 0 destination 192.168.20.2 0
 rule 10 permit ip source 192.168.10.1 0

# 接口配置
#
interface Vlanif10
 ip address 192.168.10.254 255.255.255.0
#
interface Vlanif20
 ip address 192.168.20.254 255.255.255.0
#
interface Vlanif30
 ip address 10.0.0.2 255.255.255.252
 
# 应用过滤策略
# 可以在全局应用流量过滤
traffic-filter inbound acl 3000

# 或者在入接口和出接口应用,在G0/0/2,入方向过滤或者在G0/0/4出方向过滤
interface GigabitEthernet0/0/2
 port link-type access
 port default vlan 10
 traffic-filter inbound acl 3000

#
interface GigabitEthernet0/0/4
 port link-type access
 port default vlan 20
 traffic-filter outbound acl 3000

结果:

本文由mdnice多平台发布

相关推荐
测试界萧萧4 小时前
外包干了4年,技术退步太明显了。。。。。
自动化测试·软件测试·功能测试·程序人生·面试·职场和发展
AI_小站1 天前
LLM——10个大型语言模型(LLM)常见面试题以及答案解析
人工智能·程序人生·语言模型·自然语言处理·大模型·llm·大模型面试
良技漫谈1 天前
Rust移动开发:Rust在iOS端集成使用介绍
后端·程序人生·ios·rust·objective-c·swift
我爱学Python!1 天前
AI Prompt如何帮你提升论文中的逻辑推理部分?
人工智能·程序人生·自然语言处理·chatgpt·llm·prompt·提示词
博纳软云_小程序一站服务平台2 天前
手边酒店多商户版V2源码独立部署_博纳软云
程序人生·微信小程序·小程序·微信公众平台
AI_小站2 天前
多模态大模型微调实践!PAI+LLaMA Factory搭建AI导游
人工智能·程序人生·语言模型·大模型·llm·产品经理·多模态大模型
良技漫谈2 天前
Rust移动开发:Rust在Android端集成使用介绍
android·程序人生·rust·kotlin·学习方法
AI_小站2 天前
【AI工作流】FastGPT - 深入解析FastGPT工作流编排:从基础到高级应用的全面指南
人工智能·程序人生·语言模型·大模型·llm·fastgpt·大模型应用
python_知世2 天前
AI时代:成为产品经理的核心路径
人工智能·深度学习·程序人生·自然语言处理·产品经理·计算机技术·大模型应用
提笔惊蚂蚁3 天前
java-web-day7-会话跟踪技术
java·开发语言·前端·程序人生