Acwing828模拟栈

题目

实现一个栈,栈初始为空,支持四种操作:

  1. push x -- 向栈顶插入一个数 x;
  2. pop -- 从栈顶弹出一个数;
  3. empty -- 判断栈是否为空;
  4. query -- 查询栈顶元素。

现在要对栈进行 M 个操作,其中的每个操作 33 和操作 44 都要输出相应的结果。

输入格式

第一行包含整数 M,表示操作次数。

接下来 M 行,每行包含一个操作命令,操作命令为 push xpopemptyquery 中的一种。

输出格式

对于每个 emptyquery 操作都要输出一个查询结果,每个结果占一行。

其中,empty 操作的查询结果为 YESNOquery 操作的查询结果为一个整数,表示栈顶元素的值。

数据范围

1≤M≤100000 1≤x≤10^9 所有操作保证合法。

输入样例:

perl 复制代码
10
push 5
query
push 6
pop
query
pop
empty
push 4
query
empty

输出样例:

objectivec 复制代码
5
5
YES
4
NO

代码

java 复制代码
import java.util.Scanner;

public class Main {
    static int idx = -1, N = 100010;
    static int[] stk = new int[N];
    static void push(int x) {
        stk[++ idx] = x;
    }
    static void pop() {
        idx --;
    }
    static String empty() {
        return idx == -1 ? "YES" : "NO";
    }
    static int query() {
        return stk[idx];
    }
    public static void main(String[] args) {
        Scanner in = new Scanner(System.in);
        int m = in.nextInt();
        while (m > 0) {
            m --;
            String s= in.next();
            if (s.equals("push")) {
                int x = in.nextInt();
                push(x);
            } else if (s.equals("query")) {
                System.out.println(query());
            } else if (s.equals("pop")) {
                pop();
            } else {
                System.out.println(empty());
            }
        }
    }
}
相关推荐
Estar.Lee1 小时前
查手机号归属地免费API接口教程
android·网络·后端·网络协议·tcp/ip·oneapi
2401_857610033 小时前
SpringBoot社团管理:安全与维护
spring boot·后端·安全
凌冰_3 小时前
IDEA2023 SpringBoot整合MyBatis(三)
spring boot·后端·mybatis
码农飞飞4 小时前
深入理解Rust的模式匹配
开发语言·后端·rust·模式匹配·解构·结构体和枚举
一个小坑货4 小时前
Rust 的简介
开发语言·后端·rust
monkey_meng4 小时前
【遵守孤儿规则的External trait pattern】
开发语言·后端·rust
Estar.Lee4 小时前
时间操作[计算时间差]免费API接口教程
android·网络·后端·网络协议·tcp/ip
新知图书5 小时前
Rust编程与项目实战-模块std::thread(之一)
开发语言·后端·rust
盛夏绽放5 小时前
Node.js 和 Socket.IO 实现实时通信
前端·后端·websocket·node.js
Ares-Wang6 小时前
Asp.net Core Hosted Service(托管服务) Timer (定时任务)
后端·asp.net