命令行启动mongodb服务器的问题及解决方案 -- Unrecognized option: storage.journal

目录

mongodb命令行启动问题 -- Unrecognized option: storage.journal

同样是格式出问题的问题分析和解决方式:命令行启动 mongodb 服务器问题:Error parsing YAML config file: yaml-cpp: errorxxx: illegal map value

问题日志:

C:\Users\JH>mongod.exe --config "E:\install\mongodb\mongodb-4.2.25\mongod.conf"
Unrecognized option: storage.journal

try 'mongod.exe --help' for more information

问题截图:

问题来源:

我创建 mongod.conf 配置文件,然后添加配置信息,如下,
然后再用命令启动mongodb服务器时指定 mongod.conf 配置文件,就出现该问题

添加配置信息

根据自己创建的配置文件,创建文件夹

java 复制代码
# mongod.conf
# 配置与存储有关的信息
storage:
  dbPath: E:\install\mongodb\mongodb-4.2.25\data\db
  journal:
    enabled: true

# 指定与日志有关的信息,把日志输出到file文件夹
systemLog:
  destination: file
  quiet: true
  logAppend: false
  path: E:\install\mongodb\mongodb-4.2.25\logs\mongod.log
#配置与网络有关的信息, mongodb 默认端口 27017
net:
  port: 27017
  bindIp: 0.0.0.0

错误原因:

无法识别配置文件的 storage.journal

后面发现是配置文件的缩进格式出问题

解决方式:

因为 mongodb 3.0 之后配置文件采用YAML格式,所以在使用 : 表示时,开头使用空格作为缩进。

相关推荐
程序猿乐锅3 小时前
【黑马点评 | 第八篇】Redisson分布式锁
java·数据库·spring boot·redis·分布式·spring·缓存
Leo.yuan3 小时前
2026年本地化Data Agent优质厂商盘点:哪些产品更适合企业生产环境
大数据·数据库·人工智能
做运维的阿瑞3 小时前
数据库增删改的安全写法
数据库·sql·mysql
程序边界4 小时前
迁移评估不再拍脑袋,这个数据迁移工具的量化报告把我救了(上)
数据库
阿狗童鞋4 小时前
Redis实战指南
数据库·redis·缓存
lupai5 小时前
维修保养记录精准版 API 对接实战指南
数据库·python
2601_952196368 小时前
计算机科学与技术专业应届生投商业分析岗,需要哪些额外能力?
数据库·oracle
皮皮学姐分享-ppx8 小时前
地级市、省级人才政策强度测算(2000-2025)
大数据·数据库·人工智能·百度·高考
晚安日记wanna8 小时前
大厂禁 JOIN 的真正原因,拆到第四层才清楚
数据库·后端·面试
java1234_小锋9 小时前
Redis 宣布正式接入 AI
数据库·人工智能·redis