命令行启动mongodb服务器的问题及解决方案 -- Unrecognized option: storage.journal

目录

mongodb命令行启动问题 -- Unrecognized option: storage.journal

同样是格式出问题的问题分析和解决方式:命令行启动 mongodb 服务器问题:Error parsing YAML config file: yaml-cpp: errorxxx: illegal map value

问题日志:

C:\Users\JH>mongod.exe --config "E:\install\mongodb\mongodb-4.2.25\mongod.conf"
Unrecognized option: storage.journal

try 'mongod.exe --help' for more information

问题截图:

问题来源:

我创建 mongod.conf 配置文件,然后添加配置信息,如下,
然后再用命令启动mongodb服务器时指定 mongod.conf 配置文件,就出现该问题

添加配置信息

根据自己创建的配置文件,创建文件夹

java 复制代码
# mongod.conf
# 配置与存储有关的信息
storage:
  dbPath: E:\install\mongodb\mongodb-4.2.25\data\db
  journal:
    enabled: true

# 指定与日志有关的信息,把日志输出到file文件夹
systemLog:
  destination: file
  quiet: true
  logAppend: false
  path: E:\install\mongodb\mongodb-4.2.25\logs\mongod.log
#配置与网络有关的信息, mongodb 默认端口 27017
net:
  port: 27017
  bindIp: 0.0.0.0

错误原因:

无法识别配置文件的 storage.journal

后面发现是配置文件的缩进格式出问题

解决方式:

因为 mongodb 3.0 之后配置文件采用YAML格式,所以在使用 : 表示时,开头使用空格作为缩进。

相关推荐
麦壳饼1 分钟前
SonnetDB SQL 分页查询:LIMIT/OFFSET 与 FETCH 语法
数据库·sonnetdb
Gauss松鼠会6 分钟前
【GaussDB】破除gaussdb ugin索引支持中文模糊查询的迷思-字符序
java·运维·服务器·网络·数据库·gaussdb·经验总结
l1t30 分钟前
DeepSeek总结的PostgreSQL因选择而宽松,因偶然而永久
数据库·postgresql
Nturmoils36 分钟前
数据同步中断后,KFS 怎么把链路接回来
数据库
leisoo80971 小时前
股票筹码分布怎么用获利比例成本区间与集中度实战 IG50免费开源股票数据API接口
开发语言·jvm·数据库·python·开源
字节跳动的猫1 小时前
LikeShop 商品评价体系二开:追评、晒图审核与评价标签筛选功能开发
运维·数据结构·数据库
行业研究员2 小时前
Agent Memory降低Token消耗原理解析
数据库·人工智能·oracle·腾讯云·智能体
yixun_gdas2 小时前
企业网站内容巡查的价值与方法:企业官网的合规与形象管理
数据库·内容运营
见闻小天地2 小时前
空调机房赛莱默B&G冷冻泵/冷却泵的核心技术特性分析
大数据·运维·数据库
辛迪聊物业数字化2 小时前
物业管理系统新手部署与实操指南
数据库·物联网·架构·系统架构