命令行启动mongodb服务器的问题及解决方案 -- Unrecognized option: storage.journal

目录

mongodb命令行启动问题 -- Unrecognized option: storage.journal

同样是格式出问题的问题分析和解决方式:命令行启动 mongodb 服务器问题:Error parsing YAML config file: yaml-cpp: errorxxx: illegal map value

问题日志:

C:\Users\JH>mongod.exe --config "E:\install\mongodb\mongodb-4.2.25\mongod.conf"
Unrecognized option: storage.journal

try 'mongod.exe --help' for more information

问题截图:

问题来源:

我创建 mongod.conf 配置文件,然后添加配置信息,如下,
然后再用命令启动mongodb服务器时指定 mongod.conf 配置文件,就出现该问题

添加配置信息

根据自己创建的配置文件,创建文件夹

java 复制代码
# mongod.conf
# 配置与存储有关的信息
storage:
  dbPath: E:\install\mongodb\mongodb-4.2.25\data\db
  journal:
    enabled: true

# 指定与日志有关的信息,把日志输出到file文件夹
systemLog:
  destination: file
  quiet: true
  logAppend: false
  path: E:\install\mongodb\mongodb-4.2.25\logs\mongod.log
#配置与网络有关的信息, mongodb 默认端口 27017
net:
  port: 27017
  bindIp: 0.0.0.0

错误原因:

无法识别配置文件的 storage.journal

后面发现是配置文件的缩进格式出问题

解决方式:

因为 mongodb 3.0 之后配置文件采用YAML格式,所以在使用 : 表示时,开头使用空格作为缩进。

相关推荐
ao-weilai4 分钟前
MySQL数据库:用户管理
数据库·mysql·adb
冰暮流星34 分钟前
sql之is not null运算符
数据库·sql·oracle
冰暮流星42 分钟前
sql之is null 运算符
java·数据库·sql
mengge.cloud1 小时前
Redis
运维·服务器·数据库·redis·缓存·云计算
码流子1 小时前
02-易迁信创兼容引擎
大数据·数据库·python
欣栀♡1 小时前
Redis 缓存穿透、击穿、雪崩,背出定义只是及格线
数据库·redis·缓存
杨云龙UP1 小时前
PostgreSQL 四种常见部署模式快速理解:单实例、流复制、repmgr、Patroni
linux·运维·数据库·postgresql·流复制·高可用ha
l1t1 小时前
DeepSeek总结的PostgreSQL 19回退会一直继续,直到士气好转
数据库·postgresql
ao-weilai1 小时前
MySQL数据库:C语言连接MySQL教程
c语言·数据库·mysql
盛世宏博智慧档案1 小时前
档案库房温湿度采集数据存储方案:时序数据库选型与存储优化
数据库·时序数据库