命令行启动mongodb服务器的问题及解决方案 -- Unrecognized option: storage.journal

目录

mongodb命令行启动问题 -- Unrecognized option: storage.journal

同样是格式出问题的问题分析和解决方式:命令行启动 mongodb 服务器问题:Error parsing YAML config file: yaml-cpp: errorxxx: illegal map value

问题日志:

C:\Users\JH>mongod.exe --config "E:\install\mongodb\mongodb-4.2.25\mongod.conf"
Unrecognized option: storage.journal

try 'mongod.exe --help' for more information

问题截图:

问题来源:

我创建 mongod.conf 配置文件,然后添加配置信息,如下,
然后再用命令启动mongodb服务器时指定 mongod.conf 配置文件,就出现该问题

添加配置信息

根据自己创建的配置文件,创建文件夹

java 复制代码
# mongod.conf
# 配置与存储有关的信息
storage:
  dbPath: E:\install\mongodb\mongodb-4.2.25\data\db
  journal:
    enabled: true

# 指定与日志有关的信息,把日志输出到file文件夹
systemLog:
  destination: file
  quiet: true
  logAppend: false
  path: E:\install\mongodb\mongodb-4.2.25\logs\mongod.log
#配置与网络有关的信息, mongodb 默认端口 27017
net:
  port: 27017
  bindIp: 0.0.0.0

错误原因:

无法识别配置文件的 storage.journal

后面发现是配置文件的缩进格式出问题

解决方式:

因为 mongodb 3.0 之后配置文件采用YAML格式,所以在使用 : 表示时,开头使用空格作为缩进。

相关推荐
笨小孩@GF 知行合一6 小时前
易语言-高级应用
数据库·编程·易语言·中文编程
KaiwuDB7 小时前
KaiwuDB 运维实战04:DRBD + KaiwuDB——物联网场景下的低成本数据库高可用方案
运维·数据库·物联网·时序数据库·kaiwudb·aiot·多模数据库
夜雪一千8 小时前
MySQL外键彻底入门:是什么、怎么用、什么时候不该用
数据库·mysql
qq_334466868 小时前
删除SSMS的历史登录记录
数据库·sql
zl_dfq9 小时前
Redis 之 【常见面试题总结】(从数据类型到高可用、缓存一致性全解析)
数据库·redis
龙亘川9 小时前
铭记英烈守初心,数字强基促服务:亘川智城退役军人服务系统的实践与价值
java·数据库·人工智能
kv11010 小时前
Android studio国内开发有关
java·数据库·android studio
哭泣方源炼蛊10 小时前
正则表达式c++内容汇集
数据库·c++·mysql·正则表达式
余槐i10 小时前
EXPLAIN 显示走了索引查询仍慢:回表与选择性在 500 万行表上拉开 10 倍耗时
数据库·postgresql·性能优化·vacuum·explain