命令行启动mongodb服务器的问题及解决方案 -- Unrecognized option: storage.journal

目录

mongodb命令行启动问题 -- Unrecognized option: storage.journal

同样是格式出问题的问题分析和解决方式:命令行启动 mongodb 服务器问题:Error parsing YAML config file: yaml-cpp: errorxxx: illegal map value

问题日志:

C:\Users\JH>mongod.exe --config "E:\install\mongodb\mongodb-4.2.25\mongod.conf"
Unrecognized option: storage.journal

try 'mongod.exe --help' for more information

问题截图:

问题来源:

我创建 mongod.conf 配置文件,然后添加配置信息,如下,
然后再用命令启动mongodb服务器时指定 mongod.conf 配置文件,就出现该问题

添加配置信息

根据自己创建的配置文件,创建文件夹

java 复制代码
# mongod.conf
# 配置与存储有关的信息
storage:
  dbPath: E:\install\mongodb\mongodb-4.2.25\data\db
  journal:
    enabled: true

# 指定与日志有关的信息,把日志输出到file文件夹
systemLog:
  destination: file
  quiet: true
  logAppend: false
  path: E:\install\mongodb\mongodb-4.2.25\logs\mongod.log
#配置与网络有关的信息, mongodb 默认端口 27017
net:
  port: 27017
  bindIp: 0.0.0.0

错误原因:

无法识别配置文件的 storage.journal

后面发现是配置文件的缩进格式出问题

解决方式:

因为 mongodb 3.0 之后配置文件采用YAML格式,所以在使用 : 表示时,开头使用空格作为缩进。

相关推荐
这个DBA有点耶1 天前
MVCC深入:Read View、版本链与快照读——InnoDB并发控制的内核
数据库·mysql·架构
DBA_G1 天前
从地面到云霄:GBase数据库在民航三大场景的落地实践
数据库
自由能燃气设备1 天前
商用全预混低氮冷凝锅炉免费方案vs付费方案对比+选型避坑指南
大数据·数据库·人工智能
科创致远1 天前
科创致远 ESOP 系统核心效能与实战价值展示
大数据·数据库·人工智能·精益工程
2601_962218611 天前
万象生鲜系统称重自动多退少补算法解决生鲜非标品痛点
大数据·数据库·人工智能·python·算法
张洛闻Eren1 天前
k8s云原生【第十课】:水平 Pod 自动扩缩容
运维·数据库·云原生·kubernetes·github
于平安1 天前
MySQL-触发器
数据库·mysql
白远山1 天前
上海24小时自助健身房解决方案实战指南与经验分享
java·数据库·架构·需求分析
Omics Pro1 天前
斯坦福Nature+Science|广义虚拟细胞基础大模型
数据库·人工智能·算法·机器学习·自然语言处理
2603_965148111 天前
AI+API选品:下一代智能商务助手雏形已现
java·大数据·数据库·人工智能·数据挖掘