目录
[1. 题目描述](#1. 题目描述)
[2. 思路分析](#2. 思路分析)
[3. 代码实现](#3. 代码实现)
原题链接:https://pintia.cn/problem-sets/994805046380707840/exam/problems/1518582383141380096?type=7&page=1t
1. 题目描述
新浪微博上有人发了某老板的作息时间表,表示其每天 4:30 就起床了。但立刻有眼尖的网友问:这时间表不完整啊,早上九点到下午一点干啥了?
本题就请你编写程序,检查任意一张时间表,找出其中没写出来的时间段。
输入格式:
输入第一行给出一个正整数 N,为作息表上列出的时间段的个数。随后 N 行,每行给出一个时间段,格式为:
hh:mm:ss - hh:mm:ss
其中 hh
、mm
、ss
分别是两位数表示的小时、分钟、秒。第一个时间是开始时间,第二个是结束时间。题目保证所有时间都在一天之内(即从 00:00:00 到 23:59:59);每个区间间隔至少 1 秒;并且任意两个给出的时间区间最多只在一个端点有重合,没有区间重叠的情况。
输出格式:
按照时间顺序列出时间表中没有出现的区间,每个区间占一行,格式与输入相同。题目保证至少存在一个区间需要输出。
输入样例:
8
13:00:00 - 18:00:00
00:00:00 - 01:00:05
08:00:00 - 09:00:00
07:10:59 - 08:00:00
01:00:05 - 04:30:00
06:30:00 - 07:10:58
05:30:00 - 06:30:00
18:00:00 - 19:00:00
输出样例:
04:30:00 - 05:30:00
07:10:58 - 07:10:59
09:00:00 - 13:00:00
19:00:00 - 23:59:59
2. 思路分析
刚学到的新思路。万万没想到这道题可以用结构体排序~~~
我们发现从00:00:00 到 23:59:59,所有时间点的字典序在不断变大,也就是说时间点是按照字典序升序排列的。
所以我们不妨将所有给定的时间段按照字典序排序,对于区间si和s i-1,如果si的左端点和s i-1的右端点不相等,就说明中间存在时间空段,直接输出即可。
但是需要注意:要特判两种情况,因为可能起始时间点不是00:00:00,还有就是终止时间不是23:59:59
具体实现就是用一个结构体来存储每个时间段的起始时间(l)和终止时间 (r),l和r用string字符串类型定义。按照起始时间l的大小进行升序排序写个cmp函数。
3. 代码实现
cpp
#define _CRT_SECURE_NO_WARNINGS 1
#include<bits/stdc++.h>
using namespace std;
#define ll long long
#define endl '\n'
const int N = 2e5 + 10;
struct node {
string l, r;
}s[N];
bool cmp(node x, node y) {
return x.l < y.l;
}
int main() {
ios::sync_with_stdio(0), cin.tie(0), cout.tie(0);
int n; cin >> n;
char c;
for (int i = 1; i <= n; i++) {
cin >> s[i].l >> c >> s[i].r;
}
string st = "00:00:00";
string ed = "23:59:59";
sort(s + 1, s + n + 1, cmp);
if (s[1].l != st) {
cout << st << " - " << s[1].l << endl;
}
for (int i = 2; i <= n; i++) {
if (s[i].l != s[i - 1].r) {
cout << s[i-1].r << " - " << s[i].l << endl;
}
}
if (s[n].r != ed) {
cout << s[n].r << " - " << ed << endl;
}
return 0;
}