Centos7.9环境下keepalived结合nginx实现负载均衡的高可用(亲测版)

目录

一、负载均衡高可用解释

二、安装

三、Nginx检查脚本创建

四、修改keepalived配置文件


一、负载均衡高可用解释

nginx 作为负载均衡器,所有请求都到了nginx,如果nginx服务器宕机后端web服务将无法提供服务,影响严重。这样nginx作为负载均衡器就没有实际意义。所以为了防止Nginx挂了导致整个服务无法使用的灾难发生,我们这里可以考虑使用Keepalived+Nginx集群实现高可用

二、安装

nginx安装参考:Centos7.9环境下离线安装开源版Nginx(亲测版)_centos7.9离线安装nginx-CSDN博客

keepalived安装参考:Centos7.9环境下安装Keepalived(亲测版)-CSDN博客

三、Nginx检查脚本创建

在 /usr/local/nginx目录下创建nginx_check.sh文件,并编辑内容

c 复制代码
vi /usr/local/nginx/nginx_check.sh
#编辑内容如下

#!/bin/bash
A=`ps -C nginx --no-header |wc -l`
if [ $A -eq 0 ];then
     /usr/local/nginx/sbin/nginx
     sleep 2
    if [ `ps -C nginx --no-header |wc -l` -eq 0 ];then
      killall keepalived
    fi
fi

确保给这个脚本执行权限

chmod +x /usr/local/nginx/nginx_check.sh

四、修改keepalived配置文件

! Configuration File for keepalived

global_defs {

router_id lb132

}

vrrp_script chk_nginx {

script "/usr/local/nginx/nginx_check.sh"

interval 2

weight -30

}

vrrp_instance VI_1 {

state MASTER

nopreempt

interface ens33

virtual_router_id 51

priority 100

advert_int 1

authentication {

auth_type PASS

auth_pass 1111

}

track_script {

chk_nginx

}

virtual_ipaddress {

192.168.75.131

}

}

按照以上配置,配置其他服务节点并重启keepalived 服务

相关推荐
chicheese4 分钟前
Linux 面试速查表:从初级到高级,附高频场景答题模板
linux·运维
Linux-lucky32 分钟前
32-38-Linux学习之旅之MySQL综合
linux·运维·学习·mysql·ubuntu
智能运维指南1 小时前
2026年ITSM系统怎么选?四款主流方案与五维评估模型
运维·itsm·嘉为蓝鲸
我命由我123452 小时前
Git 推送报错:error: src refspec main does not match any
运维·git·gitee·github·运维开发·学习方法·版本控制
骇客野人2 小时前
测试环境MySQL迁移Vastbase(海量数据库)完整改造与落地实施方案
运维·服务器
迪康Defender2 小时前
终端安全实战:如何高效解决企业U盘泄密与管控难题
运维·网络·安全·web安全·终端安全管理
zly35003 小时前
VMware Converter Standalone 物理机转化为虚拟机后源1硬盘变成了2个硬盘(2个硬盘文件)虚拟机无法启动。
linux·运维·服务器
智能运维指南3 小时前
2026 企业智能运维平台选型:私有化、信创、全链路打通该怎么权衡?
运维·嘉为蓝鲸·aiops平台·一体化运维平台
春天花会开1313 小时前
Supabase 自部署 Edge Functions 超时从 60s 延长到 360s 完整复盘
运维·云原生
当下新鲜事3 小时前
脱硫脱硝塔动力系统科普:四方DL500变频器工作原理解析
大数据·运维·物联网·业界资讯