【openssl s_server error】system library:BIO_bind:Address in use

问题:

在容器中执行openssl s_server -cert dilithium3_srv.crt -key dilithium3_srv.key -www -tls1_3 -groups kyber768:frodo640shake提示错误:

Using default temp DH parameters

487BAC890E7F0000:error:80000062:system library:BIO_bind:Address in use:crypto/bio/bio_sock2.c:240:calling bind()

487BAC890E7F0000:error:10000075:BIO routines:BIO_bind:unable to bind socket:crypto/bio/bio_sock2.c:242:

0 items in the session cache

0 client connects (SSL_connect())

0 client renegotiates (SSL_connect())

0 client connects that finished

0 server accepts (SSL_accept())

0 server renegotiates (SSL_accept())

0 server accepts that finished

0 session cache hits

0 session cache misses

0 session cache timeouts

0 callback cache hits

0 cache full overflows (128 allowed)

原因:

在这种情况下,它表示服务器已经使用了相同的端口------如果在没有参数的情况下启动docker,该image会自动启动启用QSC的TLS服务器。可以通过将参数传递给docker调用来避免这种情况。

解决方法:

命令行启动docker,docker run -it openquantumsafe/oqs-ossl3 sh

相关推荐
光依旧18 小时前
PageIndex没翻车,翻车的是我的解析器
docker·langchain·大模型·向量数据库·pdf解析·rag·pageindex
谢亮_vipxieliang20 小时前
容器排障实战手册:从日志到内核的分层排障
docker·云原生·容器·eureka
梦想不只是梦与想1 天前
Docker 常用命令
docker
小白的码BUG之路1 天前
Docker -- 构建ruoyi-gateway镜像
docker·容器·gateway
小白的码BUG之路1 天前
Docker -- 构建ruoyi-system镜像
运维·docker·容器
小白的码BUG之路1 天前
Docker -- 构建redis镜像
运维·docker·容器
江湖有缘1 天前
Docker实战 | 使用Docker部署EspoCRM开源客户关系管理平台
docker·容器·开源
小白的码BUG之路1 天前
Docker -- 构建ruoyi-auth镜像
运维·docker·容器
小白的码BUG之路2 天前
Docker -- 构建nacos镜像
运维·docker·容器
天衍四九-2 天前
【无标题】
前端·spring boot·mysql·nginx·docker