nginx普通用户使用80端口启动失败 [emerg] bind() to 0.0.0.0:80 failed (13: Permission denied)

场景

nginx普通用户使用80端口启动失败

复制代码
bind() to 0.0.0.0:80 failed (13: Permission denied)

解决

bash 复制代码
cd /usr/local/nginx/sbin/ 
chown root nginx
chmod u+s nginx

命令解释:

bash 复制代码
chown root nginx:将 nginx 文件的所有者设置为 root 用户。
chmod u+s nginx:为 nginx 文件设置 SUID 位,这意味着无论谁运行这个文件,它都会以文件所有者(即 root 用户)的身份运行。
相关推荐
IT_陈寒2 分钟前
Redis集群切换主节点时,服务竟然全员掉线
前端·人工智能·后端
wdfk_prog5 分钟前
Wi-Fi Direct 源码分析(09):从 P2P_CONNECT 到 GO Negotiation 完成
运维·服务器·ubuntu·golang·asp.net·p2p·wifi-direct
wangbing11257 分钟前
开发指南147-WebSocket-前端
前端·websocket·网络协议
吴声子夜歌9 分钟前
Nginx应用与运维——Nginx Web服务应用实战(伪流媒体服务器的搭建)
运维·前端·nginx
打工仔折腾 AI10 分钟前
多台服务器日志分散难查?用Promtail+Loki+Grafana搭建集中检索平台
服务器·人工智能·后端·python·性能优化·django·grafana
ss27333 分钟前
AI全栈实战 | 2.4-01 Node 与前端工程化:前端为什么离不开 Node,它不只是构建工具的宿主
前端
aixingpan34 分钟前
aixingpan.cn API开发文档:api_docs_transit接口指南
前端·php
鬓戈38 分钟前
Volta:解决 nvm「不能同时存在多个 Node 版本」的痛点
前端
吴声子夜歌41 分钟前
Nginx应用与运维——Nginx Web服务应用实战(HTTP增强协议服务器的搭建)
运维·前端·nginx
扶风ff9 小时前
新品知识更新太快?用练题簿在线刷题,安排企业培训的小测与复盘
前端·学习·小程序