nginx普通用户使用80端口启动失败 [emerg] bind() to 0.0.0.0:80 failed (13: Permission denied)

场景

nginx普通用户使用80端口启动失败

复制代码
bind() to 0.0.0.0:80 failed (13: Permission denied)

解决

bash 复制代码
cd /usr/local/nginx/sbin/ 
chown root nginx
chmod u+s nginx

命令解释:

bash 复制代码
chown root nginx:将 nginx 文件的所有者设置为 root 用户。
chmod u+s nginx:为 nginx 文件设置 SUID 位,这意味着无论谁运行这个文件,它都会以文件所有者(即 root 用户)的身份运行。
相关推荐
风骏时光牛马2 小时前
大模型底层架构与推理流程AI源码深度剖析
前端
等我调个Bug2 小时前
Linux基本指令
linux·服务器
_upupup11 小时前
Linux的调试工具——gdb/cgdb
linux·服务器
百度一下吧11 小时前
Nginx 使用手册:从安装配置到实战部署
运维·nginx
Setsuna_F_Seiei11 小时前
前端转型 Agent 开发 06 之 Agent Memory 记忆系统(让 Agent 更智能,更懂你)
前端·agent·ai编程
zhangzeyuaaa11 小时前
Ruby 多线程、GVL(GIL)与 Mutex 完全指南
开发语言·前端·ruby
默_笙12 小时前
🌊 向量库和 ES 都查不出"关系",我只好给奶茶建了一张人脉网
前端·javascript
优选资讯12 小时前
标签打印软件怎么对接 Excel 数据
前端·excel
一个风轻云淡13 小时前
GCC 和 GDB命令简单解读
java·linux·前端
u01110267514 小时前
图片处理接口如何统一错误信息 前端提示与后端错误码设计
前端·状态模式