-bash: apt-get: command not found -bash: yum: command not found

  1. 现象:

1.1. 容器内使用apt-get, yum 提示命令未找到

1.2. dockerfile制作镜像时候,使用apt-get, yum同样报此错误。

2.原因:

2.1. linux 分为:

  1. RedHat系列: Redhat、Centos、Fedora等

  2. Debian系列:Debian、Ubuntu等

2.2. RedHat系列的包管理工具是yum

2.3. Debian系列的包管理工具是apt-get

docker 中经常使用的系统,其实还有一个alpine系统,使用的为apk包管理工具,安装命令为apk add xxx

3.Alpine介绍:

3.1Alpine Linux 是一个轻型 Linux 发行版,优点如下:

  1. **小巧:**基于Musl libc 和 Busybox,和 Busybox 一样小巧,最小的 Docker 镜像只有 5MB;

  2. **安全:**面向安全的轻量发行版;

  3. **简单:**提供 APK 包管理工具,软件的搜索、安装、删除、升级都非常方便;

  4. **适合容器使用:**由于小巧、功能完备,非常适合作为容器的基础镜像;

3.2 重要:

基于musl libc和BusyBox

如果按照openjdk, 那么需要装glibc库

  1. 查看系统命令:

查看红帽系,还是debian系

cat /proc/version

查看系统版本,查看是否为alpine系统

cat /etc/issue

相关推荐
Apipi*6 分钟前
30天速通Linux 第六章信号及信号处理
linux·运维·信号处理
天启HTTP1 小时前
爬虫防封核心原理:IP轮换机制与风控规避逻辑
linux·服务器·网络·爬虫·tcp/ip
广州浮点FLOATLIC3 小时前
许可证服务器迁移后软件打不开:研发 IT 怎样定位连接问题
linux·服务器·数据库
BLUcoding4 小时前
接口服务公网超时排查记录:SecureRandom 阻塞问题分析与解决
java·linux·springboot·aes·securerandom
AIgorithmGEEK4 小时前
[Linux]从手写报头到内核套路:序列化、反序列化与自定义协议全链路
linux·运维·服务器·网络·序列化·反序列化
Nil2084 小时前
leetcode 139单词拆分
linux·运维·服务器
Starry-sky(jing)4 小时前
BUG: unable to handle kernel paging request 完整排查:dmesg 四要素与三路定罪
linux·运维·服务器·内核·排障
mounter6254 小时前
从硬件互连到操作系统变革:CXL 技术演进与 Linux 内核工程挑战
linux·运维·服务器
xh didida5 小时前
Linux -- 基础IO
linux·服务器·开发语言·c++
zly35006 小时前
centos7 mount设备挂载 /dev/sda1/硬盘挂载
linux·运维·服务器