InnoDB: corruption in the InnoDB tablespace

磁盘空间满和断电都可能导致mysql无法启动,报错如下:

复制代码
InnoDB: corruption in the InnoDB tablespace. Please refer to
InnoDB: http://dev.mysql.com/doc/refman/8.0/en/forcing-innodb-recovery.html
InnoDB: about forcing recovery.
20241031 10:54:24 [ERROR] mysqld got signal 6 ;
This could be because you hit a bug. It is also possible that this binary
or one of the libraries it was linked against is corrupt, improperly built,
or misconfigured. This error can also be caused by malfunctioning hardware.
To report this bug, see http://kb.askmonty.org/en/reporting-bugs
We will try our best to scrape up some info that will hopefully help
diagnose the problem, but since we have already crashed,
something is definitely wrong and this may fail.

处理步骤:

添加innodb_force_recovery参数的my.cnf强制启动-->导出全部数据库-->去掉innodb_force_recovery参数的my.cnf-->删除mysql数据目录重新初始化-->导入数据sql。

处理过程:

docker ps检查运行的容器

1.此次my.cnf设置innodb_force_recovery = 3后成功启动(正常从1-6按顺序尝试)

2.导出全部数据库:建议写成脚本后台跑

复制代码
docker exec mysql-master-dev mysqldump  -h127.0.0.1 -uroot -pxxx  --log-error=/var/lib/mysql/db_bak_dby_log.err --ssl-mode=DISABLED  --all-databases >./all.sql

3.关闭容器:

docker-compose -f docker-compose.yml down

4.进入data数据目录,删除所有文件rm -rf *,然后启动容器,自动重新初始化:

docker-compose -f docker-compose.yml up -d

5.进入容器检查mysql:

docker exec -it mysql-master-dev /bin/bash

root@14f086133dda:/# mysql -h127.0.0.1 -uroot -pxxx

mysql: Warning Using a password on the command line interface can be insecure.

Welcome to the MySQL monitor. Commands end with ; or \g.

Your MySQL connection id is 13

Server version: 8.0.26 MySQL Community Server - GPL

Copyright (c) 2000, 2021, Oracle and/or its affiliates.

Oracle is a registered trademark of Oracle Corporation and/or its

affiliates. Other names may be trademarks of their respective

owners.

Type 'help;' or '\h' for help. Type '\c' to clear the current input statement.

mysql> show databases;

+--------------------+

| Database |

+--------------------+

| |没有新库。

如果导出的脚本没有创建库命令,则先把库建上。create database db;

6.导入数据:使用脚本后台方式,避免网络超时断开。

root@localhost bak# cat db.sh

docker exec -i mysql-master-dev mysql -h127.0.0.1 -uroot -pxxx < all.sql

root@localhost bak# chmod +x db.sh

root@localhost bak# nohup ./db.sh > ./dby.log &

查看导入进度:

pidstat -d 1可查看io运行的情况。

相关参考:

突发!某大厂机房掉电,MySQL数据库无法启动,紧急恢复过程...

Mysql异常停止之后的恢复操作

记一次断电导致的mysql数据恢复问题

相关推荐
小马同学-3 小时前
mysql数据库原理
数据库·mysql
布莱克6056 小时前
MySQL 增删改查(CRUD)语法详解
数据库·mysql·增删改查
rm -rf * && haha.sh8 小时前
【Linux】Rocky 9.8 操作系统磁盘分区与MySQL数据目录迁移
linux·运维·mysql
ao-weilai9 小时前
MySQL数据库:表操作
数据库·mysql·adb
宵时待雨10 小时前
MySQL数据库1:数据库基础
服务器·数据库·mysql
做运维的阿瑞10 小时前
一个 NULL 让整列姓名消失?MySQL 字符串与日期函数复盘
数据库·sql·mysql
Dxy123931021611 小时前
MySQL 条件注释语法
数据库·mysql
FYKJ_201012 小时前
SSM校园互助与闲置交易平台62145-计算机课程设计、毕业设计
java·spring boot·python·mysql·架构·spark·课程设计
傲世仙尊12 小时前
从HTTPS到MySQL-会话保持的攻防与数据库的真面目
数据库·mysql·https
jyOverQ12 小时前
MySQL 崩溃以后怎么恢复数据?redo log、undo log 与 Crash Recovery
数据库·mysql