docker对nginx.conf进行修改后页面无变化或页面报错

可能是因为没有重启nginx容器

可以执行

docker restart nginx

重启nginx试试

引入了其他的配置文件

本人安装的是docker默认的nginx,自带了一个default.conf的配置文件,并且在nginx.conf中还引入了这个文件,后面我还对nginx.conf添加了一个server并且端口号都是80,在打印docker logs nginx时发现警告(80端口冲突:nginx: warn conflicting server name "localhost" on 0.0.0.0:80, ignored)

可以把引入文件哪一行注释起来(下面那一行,前面加个#就可以注释)

include /etc/nginx/conf.d/*.conf;

再尝试重新启动

目录结构错误

由于docker安装镜像是单独的文件系统,即使你挂载了数据卷(数据卷只是同步数据的作用),路径也是相对于docker那个文件系统的,我把一个html目录放到了/路径下,并且nginx.conf中的location是这样写的

bash 复制代码
    location / {
        root  /www/www;
        index  index.html index.htm;
    }

这样就导致nginx不能在自己的目录下找到对应的路径(因为我这个路径是基于Liunx的嘛)

可以将自己的html目录放到数据卷的html目录下

bash 复制代码
mv 外部的html路径 数据卷挂载的html路径

# 例如我就是执行了下面的指令
# mv /www /root/nginx/html

然后再将nginx.conf的location改成这样

bash 复制代码
	location / {
		root  /usr/share/nginx/html/www/www;
		index  index.html index.htm;
   	 }

/usr/share/nginx/html是docker中nginx的目录,这个目录可以执行

bash 复制代码
docker exec -it nginx容器名 bash

find -name html

找到

使用了其他端口

因为执行docker run 指令时-p只映射了80:80端口,所以其他端口无法访问到,docker似乎不能后添加端口映射,只能删除容器后(需要先停止容器)重新docker run创建容器,再创建容器的时候多指定一个-p参数(不会安装的可以看这个Docker安装Nginx​​​​​​​)

相关推荐
还是大剑师兰特5 天前
解决nginx错误:http://localhost:7000正常,http://localhost:7000/map 报错404
nginx·大剑师
分布式存储与RustFS5 天前
MinIO 官方 Docker 镜像被移除:依赖它的项目该怎么办
docker·云原生·devops·对象存储·minio·分布式存储
玉&心5 天前
通过Arthas在线诊断K8S中的内存及JVM等使用情况
docker·k8s·arthas
xing-xing5 天前
Docker容器中Nginx站点根目录网页配置访问
nginx·docker
guo_wen_qiang5 天前
上传本地镜像到harbor中
docker·容器·持续部署
羑悻的小杀马特5 天前
Dockerfile 全景指南:从入门编写dockerfile到生产环境镜像优化实战,一步步带你从啃透制作指令到镜像制作落地!
docker·dockerfile·镜像制作
BianHuanShiZhe5 天前
docker常见命令
docker
正经教主5 天前
【FDE系列】阶段2:Day 43:Docker Compose — 多容器一键编排
人工智能·docker·fde
PC2005-cloud5 天前
Nginx 防盗链配置实战:用 referer 模块保护网站静态资源
nginx
忆~遂愿5 天前
本地片库怎么在外面打开?Plex + cpolar 搭一套可远程访问的私人影音库
docker·容器