windows server 2019 启动 nginx 报错

环境 :windows server 2019 ,nginx-1.19.7

背景:

  1. 自己经常用这个 nginx 包作为 web 服务器。今天发现 部署到 server 2019 上直接报错了。
  2. 这可是原生的包,我啥也没改,怎么可能报错。而且之前在 其他服务器用都没问题。
  3. 特意检查了路径不能是带中文等特殊字符,发现也ok。

这就奇怪了?

分析:查看logs 目录下 error.log ,将最后的报错贴上来,以警后人:

复制代码
nginx启动报错:unknown directive " " in D:\common\nginx\conf\nginx.conf:3

网上查了下,感谢这个博主:

nginx启动报错:unknown directive " " in D:\nginx\conf\nginx.conf:3_unknown directive "user nginx-CSDN博客文章浏览阅读936次。在尝试使用Nginx部署前端项目时,由于使用记事本以UTF-8带BOM格式保存了nginx.conf配置文件,导致启动时出现unknowndirective错误。解决方案是使用不带BOM的UTF-8编码编辑器重新保存conf文件。完成修改后,Nginx成功启动。https://blog.csdn.net/shunhua19881987/article/details/125255452

我将具体原因和解决方法贴上来:

用Nginx部署一个前端项目,用记事本修改了nginx\conf\nginx.conf 文件的相关配置并保存,居然启动时报错:unknown directive " " in D:\nginx\conf\nginx.conf:1

原因:

是编码问题。 conf文件被记事本编辑过,保存成了含BOM编码的文件。

注:记事本编辑UTF-8都会自动加BOM头

解决方法:

使用其他编辑器(不能是记事本)将conf文件另存为UTF-8编码不含Bom的格式。

修改完成后,Nginx成功启动。

相关推荐
虎头金猫5 天前
4K 视频总卡在公网带宽?用 N1 + OpenList 把网盘播放链路重新理顺
运维·服务器·网络·python·容器·beautifulsoup·pandas
还是大剑师兰特5 天前
解决nginx错误:http://localhost:7000正常,http://localhost:7000/map 报错404
nginx·大剑师
AI职业加油站5 天前
AI智能体应用工程师证书:政策红利下的职业新风口
大数据·运维·人工智能·学习·职场发展
此冬歌咏5 天前
K8s 节点故障实战:优雅驱逐 31 秒,硬故障 331 秒,以及那个永远 Pending 的 Pod
运维·k8s
xing-xing5 天前
Docker容器中Nginx站点根目录网页配置访问
nginx·docker
-梅5 天前
linux(8) 软硬链接
linux·运维·服务器
张洛闻Eren5 天前
k8s云原生【第十课】:水平 Pod 自动扩缩容
运维·数据库·云原生·kubernetes·github
其实防守也摸鱼5 天前
内网穿透与反向代理:原理、工具与实战指南
android·大数据·运维·安全·网络安全·自动化·渗透
布裘5 天前
【银河麒麟】V4桌面图标消失,右击鼠标没反应排查
运维·银河麒麟·桌面环境
懂软件的胡子个哥5 天前
微信机器人为什么需要“回复候选”而不是所有 AI 内容直接发送
运维·微信·自动化·wechatapi·个人微信号二次开发