[Order]Cisco路由交换基础命令汇总

说明

这里配置的是锐捷Cisco的路由交换配置命令。华为和H3C的后续再汇总

1. VTP (VLAN Trunking Protocol)

作用:用于在多个交换机之间传播VLAN信息。

配置命令

bash 复制代码
Switch(config)# vtp mode server   //配置交换机的VTP模式为服务器模式,允许此交换机添加、删除或修改VLAN。
Switch(config)# vtp domain MYDOMAIN   //配置VTP域名称。所有交换机必须在同一VTP域下才能交换VLAN信息。
Switch(config)# vtp password MYPASSWORD   //配置VTP域的密码,用于认证VTP通信,确保安全性。
Switch(config)# interface fastethernet 0/1   //进入指定的接口配置模式,这里是fastethernet 0/1端口。
Switch(config-if)# switchport mode trunk   //将接口设置为trunk模式,使该接口能够传输多个VLAN的数据。
Switch(config-if)# switchport trunk encapsulation dot1q   //设置trunk模式的封装方式为IEEE 802.1Q,支持多个VLAN的标记。
Switch(config-if)# exit   //退出接口配置模式,返回全局配置模式。

2. HSRP (Hot Standby Router Protocol)

作用:提供冗余网关功能,确保网络的高可用性。

配置命令

bash 复制代码
Router(config)# interface fastethernet 0/0   //进入接口配置模式,配置FastEthernet 0/0接口
Router(config-if)# standby 1 ip 192.168.1.254   //配置HSRP(Hot Standby Router Protocol)虚拟IP地址,作为冗余网关
Router(config-if)# standby 1 priority 110   //设置HSRP优先级,优先级越高,成为主路由器的机会越大
Router(config-if)# standby 1 preempt   //启用HSRP预占功能,允许路由器在优先级更高时成为主路由器
Router(config-if)# exit   //退出接口配置模式

3. ACL (Access Control List)

作用:基于IP地址、协议、端口号等条件对网络流量进行过滤。

配置命令

bash 复制代码
Router(config)# access-list 100 permit ip 192.168.1.0 0.0.0.255 any   //配置ACL 100,允许源地址为192.168.1.0/24的IP流量访问任何目标
Router(config)# access-list 100 deny ip any any   //配置ACL 100,拒绝所有其他IP流量
Router(config)# interface fastethernet 0/0   //进入接口配置模式,配置FastEthernet 0/0接口
Router(config-if)# ip access-group 100 in   //将ACL 100应用到FastEthernet 0/0接口的入站流量
Router(config-if)# exit   //退出接口配置模式

4. QoS (Quality of Service)

作用:控制和优化网络流量,确保带宽和延迟满足应用需求。

配置命令

bash 复制代码
Router(config)# class-map match-any VOICE   //创建一个名为VOICE的类映射,匹配所有符合条件的流量
Router(config-cmap)# match access-group 100   //指定使用ACL 100来匹配流量
Router(config-cmap)# exit   //退出类映射配置模式
Router(config)# policy-map QoS_POLICY   //创建一个名为QoS_POLICY的策略映射
Router(config-pmap)# class VOICE   //指定QoS_POLICY策略中应用VOICE类的配置
Router(config-pmap-c)# priority 512   //为VOICE类流量配置512 kbps的优先级带宽
Router(config-pmap-c)# exit   //退出类配置模式
Router(config-pmap)# exit   //退出策略映射配置模式
Router(config)# interface fastethernet 0/0   //进入FastEthernet 0/0接口配置模式
Router(config-if)# service-policy output QoS_POLICY   //将QoS_POLICY应用到接口的输出流量
Router(config-if)# exit   //退出接口配置模式

5. RIP (Routing Information Protocol)

作用:一种基于距离矢量的路由协议,用于在网络中传递路由信息。

配置命令

bash 复制代码
Router(config)# router rip   //启用RIP路由协议
Router(config-router)# version 2   //指定使用RIP版本2
Router(config-router)# network 192.168.1.0   //启用RIP在192.168.1.0网络上进行路由广播
Router(config-router)# exit   //退出RIP路由配置模式

6. SNMP (Simple Network Management Protocol)

作用:用于监控和管理网络设备的性能、配置和故障。

配置命令

bash 复制代码
Router(config)# snmp-server community public RO   //配置SNMP社区字符串"public",并设置为只读权限
Router(config)# snmp-server community private RW   //配置SNMP社区字符串"private",并设置为读写权限
Router(config)# snmp-server location "Data Center"   //设置路由器的物理位置为"Data Center"
Router(config)# snmp-server contact "admin@company.com"   //设置管理员联系邮箱为"admin@company.com"

7. EtherChannel

作用 :将多个物理链路捆绑成一个逻辑链路,提高带宽和冗余。
配置命令

bash 复制代码
Switch(config)# interface range fastethernet 0/1 - 2   //进入多个接口配置模式,选择FastEthernet 0/1和0/2接口
Switch(config-if-range)# channel-group 1 mode active   //将接口加入到聚合组1,并设置为LACP(Link Aggregation Control Protocol)活动模式
Switch(config-if-range)# exit   //退出接口范围配置模式
Switch(config)# interface port-channel 1   //进入聚合接口Port-Channel 1的配置模式
Switch(config-if)# switchport mode trunk   //设置聚合接口为trunk模式,允许多个VLAN通过
Switch(config-if)# exit   //退出聚合接口配置模式

8. IP Routing

作用:启用路由功能,使设备能够在不同子网之间进行通信。

配置命令

bash 复制代码
Router(config)# ip routing

9. GRE (Generic Routing Encapsulation)

作用:在两个网络之间建立虚拟隧道,通过IP协议承载其他协议的流量。

配置命令

bash 复制代码
Router(config)# interface tunnel 0   //进入隧道接口0的配置模式
Router(config-if)# ip address 192.168.1.1 255.255.255.0   //配置隧道接口的IP地址和子网掩码
Router(config-if)# tunnel source 192.168.0.1   //设置隧道源IP地址
Router(config-if)# tunnel destination 192.168.2.1   //设置隧道目标IP地址
Router(config-if)# exit   //退出隧道接口配置模式

10. VLAN Access Map

作用:通过VLAN访问控制映射提供灵活的流量过滤和策略控制。

配置命令

bash 复制代码
Switch(config)# vlan access-map MAP_NAME 10   //创建一个VLAN访问映射,名称为MAP_NAME,序号为10
Switch(config-access-map)# match ip address 101   //配置匹配条件,使用访问控制列表(ACL)编号101
Switch(config-access-map)# action drop   //设置匹配到的流量进行丢弃(drop)
Switch(config-access-map)# exit   //退出VLAN访问映射配置模式
Switch(config)# vlan filter MAP_NAME vlan-list 10-20   //将VLAN访问映射应用到VLAN 10到VLAN 20的范围

11. RADIUS Authentication

作用:使用RADIUS协议对设备进行认证、授权和计费。

配置命令

bash 复制代码
Router(config)# radius-server host 192.168.1.100 key MYSECRET   //配置RADIUS服务器地址为192.168.1.100,并设置共享密钥为MYSECRET
Router(config)# aaa authentication login default group radius local   //配置登录认证,首先使用RADIUS服务器进行认证,如果RADIUS不可用则使用本地认证
Router(config)# aaa authorization exec default group radius local   //配置执行授权,首先使用RADIUS进行授权,如果RADIUS不可用则使用本地授权
Router(config)# exit   //退出配置模式

12. IPSLAs (IP Service Level Agreements)

作用:用于主动监测网络性能和质量,支持延迟、抖动、丢包率等统计。

配置命令

bash 复制代码
Router(config)# ip sla 1   //创建一个IP SLA任务,任务编号为1
Router(config-ip-sla)# icmp-echo 8.8.8.8 source-ip 192.168.1.1   //配置IP SLA任务,使用ICMP回显请求向8.8.8.8发送数据包,源IP为192.168.1.1
Router(config-ip-sla-echo)# frequency 30   //设置ICMP回显请求发送频率为每30秒一次
Router(config-ip-sla-echo)# exit   //退出IP SLA任务配置模式
Router(config)# ip sla schedule 1 life forever start-time now   //配置IP SLA任务1的调度,任务永久运行,立即开始
Router(config)# exit   //退出全局配置模式

13. VPLS (Virtual Private LAN Service)

作用:为多个站点提供透明的以太网连接,适用于多点间的局域网连接。

配置命令

bash 复制代码
Router(config)# l2vpn   //进入L2VPN配置模式
Router(config-l2vpn)# vpls 100   //配置VPLS实例,编号为100
Router(config-l2vpn-vpls)# vpn id 100   //为VPLS实例100配置VPN ID
Router(config-l2vpn-vpls)# customer 1   //配置客户1
Router(config-l2vpn-vpls-customer)# site 1   //为客户1配置站点1
Router(config-l2vpn-vpls-customer-site)# interface ethernet 0/1   //为站点1配置以太网接口ethernet 0/1
Router(config-l2vpn-vpls-customer-site)# exit   //退出站点配置模式
Router(config-l2vpn-vpls-customer)# exit   //退出客户配置模式
Router(config-l2vpn-vpls)# exit   //退出VPLS配置模式

作用:用于自动化链路聚合,将多个物理接口聚合成一个逻辑接口。

配置命令

bash 复制代码
Switch(config)# interface range gigabitethernet 0/1 - 2   //进入多个以太网接口配置模式,选择GigabitEthernet 0/1到0/2
Switch(config-if-range)# channel-group 1 mode active   //将接口加入到聚合组1,并设置为LACP活动模式
Switch(config-if-range)# exit   //退出接口范围配置模式
Switch(config)# interface port-channel 1   //进入聚合接口port-channel 1的配置模式
Switch(config-if)# switchport mode trunk   //将聚合接口设置为Trunk模式
Switch(config-if)# exit   //退出聚合接口配置模式

15. VPN (Virtual Private Network)

作用:通过加密隧道保护数据传输,确保在公网上的安全通信。

配置命令

bash 复制代码
Router(config)# ip vpn-instance VPN1   //创建VPN实例VPN1
Router(config-vpn-instance)# interface gigabitethernet 0/0   //进入GigabitEthernet 0/0接口配置模式
Router(config-vpn-instance-if)# ip address 192.168.1.1 255.255.255.0   //为接口配置IP地址和子网掩码
Router(config-vpn-instance-if)# vpn-service ipsec   //启用IPSec VPN服务
Router(config-vpn-instance-if)# exit   //退出接口配置模式
Router(config-vpn-instance)# exit   //退出VPN实例配置模式

16. Static Routing

作用:手动配置路由表,指定数据包的转发路径。

配置命令

bash 复制代码
Router(config)# ip route-static 192.168.1.0 255.255.255.0 192.168.2.1

17. Dynamic ARP Inspection (DAI)

作用:防止ARP欺骗攻击,确保ARP请求和响应的合法性。

配置命令

bash 复制代码
Switch(config)# ip arp inspection vlan 10   //启用ARP检查功能,并指定检查VLAN 10的ARP包
Switch(config)# interface fastethernet 0/1   //进入FastEthernet 0/1接口配置模式
Switch(config-if)# ip arp inspection trust   //将接口设置为ARP信任接口
Switch(config-if)# exit   //退出接口配置模式

18. HSA (High-Speed Access)

作用:为特定的访问链路提供高速服务,通常用于接入层设备。

配置命令

bash 复制代码
Router(config)# interface ethernet 0/0
Router(config-if)# hsa enable
Router(config-if)# exit

19. SPF (Shortest Path First)

作用:在OSPF和IS-IS等协议中,SPF算法用于计算网络中到达目的地的最短路径。

配置命令

bash 复制代码
Router(config)# router ospf 1
Router(config-router)# network 192.168.1.0 0.0.0.255 area 0
Router(config-router)# spf delay 500
Router(config-router)# exit

20. BFD for OSPF

作用:为OSPF路由协议提供快速故障检测,提高网络可靠性。

配置命令

bash 复制代码
Router(config)# router ospf 1
Router(config-router)# bfd all-interfaces
Router(config-router)# exit

21.VLAN (Virtual Local Area Network)

作用:将一个物理网络划分为多个逻辑网络,以提高网络管理的灵活性和安全性。

配置命令

bash 复制代码
# 配置交换机端口加入VLAN
Switch(config)# vlan 10
Switch(config-vlan)# name SALES
Switch(config-vlan)# exit
Switch(config)# interface fastethernet 0/1
Switch(config-if)# switchport mode access
Switch(config-if)# switchport access vlan 10
Switch(config-if)# exit

22.OSPF (Open Shortest Path First)

作用:基于链路状态协议的内部网关协议,优化路由选择,常用于大型网络。

配置命令

bash 复制代码
Router(config)# router ospf 1
Router(config-router)# network 192.168.1.0 0.0.0.255 area 0
Router(config-router)# exit

23.ISIS (Intermediate System to Intermediate System)

作用:链路状态协议,常用于ISP核心网络中,支持更复杂的网络拓扑。

配置命令

bash 复制代码
Router(config)# router isis
Router(config-router)# net 49.0001.1921.6800.1001.00
Router(config-router)# is-type level-2-only
Router(config-router)# exit

24.DHCP (Dynamic Host Configuration Protocol)

作用:动态分配IP地址,简化IP管理。

配置命令

bash 复制代码
Router(config)# ip dhcp pool MYPOOL
Router(dhcp-config)# network 192.168.1.0 255.255.255.0
Router(dhcp-config)# default-router 192.168.1.1
Router(dhcp-config)# dns-server 8.8.8.8
Router(dhcp-config)# exit
Router(config)# ip dhcp excluded-address 192.168.1.1 192.168.1.10

25.MPLS (Multiprotocol Label Switching)

作用:通过标签交换加速数据转发,提高网络性能,支持流量工程。

配置命令

bash 复制代码
Router(config)# mpls ip
Router(config)# interface fastethernet 0/0
Router(config-if)# mpls ip
Router(config-if)# exit

26.VRRP (Virtual Router Redundancy Protocol)

作用:路由器冗余协议,确保路由器高可用性。

配置命令

bash 复制代码
Router(config)# interface fastethernet 0/0
Router(config-if)# vrrp 1 ip 192.168.1.1
Router(config-if)# vrrp 1 priority 100
Router(config-if)# vrrp 1 preempt
Router(config-if)# exit

27.NAT (Network Address Translation)

作用:转换私有IP和公有IP,隐藏内部网络结构。

配置命令

bash 复制代码
Router(config)# interface fastethernet 0/0
Router(config-if)# ip nat inside
Router(config-if)# exit
Router(config)# interface fastethernet 0/1
Router(config-if)# ip nat outside
Router(config-if)# exit
Router(config)# ip nat inside source list 1 interface fastethernet 0/1 overload
Router(config)# access-list 1 permit 192.168.1.0 0.0.0.255

28.BGP (Border Gateway Protocol)

作用:外部网关协议,用于不同自治系统之间交换路由信息。

配置命令

bash 复制代码
Router(config)# router bgp 65001
Router(config-router)# neighbor 192.168.2.1 remote-as 65002
Router(config-router)# network 192.168.1.0 mask 255.255.255.0
Router(config-router)# exit

29.IPsec (Internet Protocol Security)

作用:通过加密和认证保护IP数据包,确保数据传输安全。

配置命令

bash 复制代码
Router(config)# crypto isakmp policy 1   //配置ISAKMP策略,定义加密和认证参数
Router(config-isakmp)# encryption aes   //设置加密算法为AES
Router(config-isakmp)# hash sha   //设置哈希算法为SHA
Router(config-isakmp)# authentication pre-share   //设置认证方式为预共享密钥
Router(config-isakmp)# group 2   //设置Diffie-Hellman组为组2
Router(config-isakmp)# exit   //退出ISAKMP策略配置模式
Router(config)# crypto isakmp key MYKEY address 192.168.2.1   //设置ISAKMP预共享密钥和远端设备地址
Router(config)# crypto ipsec transform-set MYSET esp-aes esp-sha-hmac   //定义IPSec转换集,指定加密和哈希算法
Router(config)# crypto map MYMAP 10 ipsec-isakmp   //创建并应用IPSec加密映射,关联ISAKMP
Router(config-crypto-map)# set peer 192.168.2.1   //设置对等设备的IP地址
Router(config-crypto-map)# set transform-set MYSET   //设置转换集为MYSET
Router(config-crypto-map)# match address 101   //指定访问控制列表(ACL)101匹配的流量将应用该加密映射
Router(config-crypto-map)# exit   //退出加密映射配置模式
Router(config)# interface fastethernet 0/0   //进入FastEthernet 0/0接口配置模式
Router(config-if)# crypto map MYMAP   //将加密映射MYMAP应用到接口
Router(config-if)# exit   //退出接口配置模式

30.BFD (Bidirectional Forwarding Detection)

作用:快速检测链路故障,提高网络可靠性。

配置命令

bash 复制代码
Router(config)# bfd interval 50 min_rx 50 multiplier 3
Router(config)# interface fastethernet 0/0
Router(config-if)# bfd interval 50 min_rx 50 multiplier 3
Router(config-if)# exit

31.NQA (Network Quality Analyzer)

作用:监控和分析网络性能。

配置命令

bash 复制代码
Router(config)# nqa test-instance ICMPTEST
Router(config-nqa)# type icmp
Router(config-nqa-icmp)# destination ip 8.8.8.8
Router(config-nqa-icmp)# frequency 30
Router(config-nqa-icmp)# exit
Router(config-nqa)# start
Router(config-nqa)# exit

有问题的还请见谅!

相关推荐
Cici_ovo17 分钟前
wlan和vlan
网络·智能路由器
hardWork_yulu5 小时前
Android RTMP直播练习实践
网络·安卓
qq_243050796 小时前
irpas:互联网路由协议攻击套件!全参数详细教程!Kali Linux入门教程!黑客渗透测试!
linux·网络·web安全·网络安全·黑客·渗透测试·系统安全
大丈夫立于天地间8 小时前
机遇、挑战与融合创新之路
网络
青旋.8 小时前
数据链路层——以太网协议
网络·网络协议·tcp/ip
东锋1.310 小时前
计算机网络中常用的端口号以及对应的应用程序
网络
IpdataCloud10 小时前
如何提升IP地址查询数据服务的安全?
网络·tcp/ip·安全
互联网资讯10 小时前
详解共享WiFi小程序怎么弄!
大数据·运维·网络·人工智能·小程序·生活
可涵不会debug11 小时前
【C++】在线五子棋对战项目网页版
linux·服务器·网络·c++·git
RayTz12 小时前
STM32-CAN总线
网络·stm32·嵌入式硬件