Ubuntu24 cgroupv2导致rancher(k3s)启动失败的处理

方案一:

修改系统镜像为ubuntu18

方案二:

修改当前系统的cgroup版本,由v2改成v1

修改步骤:

1、查看当前cgroup版本

复制代码
stat -fc %T /sys/fs/cgroup

cgroup v2,输出结果为cgroup2fs

cgroup v1,输出为tmpfs

2、修改引导参数

为了将 cgroups 改回 v1,你需要修改你的系统引导参数。通常,这是通过编辑 GRUB 配置文件来实现:

复制代码
vi /etc/default/grub 

在文件末尾附加

复制代码
GRUB_CMDLINE_LINUX="cgroup_enable=memory swapaccount=0 systemd.unified_cgroup_hierarchy=0"

3、更新 GRUB

在修改完 GRUB 配置后,需要更新 GRUB 以应用更改:

复制代码
update-grub

4. 重启系统

重启系统以使更改生效:

复制代码
reboot

5. 验证更改

重复步骤1查看修改结果

相关推荐
大圣编蚕5 天前
Rancher证书轮换过期导致不能访问UI问题处理
ui·rancher
赵文宇(温玉)19 天前
CoreDNS的hosts插件的缺行配置导致k8s集群异常
容器·kubernetes·rancher
菠萝炒饭pineapple-boss1 个月前
Rancher迁移到其他Local集群
rancher
赵文宇(温玉)1 个月前
OpenEuler24.03 SP4安装Rancher时遇到cgroupv2和iptables问题的经验
iptables·rancher·openeuler·cgroupv2
snow@li2 个月前
SpringBoot:项目基于Rancher全景梳理与深入分析/Kubernetes可视化管理平台
rancher
wangyadong3174 个月前
rancher 安装jenkins 。国内镜像太头疼
servlet·jenkins·rancher
wangyadong3174 个月前
重新安装k3s,因为我安装jenkins 的时候报错了。不知道为啥rancher 访问不了了。
linux·服务器·rancher
qq_356408664 个月前
Rancher 安装与配置文档
rancher
dyj0955 个月前
【Rancher Server+Kubernets】- 部署的Http服务进行文件上传时因为文件大小限制导致上传失败的解决过程
rancher
@王先生15 个月前
rancher安装--针对报错API Aggregation not ready
linux·运维·rancher