百度搜索应适用中文域名国家标准,修复中文网址展示BUG

12月1日中文域名国家标准正式实施。该标准"明确了中文域名在编码、解析、注册、字表等方面的技术要求,适用于中文域名注册管理机构、注册服务机构、网络软硬件服务商及终端用户"。

00:23

显然,百度作为网络软硬件服务商,是包括在国家标准的适用范围中的。百度搜索应该支持中文域名国家标准。

百度收录了数百万中文域名网站,但在网址展示上,并未显示中文字符,而是显示为一串punycode码(见附件一、附件二截图),这显然不符合国家标准的要求,是一种产品bug,影响了用户体验。

希望百度搜索团队能够尽快修正这个bug,将punycode码展示成其本来的中文字符形式。

对于网民而言,这串punycode码无法识别,是没有提供有价值信息的乱码,会令其对网站的可信性、安全性感到更加困惑。对于网站持有者来说,目前的收录展示方式,并未发挥其持有的中文域名的标识价值,影响其在百度平台推广其网站。

根据site指令查询,这涉及到数百万个网站(如".中国"中文域名下的查询结果就达到135万条,".网址"下为2.68万条),而国内的中文顶级域就有30多个,以此推之,可以说影响面很大。我也观察到,Google搜索、Bing搜索、搜狗搜索都已经支持中文域名收录和准确展示,满足用户使用体验。(见附件三)

中文域名是国家支持并发展的方向,主管部门对于中文域名应用普及有明确工作要求。据新华社客户端报道(https://h.xinhuaxmt.com/vh512/share/11835579?d=134b43d),工业和信息化部信息通信管理局致函中国互联网协会,要求协会组织行业相关单位,落实《"十四五"信息通信行业发展规划》关于"完善中文域名应用环境,进一步推动中文域名推广应用"的要求,基于前期工作基础,深入开展中文域名推进工作,推动中文域名高质量发展。

措施中有一条,"开展技术培训。组织开展中文域名专题技术培训,宣贯中文域名相关标准和规范,推动涉及中文域名应用服务的企业在各种互联网应用程序、设备和系统中,实现对中文域名的正常解析、识别、检索、收录、展示和准确显示。"

综上,搜索引擎收录、展示和准确显示中文域名,既是完善产品体验,也是响应政府工作要求、履行社会责任的一种体现。百度作为中国最大的搜索平台,用户基数大,影响面广,希望能尽早修正中文域名的收录展示bug。

据我了解,中文域名有完备的国际技术标准和规范(IETF技术标准见附件四),当下国家标准也已经实施(见附件五),将punycode码翻译为中文字符,在技术标准和实施上不存在任何问题。

现在是百度适用国家标准,修复收录展示bug的时候了。

附件一:".中国"中文域名收录展示情况

site指令查询,".中国"中文域名显示收录1350000个相关结果

以上图红框的搜索结果为例,点击到达的网站,在地址栏显示为中文域名"新爱半导体.中国",而在百度则显示为一串punycode码。如果百度收录结果显示为这个中文域名,相信对于用户而言,更加容易判断搜索结果的精准性和网站的安全可信性。

附件二:".网址"中文域名的收录展示情况

site指令查询,".网址"中文域名显示收录26800个相关结果

以上图红框的搜索结果为例,点击到到达的网站,在地址栏显示为中文域名"畅远.网址",而在百度则显示为一串punycode码。如果百度收录结果显示为这个中文域名,相信将对于用户而言,更加容易判断搜索结果的精准性和网站的安全可信性。

附件三 搜索引擎支持中文域名现状

1、Google已经支持中文域名的收录和准备展示

2、Bing搜索已经支持中文域名收录和准确显示

3、搜狗搜索已经支持中文域名收录和准确展示

附件四:中文域名IETF标准文档链接

1、RFC3492:++https://www.rfc-editor.org/rfc/rfc3492++

2、RFC3490:++https://www.rfc-editor.org/rfc/rfc3490++

3、RFC5890:++https://www.rfc-editor.org/rfc/rfc5890++

4、RFC5891:++https://datatracker.ietf.org/doc/html/rfc5891++

附件五:中文域名国家标准文档链接

GB/T 44266-2024 中文域名总体技术要求

GB/T 44596-2024 中文域名编码技术要求

GB/T 44270-2024 中文域名注册技术要求

GB/T 44278-2024 中文域名解析技术要求

GB/T 44277-2024 中文域名字表技术要求

相关推荐
LaughingZhu8 天前
Product Hunt 热榜 2026-11-02:Screen Studio 4.0、ClawsGO Science、Riverside Agents
人工智能·深度学习·神经网络·数码相机·搜索引擎·百度
LaughingZhu9 天前
Product Hunt 热榜 2026-11-01:Specsight、SKI、telemetry.dev
人工智能·深度学习·神经网络·搜索引擎·百度
X54先生(人文科技)11 天前
百度智能对 X54 先生学科底色评估
人工智能·深度学习·百度·架构
孙琦Ray11 天前
百度开源 Unlimited OCR 2:百页文档单请求解析,竞品得分仅其四成
百度·ocr·开源模型·unlimited ocr 2·长文档解析·sr-swa
辛迪聊物业数字化11 天前
智慧社区小程序落地避坑指南:3类物业方案选型+成本测算,线上服务零翻车
大数据·嵌入式硬件·百度·系统架构
GitCode官方11 天前
从大语言模型到具身智能:百度百舸 LoongForge 入驻 AtomGit
人工智能·react native·百度·harmonyos·atomgit
yumengxt12 天前
百度 AI 搜索核心能力与实测表现深度评测
人工智能·百度
览讯冷却13 天前
冷却塔噪声的健康危害与法规要求的技术梳理
经验分享·笔记·科技·其他·百度·制造·业界资讯
Agent世界14 天前
百度OCR 2开源:KV缓存从47GB压到1.77GB
百度·缓存·开源·大模型·ocr
我喜欢就喜欢15 天前
百度 AI 搜索实战应用场景与落地指南
人工智能·百度