【异常解决】Unable to start embedded Tomcat Nacos 启动报错

Unable to start embedded Tomcat Nacos 启动报错解决方案

一、背景描述

Windows 本地启动 Nacos(2.2.0) 服务,控制台报错 Unable to start embedded Tomcat。

报错信息:Unable to start embedded Tomcat,无法加载内置的tomcat。如下图所示:

二、原因分析

原因一:启动方式不对,直接双击打开或者是通过命令行启动(startup.cmd)默认是集群模式。

原因二:端口被占用。 Nacos 配置的默认端口号是 8848,请检查这个端口是否被占用。

三、解决方案

3.1 解决方案一

单机模式后启动

进入到nacos安装目录下的bin文件夹下,输入 startup.cmd -m standalone 回车即可。

复制代码
startup.cmd -m standalone

再次启动,成功!即可访问控制台 http://localhost:8848/nacos/index.html 。

3.2 解决方案二

把占用的 8848 端口 kill掉。然后再次启动 nacos 服务即可。

本文完结!

相关推荐
青山木几秒前
Hot 100 --- 下一个排列
java·数据结构·算法·leetcode
Thinker QAQ1 分钟前
并发编程(六):Atomic 的实现——从 Runtime 到 CPU
java·go·cas·并发编程·atomic·cpython
沐欣工作室_lvyiyi10 分钟前
基于SpringBoot的博物馆预约系统设计与实现(论文+源码)
java·spring boot·后端·计算机毕业设计
程序员清风2 小时前
Java 智能体开发:从对话接口到任务执行
java·人工智能·python
一 乐2 小时前
博客管理系统|基于springboot + vue博客管理系统(源码+数据库+文档)
java·数据库·vue.js·spring boot·毕设
QuZhengRong2 小时前
【Spring】后端接收的请求参数多了一个逗号的处理办法
java·后端·spring
ZealSinger2 小时前
Go1.25容器感知GOMAXPROCS避限流
java·开发语言
cxoptics2 小时前
LBO 会不会潮解?存储、镀膜、日常使用注意事项?
java
SL_staff2 小时前
非研发人员搭业务逻辑?先认清这3个可视化编程分水岭
java