linux centos安装elasticsearch-7.6.2

1.安装elasticsearch-7.6.2

上传包

解压

tar -xvf elasticsearch-7.6.2-linux-x86_64.tar 进入config文件夹

修改elasticsearch.yml 配置

修改jvm.options配置

修改bin/elastisearch

2.创建用户,然后授权

useradd elastic chown -R elastic /opt/es/elasticsearch-7.6.2

3.为了防止出这个错误

max virtual memory areas vm.max_map_count 65530 is too low, increase to at least 262144 /etc/sysctl.conf 添加下面配置: vm.max_map_count=262144 并执行命令: sysctl -p

4.然后启动运行 ,服务器需要开通9200,9300端口

su elastic cd /opt/es/elasticsearch-7.6.2 ./bin/elasticsearch -d

5.浏览器运行ip:9200

出现如下页面,证明成功了

问题:想重启怎么办? ES不支持直接重启,只能先结束掉进程,在运行脚本重启。下面是操作的过程:

1.查找ES进程

ps -ef | grep elastic

然后可以看到如下的进程号,10965之类的,之后kill掉就可以啦。

2.杀掉ES进程kill -9 2382(进程号)

kill -9 10965

3.启动ES (为安全考虑,ES不允许 root 启动,先切换到ES的账号 su elastic , root账号启动会报错)

切换到elasticsearch所在bin目录执行(-d 表示后台运行)

su elastic cd /opt/es/elasticsearch-7.6.2 ./bin/elasticsearch -d 4.检查ES启动状态

curl 127.0.0.1:9200

相关推荐
光影少年12 小时前
langchain与langgraph区别以及学习路线
elasticsearch·langchain·llm
Elasticsearch13 小时前
错误最多的服务运行正常:使用 ES|QL 从日志进行根因分析
elasticsearch
Elasticsearch13 小时前
将你自己的密钥用于现有 Elastic Cloud 部署
elasticsearch
IT大白鼠1 天前
搜索系列 · 第 06 篇——避坑汇总:经典生产问题
elasticsearch·nosql
IT大白鼠1 天前
搜索系列 · 第 07 篇——调优实战:写入、查询与监控
elasticsearch·nosql
Elasticsearch1 天前
检查 100 个候选项,而不是 1000 万个文档:更快速的 Elasticsearch kNN 过滤
elasticsearch
Elasticsearch1 天前
当 AI agent 群集出现时,银行能跟上吗?
elasticsearch
Sayai2 天前
Elasticsearch 日志检索 DSL 实战:时间范围查询、字段去重、分钟级统计与最新日志获取
大数据·运维·elasticsearch·搜索引擎·日志分析
阿狗童鞋2 天前
Elasticsearch实战指南
大数据·elasticsearch·搜索引擎
IT大白鼠2 天前
搜索系列 · 第 04 篇——部署实操:内网集群落地
运维·elasticsearch·nosql