weblogic部署报错汇总

weblogic部署报错汇总

Weblogic部署遇到的问题

1.部署完weblogic,进入weblogic控制台,后提示无资源可访问。

解决方法: 权限问题,检查weblogic应用的启动用户和所属用户是否一致。

2. 安装weblogic,创建域的时候特别慢,一直卡着等待或者启动weblogic的时候特别慢

解决方法:

修改Linux上Weblogic使用的jdk 文件

复制代码
$JAVA_HOME/jre/lib/security/java.security

将securerandom.source=file:/dev/urandom 修改为securerandom.source=file:/dev/./urandom

3. 报错:对于服务器与计算机相关联的节点管理器无法访问。

所有所选服务器当前都处于与此操作不兼容的状态, 或未与运行的节点管理器关联, 或没有授权您执行请求的操作。

解决方法:

这种基本都是节点没启动。

思路检查端口、修改配置文件查看日志。

5556是节点的默认端口,查看这个端口是不是被开放,防火墙配置啥的,然后查看节点是否启动,可以通过ps看进程或者ss查看5556端口。

还有就是/usr/local/weblogic/oracle/user_projects/domains/base_domain/nodemanager

/nodemanager.properties文件

ListenPort=5556 侦听端口

SecureListener=false 安全监听,得配合ssl如果没有就检测不到

4. 节点管理器可访问,但是启动其他IP的节点服务器无法启动,可以启动本机的节点,

查看输出日志:

-Dweblogic.home=/usr/local/weblogic/oracle/wlserver/server *-Dweblogic.management.server=http://192.168.122.1:7001* -Dweblogic.ut

ils.cmm.lowertier.ServiceDisabled=true weblogic.Server

<2024-12-29 下午06时01分37秒 CST> <Disabling the CryptoJ JCE Provider self-integrity check for better startup performanc

e. To enable this check, specify -Dweblogic.security.allowCryptoJDefaultJCEVerification=true.>

<2024-12-29 下午06时01分37秒 CST> <Changing the default Random Number Generator in RSA CryptoJ from ECDRBG128 to FIPS186

PRNG. To disable this change, specify -Dweblogic.security.allowCryptoJDefaultPRNG=true.>

<2024-12-29 下午06时01分38秒 CST> <Starting WebLogic Server with Java HotSpot™ 64-Bit Server VM Version 24.80-b

11 from Oracle Corporation.>

<2024-12-29 下午06时01分39秒 CST> <Could not register with the Administration Server: java.rmi.RemoteException: [Deplo

yer:149147]Could not reach the Administration Server through any of its URLs: "http://192.168.122.1:7001".>

<2024-12-29 下午06时01分39秒 CST> <Version: WebLogic Server 12.1.3.0.0 Wed May 21 18:53:34 PDT 2014 1604337 >

<2024-12-29 下午06时01分39秒 CST> <The server name 116-7011 specified with -Dweblogic.Name does not exist. The configu

ration includes the following servers {AdminServer}.>

<2024-12-29 下午06时01分39秒 CST> <Server failed. Reason:

There are 1 nested errors:

weblogic.management.ManagementException: Management:141223*The server name 116-7011 specified with -Dweblogic.Name does not exist. The configuration i*

ncludes the following servers {AdminServer}.

​ at weblogic.management.provider.internal.RuntimeAccessImpl.initialize(RuntimeAccessImpl.java:425)

​ at weblogic.management.provider.internal.RuntimeAccessService.start(RuntimeAccessService.java:70)

​ at weblogic.server.AbstractServerService.postConstruct(AbstractServerService.java:78)

​ at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

​ at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)

​ at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)

​ at java.lang.reflect.Method.invoke(Method.java:606)

​ at org.jvnet.hk2.internal.Utilities.createService(Utilities.java:2488)

​ at org.jvnet.hk2.internal.ServiceHandleImpl.getService(ServiceHandleImpl.java:98)

​ at org.jvnet.hk2.internal.ServiceHandleImpl.getService(ServiceHandleImpl.java:87)

​ at

<2024-12-29 下午06时01分39秒 CST>

通过日志分析:报错是这个节点不存在,但是我们肯定是创建的,再有日志中发现,管理服务器IP并不是我们主服务器的IP,因此需要再配置文件修改IP

解决方法:

修改weblogic控制台那台服务器的/domain/config/config.xml

AdminServer

IP 7001

7002

在listen-address栏中写死控制IP。

5. 修改ts t3s拦截规则后weblogic无法启动

报错日志如下:

  1. weblogic.utils.NestedRuntimeException: Security:090467problem with connection filter
  2. java.lang.IllegalStateException: Unable to perform operation: post construct on weblogic.security.PreSecurityService
  3. java.lang.IllegalArgumentException: While attempting to resolve the dependencies of weblogic.security.SecurityService errors were found
  4. java.lang.IllegalStateException: Unable to perform operation: resolve on weblogic.security.SecurityService
  5. java.lang.IllegalArgumentException: While attempting to resolve the dependencies of weblogic.jndi.internal.RemoteNamingService errors were found
  6. java.lang.IllegalStateException: Unable to perform operation: resolve on weblogic.jndi.internal.RemoteNamingService
  7. java.lang.IllegalArgumentException: While attempting to resolve the dependencies of weblogic.management.mbeanservers.runtime.internal.RuntimeServerS
    ervice errors were found
  8. java.lang.IllegalStateException: Unable to perform operation: resolve on weblogic.management.mbeanservers.runtime.internal.RuntimeServerService
  9. java.lang.IllegalArgumentException: While attempting to resolve the dependencies of weblogic.cacheprovider.CacheProviderServerService errors were fo
    und
  10. java.lang.IllegalStateException: Unable to perform operation: resolve on weblogic.cacheprovider.CacheProviderServerService

A MultiException has 10 exceptions. They are:

  1. weblogic.utils.NestedRuntimeException: Security:090467problem with connection filter
  2. java.lang.IllegalStateException: Unable to perform operation: post construct on weblogic.security.PreSecurityService
  3. java.lang.IllegalArgumentException: While attempting to resolve the dependencies of weblogic.security.SecurityService errors were found
  4. java.lang.IllegalStateException: Unable to perform operation: resolve on weblogic.security.SecurityService
  5. java.lang.IllegalArgumentException: While attempting to resolve the dependencies of weblogic.jndi.internal.RemoteNamingService errors were found
  6. java.lang.IllegalStateException: Unable to perform operation: resolve on weblogic.jndi.internal.RemoteNamingService
  7. java.lang.IllegalArgumentException: While attempting to resolve the dependencies of weblogic.management.mbeanservers.runtime.internal.RuntimeServerS
    ervice errors were found
  8. java.lang.IllegalStateException: Unable to perform operation: resolve on weblogic.management.mbeanservers.runtime.internal.RuntimeServerService
  9. java.lang.IllegalArgumentException: While attempting to resolve the dependencies of weblogic.cacheprovider.CacheProviderServerService errors were fo
    und
  10. java.lang.IllegalStateException: Unable to perform operation: resolve on weblogic.cacheprovider.CacheProviderServerService

at org.jvnet.hk2.internal.Collector.throwIfErrors(Collector.java:88)

at org.jvnet.hk2.internal.ClazzCreator.resolveAllDependencies(ClazzCreator.java:269)

at org.jvnet.hk2.internal.ClazzCreator.create(ClazzCreator.java:413)

at org.jvnet.hk2.internal.SystemDescriptor.create(SystemDescriptor.java:456)

at org.glassfish.hk2.runlevel.internal.AsyncRunLevelContext.findOrCreate(AsyncRunLevelContext.java:225)

Truncated. see log file for complete stacktrace
Caused By: weblogic.utils.NestedRuntimeException: Security:090467problem with connection filter

at weblogic.security.PreSecurityService.initializeConnectionFilter(PreSecurityService.java:236)

at weblogic.security.PreSecurityService.start(PreSecurityService.java:135)

at weblogic.server.AbstractServerService.postConstruct(AbstractServerService.java:78)

at sun.reflect.GeneratedMethodAccessor13.invoke(Unknown Source)

at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)

Truncated. see log file for complete stacktrace
Caused By: java.lang.ClassNotFoundException: nohup /usr/local/weblogic/oracle/user_projects/domains/base_domain/bin/startNodeManager.sh >/usr/local/web
logic/nodeOut.log 2>&1 &

at java.lang.Class.forName0(Native Method)

at java.lang.Class.forName(Class.java:195)

at weblogic.security.PreSecurityService.initializeConnectionFilter(PreSecurityService.java:231)

at weblogic.security.PreSecurityService.start(PreSecurityService.java:135)

at weblogic.server.AbstractServerService.postConstruct(AbstractServerService.java:78)

Truncated. see log file for complete stacktrace

日志解析:

复制代码
weblogic.utils.NestedRuntimeException: [Security:090467]problem with connection filter

这个报错是连接器筛选器的报错可以记住这个报错代码090467,weblogic的页面端就是下面这个地方。

问题出在了weblogic拦截策略配置上面,即上图的配置页面,也可在config.xml找到

可以检查一下输入的是否有错 没加*号或者缺少也会报错

正确配置如图

A MultiException has 10 exceptions. They are: 这个就是说我配置了10个这种规则,不生效,但是我遇到的问题不是拦截规则设置错误

而是Caused By: java.lang.ClassNotFoundException: nohup /usr/local/weblogic/oracle/user_projects/domains/base_domain/bin/startNodeManager.sh >/usr/local/web
logic/nodeOut.log 2>&1 & ,加载了一个这玩意的

类的时候没找到,但是这个是启动脚本的shell命令,和java类应该没关系,打开config.xml配置文件,文件在/domain/config/下,查看如下图

把weblogic.security.filters.DefaultConnectionFilter,替换掉 nohup /usr/local/weblogic/oracle/user_projects/domains/base_domain/bin/startNodeManager.sh >/usr/local/web

logic/nodeOut.log 2>&1 &

重新启动不报错了

相关推荐
醇氧5 分钟前
uvicorn 详细介绍
linux·运维·python·python3.11
Qwier11 分钟前
Win Srv 2019 安装补丁后重启
运维·服务器·windows
海宇服务13 分钟前
零信任架构实战:基于海宇车辆出险记录核验构建自动化车险流转网关
运维·人工智能·架构·自动化
guo_wen_qiang1 小时前
云服务器elasticsearch环境搭建-单台
运维·elasticsearch·容器
Zhou1411361 小时前
CICD_01_持续集成与Jenkins入门
运维·ci/cd·jenkins
硅基手札1 小时前
MCP 实战 —— 从零写一个 CRC16 服务器(保姆级)
运维·服务器·ai
今年下半年1 小时前
【运维】windows虚拟机安装arm(aarch64)服务器
运维·windows·arm·虚拟机·aarch64
杨云龙UP2 小时前
TDengine Community 超级表建表实战:统一21个TAG与DOUBLE/字符串数据模板
运维·服务器·数据库·时序数据库·tdengine·涛思数据·stable建表
高山有多高2 小时前
【Linux笔记】冯诺依曼体系结构
linux·运维·笔记
筑梦之路2 小时前
Alibaba Cloud Linux 4 IPXE全自动安装(直连官方源)——筑梦之路
linux·运维·服务器·国产化·阿里云操作系统