Arcgis连接HGDB报错

文章目录

环境

系统平台:Linux x86-64 Red Hat Enterprise Linux 7

版本:6.0

症状

Arcgis连接HGDB报错:

无法连接到数据库服务器来检索数据库列表;请检查服务器名称、用户名和密码信息,然后重试。

登录用户不正确。

问题原因

查看数据库日志,提示未配置spatial_planning用户连接postgres数据库的pg_hba记录。

解决方案

  1. 新增pg_hba内容

    vi $PGDATA/pg_hba.conf

    host postgres spatial_planning 0.0.0.0/0 md5

  2. 重新加载数据库

    pg_ctl reload

  3. 再次使用arcgis连接HGDB,可正常连接,问题解决。

相关推荐
fb_1234518 分钟前
MySQL基础核心|数据库原理+MySQL详解
数据库·mysql
‎ദ്ദിᵔ.˛.ᵔ₎24 分钟前
Mysql 基本查询
数据库·mysql
-madongyu-31 分钟前
GaussDB 性能调优:等待事件、慢 SQL 定位与关键参数
数据库·sql·gaussdb
-madongyu-42 分钟前
GaussDB 部署规划:磁盘水位、RAID 与端口设计
数据库·gaussdb
weixin_511255218 小时前
MySQL升级记录
数据库·mysql
程序猿乐锅9 小时前
【黑马点评 | 第八篇】Redisson分布式锁
java·数据库·spring boot·redis·分布式·spring·缓存
Leo.yuan9 小时前
2026年本地化Data Agent优质厂商盘点:哪些产品更适合企业生产环境
大数据·数据库·人工智能
做运维的阿瑞9 小时前
数据库增删改的安全写法
数据库·sql·mysql
程序边界9 小时前
迁移评估不再拍脑袋,这个数据迁移工具的量化报告把我救了(上)
数据库
阿狗童鞋10 小时前
Redis实战指南
数据库·redis·缓存