SAP在未启用负库存的情况下,库存却出现了负数-补充S4 1709 BUG

SAP在未启用负库存的情况下,库存却出现了负数-补充S4 1709 BUG

共用物料合并发料:单行发料数量没有超过库存数量,但合计发料数量超过库存数量了,系统还是可以过账,没有任何提示,如下图所示:

库存数量是100,当单行发料数量都小于库存数量,但是合计发料数量110(50+60)大于库存数量(100),如下图所示:

过账,系统没有任何提示,按照常理发料数量大于库存数量,系统是要报错拦截,至少也是要有一个警告信息才对,生成物料凭证,如下图所示:

库存数量是100,当单行发料数量某一行大于库存数量,系统会报错,如下图所示:

以上是在S4 1709上测试的,下面在S4 2020上测试,版本如下图所示:

库存数量还是100,T-CODE:MIGO对2个工单261/B发料,数量分别是50/60,当单击"检查"时,系统提示库存短缺10PC,消息M7021,如下图所示:

此时查看S4 1709中消息号M7021的设置,发现是W,更改为E,如下图所示:

重新对2个工单发料,当共用物料合计发料数量大于库存数量时,系统依然是可以过账的,没有任何报错信息。

总结一下:

在S4 1709版本,要想对B库存共用物料批量发料,当发料数量超过库存数量时,标准系统是不控制的,这样过账后就会出现负库存,这时就要做增强控制;

而S4 2020版本,是通过消息号M7021即可拦截负库存出现,无需增强管控。

在S4 2020版本中,不仅上述的共用物料合并发料数量能否超过库存数量可以通过消息号M7021控制,单工单发料也是可以用消息号M7021控制,T-CODE:OMCP&OMJJ,动态可用性检查都是A(S4 1709必须是B),如下图所示:

T-CODE:MIGO对工单261/B发料,发料数量101,库存数量100,这是系统提示的消息号是M7021,而不再是S4 1709中的M7181,如下图所示:

相关推荐
吴声子夜歌2 小时前
Nginx应用与运维——Nginx负载均衡应用实战(二)
运维·nginx·负载均衡
lisanmengmeng2 小时前
NRPE 添加命令(一)
linux·运维·服务器
pt10432 小时前
CML网络仿真入门-2:使用CML模拟网络实验环境
运维·网络协议
沫璃染墨3 小时前
《从零入门Linux系统篇(五十七):线程篇·十——生产者消费者模型进阶:从环形缓冲区到POSIX信号量》
linux·运维·服务器·开发语言·c++·系统架构·信号处理
HAHAXX84 小时前
电商RPA批量上架通用方案:一套流程如何同时跑通拼多多、抖店、淘宝和跨境平台
java·运维·rpa
零基础1234 小时前
LLM Agent 驱动的物模型构建:从设备手册到边缘接入的自动化实践
运维·人工智能·经验分享·python·自动化
程序猿老A5 小时前
从入门型到企业型:云服务器开放共享型到独享型规格升级
运维·服务器
Ruiery6 小时前
Linux 6.6内核 CPU 深度解析(九):时钟与 TSC — 内核怎么从 PIT/HPET 切到 TSC
linux·运维·服务器
吴声子夜歌6 小时前
Nginx应用与运维——Nginx监控配置及管理(二)
运维·nginx
吴声子夜歌7 小时前
Nginx应用与运维——Nginx日志管理
java·运维·nginx