启动nginx报错nginx [emerg] bind() to 0.0.0.080 failed (98 Address already in use)

启动nginx报错:98:Address already in use

一、问题

某天发现域名ssl证书过期了,重新给域名配置了ssl证书,重启报错:

二、过程

1、查找原因(可以不看)

一开始以为是端口被占用,停掉对应的端口进程就行了,于是挨个停一遍

完了发现不对啊,并没有作用,启动还是报这个错。

那看看80端口跑了什么

那看看网络相关的端口,使用如下命令查找

复制代码
netstat -ntpl

解释:

拒绝显示别名,能显示数字的全部转化成数字,(tcp)仅显示tcp相关选项,显示建立相关链接的程序名,仅列出有在 Listen (监听) 的服務状态。

netstat详情可以查看这篇博客

然后停掉对应的进程,注意 PID 列才是对应的进程id

复制代码
kill 1322

可以看到这几个端口都是同一个进程。

再次启动nginx

复制代码
systemctl start nginx

成功了。

2、解决办法

使用如下命令查看对应占用进程端口

复制代码
netstat -ntpl

使用 PID 列下的进程id停掉进程

复制代码
kill 1322

再次启动就可以了。

复制代码
systemctl start nginx
相关推荐
蓝速科技1 小时前
会议室门牌公告通知发布选型与落地指南丨蓝速科技
大数据·运维·数据库·人工智能·科技
chicheese2 小时前
Linux 面试速查表:从初级到高级,附高频场景答题模板
linux·运维
Linux-lucky2 小时前
32-38-Linux学习之旅之MySQL综合
linux·运维·学习·mysql·ubuntu
智能运维指南3 小时前
2026年ITSM系统怎么选?四款主流方案与五维评估模型
运维·itsm·嘉为蓝鲸
我命由我123453 小时前
Git 推送报错:error: src refspec main does not match any
运维·git·gitee·github·运维开发·学习方法·版本控制
骇客野人3 小时前
测试环境MySQL迁移Vastbase(海量数据库)完整改造与落地实施方案
运维·服务器
迪康Defender3 小时前
终端安全实战:如何高效解决企业U盘泄密与管控难题
运维·网络·安全·web安全·终端安全管理
zly35004 小时前
VMware Converter Standalone 物理机转化为虚拟机后源1硬盘变成了2个硬盘(2个硬盘文件)虚拟机无法启动。
linux·运维·服务器
智能运维指南4 小时前
2026 企业智能运维平台选型:私有化、信创、全链路打通该怎么权衡?
运维·嘉为蓝鲸·aiops平台·一体化运维平台
春天花会开1315 小时前
Supabase 自部署 Edge Functions 超时从 60s 延长到 360s 完整复盘
运维·云原生