vnc连接问题:Timed out waiting for a response from the computer

一. 问题说明

学校服务器 + CentOS Linux

vscode利用ssh可以正确连接

vnc之前可以正确连接,后来突然出现报错:Timed out waiting for a response from the computer

二.解决方案

  1. 利用vscode连接服务器后,在终端输入:

    [xxx@cat ~]$ vncserver -list
    TigerVNC server sessions:
    X DISPLAY # PROCESS ID

说明:当前没有任何正在运行的 VNC 会话

需要手动启动一个 VNC 会话

  1. 配置 VNC 启动桌面

    编辑文件:

    vi ~/.vnc/xstartup

    内容全部替换为下面这几行:

    #!/bin/sh
    unset SESSION_MANAGER
    unset DBUS_SESSION_BUS_ADDRESS
    exec /usr/bin/gnome-session &

    保存退出后,给执行权限:

    chmod +x ~/.vnc/xstartup

出现问题:

复制代码
:w ".vnc/xstartup" 
".vnc/xstartup" E212: 无法打开并写入文件

原因:

复制代码
vi 无法写入这个文件

常见原因只有 3 个:

~/.vnc/ 目录不存在

文件路径写错

文件权限/目录权限不对

解决方案:

复制代码
1:确保 .vnc 目录存在

在服务器上执行:

mkdir -p ~/.vnc

2:直接用 cat 创建 xstartup(避开 vi)
cat > ~/.vnc/xstartup << 'EOF'
#!/bin/sh
unset SESSION_MANAGER
unset DBUS_SESSION_BUS_ADDRESS
exec /usr/bin/gnome-session &
EOF

3:赋予执行权限(非常重要)
chmod +x ~/.vnc/xstartup

验证一下:
ls -l ~/.vnc/xstartup

输出结果:

复制代码
[xxx@cat ~]$ ls -l ~/.vnc/xstartup 
-rwxrwxr-x 1 xxx xxx 93 12月 28 05:47 /home/xxx/.vnc/xstartup 
[xxx2@cat ~]$ vncserver :1 
A VNC server is already running as :1 
[xxx2@cat ~]$ vncserver -list 
TigerVNC server sessions: 
X DISPLAY # PROCESS ID
  • vncserver :1 → 说 already running

所以换一个端口:

复制代码
[xxx2@cat ~]$ vncserver :18 
You will require a password to access your desktops. 
Password:
Verify:
Would you like to enter a view-only password (y/n)? n
A view-only password is not used

Creating default config /home/xxx3/.vnc/config
Starting applications specified in /home/xxx3/.vnc/xstartup
Log file is /home/xxx3/.vnc/cat:19.log

成功启动。

重新启动vnc连接服务器。

成功。

相关推荐
Fcy6484 小时前
Linux下 进程间关系与守护进程
linux·运维·服务器·守护进程
g10565591394 小时前
公有云_云运维服务
java·运维·服务器
well06124 小时前
Linux粘滞位与Makefile机制深度解析
linux·运维·服务器
hzxpaipai5 小时前
杭州企业官网怎么建设?从策划到上线的5步建站方法
运维·服务器·前端·网络
smartpi_ai5 小时前
通用脱机烧录器为什么烧不进 CI-03?下载协议的门槛、免唤醒 10 条的建议值属性
服务器·网络·ci/cd
2501_937860946 小时前
中篇:TCP 为什么可靠又高效?滑动窗口、流量控制、拥塞控制与粘包全解析
服务器·网络·tcp/ip
QYRdata7 小时前
2026-2032年图形处理云服务器CAGR预计达18.7%
运维·服务器·服务发现
极光通讯8 小时前
呆滞库存回收定价逻辑:如何评估DDR4内存和SATA SSD的回收价值
服务器·ssd
技术人生0018 小时前
VMware Workstation 安装 Ubuntu 24.04 LTS 完整教程
运维·服务器·ubuntu
YumiProxy8 小时前
动态IP冲突排查实战:从ARP检测到DHCP地址池的完整链路
服务器·网络·网络协议·tcp/ip·ip