【异常解决】Unable to start embedded Tomcat Nacos 启动报错

Unable to start embedded Tomcat Nacos 启动报错解决方案

一、背景描述

Windows 本地启动 Nacos(2.2.0) 服务,控制台报错 Unable to start embedded Tomcat。

报错信息:Unable to start embedded Tomcat,无法加载内置的tomcat。如下图所示:

二、原因分析

原因一:启动方式不对,直接双击打开或者是通过命令行启动(startup.cmd)默认是集群模式。

原因二:端口被占用。 Nacos 配置的默认端口号是 8848,请检查这个端口是否被占用。

三、解决方案

3.1 解决方案一

单机模式后启动

进入到nacos安装目录下的bin文件夹下,输入 startup.cmd -m standalone 回车即可。

复制代码
startup.cmd -m standalone

再次启动,成功!即可访问控制台 http://localhost:8848/nacos/index.html 。

3.2 解决方案二

把占用的 8848 端口 kill掉。然后再次启动 nacos 服务即可。

本文完结!

相关推荐
Sarvartha3 小时前
final 关键字
java·开发语言
2601_952047793 小时前
单一策略深度教程:用轻易云把集成任务的报错实时推送到钉钉机器人
java·机器人·钉钉
数据狐(Datafox)4 小时前
淘宝图片搜索 API 落地实战:基于以图搜货搭建跨境电商选品系统
java·大数据·微服务
Escalating_xu6 小时前
【C 语言】数据在内存中的存储:补码、大小端、整型陷阱与 IEEE 754 全解析
java·c语言·网络
灯澜忆梦6 小时前
【面向对象编程C++】| 基础语法
java·c++·算法
一个风轻云淡6 小时前
GCC 和 GDB命令简单解读
java·linux·前端
省钱兄--zs6 小时前
西安24小时自助健身房解决方案实战:系统开发与部署全流程指南
java·spring boot·系统架构·intellij-idea·需求分析
资料库016 小时前
Linux 8个常见运维故障排查
java·linux·运维