【异常解决】Unable to start embedded Tomcat Nacos 启动报错

Unable to start embedded Tomcat Nacos 启动报错解决方案

一、背景描述

Windows 本地启动 Nacos(2.2.0) 服务,控制台报错 Unable to start embedded Tomcat。

报错信息:Unable to start embedded Tomcat,无法加载内置的tomcat。如下图所示:

二、原因分析

原因一:启动方式不对,直接双击打开或者是通过命令行启动(startup.cmd)默认是集群模式。

原因二:端口被占用。 Nacos 配置的默认端口号是 8848,请检查这个端口是否被占用。

三、解决方案

3.1 解决方案一

单机模式后启动

进入到nacos安装目录下的bin文件夹下,输入 startup.cmd -m standalone 回车即可。

复制代码
startup.cmd -m standalone

再次启动,成功!即可访问控制台 http://localhost:8848/nacos/index.html 。

3.2 解决方案二

把占用的 8848 端口 kill掉。然后再次启动 nacos 服务即可。

本文完结!

相关推荐
小羊没烦恼!3 天前
微服务化的基石——持续集成
java·大数据·word·powerpoint·.net
俊昭喜喜里3 天前
java中的继承和多态的区别
java
小羊没烦恼!3 天前
初探性能优化——2个月到4小时的性能提升
java·开发语言·windows·算法·c#
譕痕3 天前
JSONObject与JSONArray封装数据格式区别
java·json
胡写代码3 天前
别再前后端各写一套表单校验了
java·后端
小鱼能吃糖3 天前
缺陷修复总览 · mall电商项目:5类缺陷,1个病根,4个业务域
java·电商
此时不提桶,更待何时3 天前
01-06-A-JVM排查实战详解
java·jvm
vipxieliang3 天前
ValidX 在 DDD 领域驱动设计中的实践
java·spring boot
ba_pi3 天前
mysql 查询所有表名并授权
java
ProcessOn官方账号3 天前
java函数式编程--入门基础
java·编程·函数式编程