ORA-12792: Network transfer operation aborted due to TTC error 12543.

RMAN Active duplicate hung with ORA-12792: Network transfer operation aborted due to TTC error 12543

KB160250

Summary

Creation of standby using RMAN active duplicate hung with below errors seen on primary alert log :

2024-03-23T04:45:47.593662-04:00

Errors in file /u01/app/oracle/diag/rdbms/test_shk_iad/test/trace/test_ora_65670.trc:

ORA-12792: Network transfer operation aborted due to TTC error 12543.

2024-03-23T04:48:35.527422-04:00

Solution

Please follow below action plan to modify the iptables on both primary & standby and retry the active duplicate :

1.) Save iptables

sudo su -

iptables-save > /home/oracle/iptables.orig

2.) List iptables

iptables -L --line-numbers

3.) Delete following lines from below chains :

Chain INPUT (policy ACCEPT)

12 REJECT all -- anywhere anywhere reject-with icmp-host-prohibited

Chain FORWARD (policy ACCEPT)

1 REJECT all -- anywhere anywhere reject-with icmp-host-prohibited

4.) Below commands will be used for deletion :

iptables -D INPUT <number from first col from above output belonging to the reject-with icmp-host-prohibited >

iptables -D FORWARD <number from first col from above output belonging to the reject-with icmp-host-prohibited >

Example :

iptables -D INPUT 12

iptables -D FORWARD 1

4.) Verify if rules have been deleted :

iptables -L --line-numbers

5.) Retry the creation of standby.

6.) Below step to restore should be done only after standby is created.

Restore the default rules:

iptables-restore /tmp/iptables.orig

Reload and check if the previous rules are as a default

systemctl reload iptables.service

systemctl status iptables.service

Attachments :

Cause

This is known issue in DB System and this was being investigated in below mentioned bug by Development :

Bug 35470978 - ORCHESTRATIONS WHERE RMAN IS INVOLVED ARE FAILING WITH ORA-12792: NETWORK TRANSFER OPERATION ABORTED DUE TO TTC E

But bug got closed since issue was resolved with the workaround as mentioned below after which customer didn't comeback.

相关推荐
其实防守也摸鱼8 小时前
Fastjson 反序列化漏洞(JNDI注入)
android·数据库·安全·oracle·自动化·fastjson·反序列化
ClouGence16 小时前
开源数据库管理工具 CloudDM 4.3.0 发布,支持 SQL 收藏,多数据源语法支持大幅增强
数据库·oracle·sql server
Leo.yuan20 小时前
2026企业级数据集成平台市场报告:国内外厂商格局与技术路线
数据库·oracle
\光辉岁月/1 天前
7.mybatisplus学习-条件构造器、插件、通用枚举、多数据源环境、MybatisX
数据库·oracle
施嘉伟1 天前
Oracle 在线重定义卡了一个多小时:查不到阻塞会话
数据库·oracle
weixin_404551242 天前
Oracle SQL 优化知识库:构建方案与价值评估
数据库·sql·oracle
LRL_2 天前
Oracle 19c 创建用户并连接 PDB 完整避坑指南
数据库·oracle
其实防守也摸鱼2 天前
SQL注入实验笔记
android·运维·数据库·安全·oracle·自动化
做运维的阿瑞2 天前
一张用户表串懂 MySQL 的库、表、列、行、主键
数据库·sql·mysql·oracle
oradh2 天前
Oracle SQL Tuning Advisor调优工具
数据库·sql·oracle