ORA-12518:Oracle 监听程序无法分发客户端连接原因及解决方法

本文主要讲解ORA-12518:Oracle监听程序无法分发客户端连接的原因分析及解决方法。

问题描述

数据中台的同步任务有时会报错如下:

ORA-12518, TNS:listener could not hand off client connection。

意即Oracle监听程序无法分发客户端连接,

原因分析

只是有时候会报错,有时候又能成功执行,就可以排除监听配置错误的可能性,大概率是数据库当前的进程数或会话数已经达到设置的上限值,无法接收新的连接了,也可能是服务器内存或CPU资源耗尽,导致数据库无法创建新进程去响应连接。

进程数就是Oracle同时工作的进程数量,会话数就是Oracle同时接受的客户端连接的数量。

查询数据库的进程数上限:

SELECT value FROM v$parameter WHERE name = 'processes';

查询数据库的进会话数上限:

SELECT value FROM v$parameter WHERE name = 'sessions';

查询当前实际进程数:

SELECT COUNT(*) FROM v$process;

查询当前实际会话数:

SELECT COUNT(*) FROM v$session;

查询结果发现

实际进程数非常接近进程数上限值,实际会话数也很接近会话数上限值,而且检查发现Oracle服务器CPU和内存资源都还足够,说明是连接数达到上限了,需要调高上限值。

解决方法

Oracle默认的进程数和会话数上限分别是150和248,显然这是完全不够用的,应该根据实际项目规模来设置相应的进程数上限,

我这里把进程数上限改为1000:

ALTER SYSTEM SET processes=1000 SCOPE=spfile;

会话数上限会根据进程数上限自动计算,不用手动设置,一个进程可以对应多个会话,所以会话数一般高于进程数。

修改完成后需要重启数据库服务以使修改生效,打开运行窗口,输入 services.msc ,再按回车键,打开服务界面,先停止数据库服务和监听服务,再启动数据库服务和监听服务。

修改完进程数上限后,会话数上限也会根据换算关系自动调整过来,如下图,发现会话数上限已经变为1528了。

不同版本的Oracle数据库的会话数和进程数的换算关系有所区别,如下是目前的几种换算关系,从上到下不同的换算关系对应的版本越来越新。

1:会话数 = (进程数 * 1.1) + 5

2:会话数 = (进程数 * 1.5) + 22

3:会话数 = (进程数 * 1.5) + 28

后续观察发现中台同步任务没有再出现ORA-12518的报错了。

相关推荐
这个DBA有点耶3 天前
MVCC深入:Read View、版本链与快照读——InnoDB并发控制的内核
数据库·mysql·架构
DBA_G3 天前
从地面到云霄:GBase数据库在民航三大场景的落地实践
数据库
自由能燃气设备3 天前
商用全预混低氮冷凝锅炉免费方案vs付费方案对比+选型避坑指南
大数据·数据库·人工智能
科创致远3 天前
科创致远 ESOP 系统核心效能与实战价值展示
大数据·数据库·人工智能·精益工程
2601_962218613 天前
万象生鲜系统称重自动多退少补算法解决生鲜非标品痛点
大数据·数据库·人工智能·python·算法
张洛闻Eren3 天前
k8s云原生【第十课】:水平 Pod 自动扩缩容
运维·数据库·云原生·kubernetes·github
于平安3 天前
MySQL-触发器
数据库·mysql
白远山3 天前
上海24小时自助健身房解决方案实战指南与经验分享
java·数据库·架构·需求分析
Omics Pro3 天前
斯坦福Nature+Science|广义虚拟细胞基础大模型
数据库·人工智能·算法·机器学习·自然语言处理
2603_965148113 天前
AI+API选品:下一代智能商务助手雏形已现
java·大数据·数据库·人工智能·数据挖掘