磁盘故障导致数据库进入恢复模式

文章目录

环境

系统平台:银河麒麟 (鲲鹏)

版本:4.5.8

症状

程序无法连接数据库,psql登录数据库提示数据库进入恢复模式。

问题原因

1、命令 ls -lrth 执行后无任何输出,进程进入挂起状态。

2、top命令显示CPU 时间的 18.7%​ 消耗在 wa​ (I/O Wait) 上

3、vmstat 查看b 列:处于 "不可中断睡眠状态" 的进程数,持续稳定在 "3",说明系统中始终有 3 个进程在等待 I/O 资源。

解决方案

经诊断确认为存储设备物理故障,需要硬件供应商介入处理。

相关推荐
阳光九叶草LXGZXJ7 小时前
达梦数据库-报错-15-列【XXX】长度超出定义
linux·运维·数据库·sql·学习
字节渡客7 小时前
Redis键明明过期了,业务还在读到旧数据
数据库·redis·spring
OnlineProxy9 小时前
亚马逊多账号运营:如何在规避“关联封号”风险的同时实现电商规模化扩张
服务器·数据库·redis
辻弋20111 小时前
五年前的旅行视频糊成马赛克?Video2X用Real-ESRGAN逐帧重建细节,但只支持Windows、集显用户建议直接放弃
服务器·数据库·windows·游戏引擎·电脑
可乐鸡翅yeah_12 小时前
业务中 M3U8 水印相关坑,硬水印和动态水印区别
前端·网络·数据库·ffmpeg·m3u8在线
石头麻辣鱼12 小时前
Bamboo 调度系统 OceanBase 适配实战:存储过程迁移踩过的三个大坑
数据库
龙亘川12 小时前
数智驱动民政升级 精准守护民生保障
大数据·数据库·人工智能
念何架构之路13 小时前
zap扩展生态与总结
java·前端·数据库
晚安日记wanna13 小时前
MySQL 回表为什么这么慢?5 种优化手段逐个拆解
数据库·mysql·性能优化
第七页独白13 小时前
汽车零件厂如何通过 QMS 真正落地 IATF 16949——QMS软件系统:品质检验-内审稽核-8d客诉管理:全星质量管理软件系统
java·前端·数据库