PHP V6 单商户常见问题——数据库模式修改 sql-mode

数据库模式修改 sql-mode

问题现象

很多小伙伴在本地部署后访问站点会报下图这种错误:

数据获取失败:SQLSTATE42000: Syntax error or access violation: 1055 Expression #1 of SELECT list is not in GROUP BY clause and contains nonaggregated column nc_saas.SysUserRole.id' which is not functionally dependent on columns in GROUP BY clause; this is incompatible with sql_mode=only_full_group_by

问题原因

这是因为在MySQL 5.7后,MySQL默认开启了SQL_MODE严格模式,对数据进行严格校验。我们需要修改数据库配置

解决方案

一、本地部署数据库修改

1. 打开配置文件

打开本地部署软件phpstudy,侧边栏选择设置,点击文件位置,选择MySQL

2. 编辑 my.ini 文件

弹出的文件夹中双击打开my.ini文件

3. 修改 sql_mode

找到sql_mode(注意:有点显示的是sql_mode,有点显示的是sql-mode两者都可以),将sql_mode=NO_ENGINE_SUBSTITUTION,STRICT_TRANS_TABLES改为

复制代码
sql_mode=' '
4. 重启 MySQL

修改完成后,重启mysql

二、宝塔部署数据库修改

1. 选择 MySQL 软件

在宝塔侧边栏选择软件商店,搜索mysql,选中相应的数据库,点击设置

注意:要修改哪个站点的数据库,就选择该站点的数据库版本号

2. 搜索 sql-mode

点击配置修改,按住Ctrl+F键搜索sql-mode(注意:有点显示的是sql_mode,有点显示的是sql-mode两者都可以)

3. 修改配置

将sql-mode=NO_ENGINE_SUBSTITUTION,STRICT_TRANS_TABLES,NO_AUTO_VALUE_ON_ZERO改为

复制代码
sql-mode=' '
4. 保存配置

修改后点击保存

5. 重启 MySQL
相关推荐
damoluomu1 天前
挑 PHP CMS 之前,先学会看它的协议
php
子非鱼a1 天前
【WEB】Online ToolWEB
php
PHP实战开发录1 天前
Nginx上传大文件为什么报413
nginx·php·开发
damoluomu2 天前
国产企业级 PHP CMS:哪些能免费商用
php
郑州光合科技余经理2 天前
同城外卖小程序开发:下单成功后,后台导出能不能对上用户端状态
开发语言·前端·git·后端·uni-app·php·ai编程
MyFreeIT2 天前
Android PHP Manual
php
aixingpan2 天前
aixingpan.cn API开发文档:api_docs_trichart_natal_progression_sec_transit2接口指南
前端·php
sbjdhjd2 天前
从日志包含到临时文件竞争:文件包含进阶复盘中的 Docker、Windows 与 Session 限制
网络·安全·web安全·网络安全·数据挖掘·php·rce
daxiangxm2 天前
【趣味休息】“围住小猫在线玩”-“困住小猫”,又回来了
数据结构·人工智能·vscode·github·php
星光开发者2 天前
基于Spring Boot的充电桩管理系统的设计与实现-计算机毕设【课程设计】57105
vue.js·spring boot·vscode·mysql·django·php·express