HANA同库不同租户间备份,还原

场景:从S01租户库hnq整库备份,还原到S01下HIS租户库

1、备份

1.1、登录管理数据库systemdb

hdbsql -d systemdb -u system

backup data for hnq using file('/hana/shared/S01/HDB00/backup/data/DB_HNQ','full_hnq_')

1.2、登录租户库执行如下sql查看备份进度

\c -d HNQ -u system

SELECT * FROM SYS.M_BACKUP_CATALOG where entry_type_name='complete data backup' order by sys_end_time desc;

备份后文件如下

2、恢复

注意:

1.要恢复到最新状态,日期必须晚于最新状态

2.恢复的目标数据库不存在时,需要先创建好目标数据库,如果恢复的目标数据库和老的数据库名字相同,那么恢复后库的密码是新库的密码

3.SAP HANA 数据库无法恢复到比其现有版本低的任何版本。用于恢复的 SAP HANA 数据库软件版本必须是相同或高于创建备份的 SAP HANA 数据库的版本。

2.1、登录

登录管理数据库systemdb

hdbsql -d systemdb -u system

2.2 停止租户库

alter system stop database his;

2.3 执行恢复语句

RECOVER DATA FOR HIS USING FILE ('/hana/shared/S01/HDB00/backup/data/DB_HNQ/full_hnq_') CLEAR LOG

导入成功

3、备份恢复期间报错解决

3.1、如下报错原因是调用了backint文件备份,需要修改参数,system级别的参数需要登录systemdb管理数据库修改,database级别的参数需要登陆备份的数据库修改。

ALTER SYSTEM ALTER CONFIGURATION ('global.ini', 'SYSTEM') SET ('backup', 'catalog_backup_using_backint') = 'false' WITH RECONFIGURE;

ALTER SYSTEM ALTER CONFIGURATION ('global.ini', 'SYSTEM') SET ('backup', 'log_backup_using_backint') = 'false' WITH RECONFIGURE;

ALTER SYSTEM ALTER CONFIGURATION ('global.ini', 'DATABASE') SET ('backup', 'catalog_backup_using_backint') = 'false' WITH RECONFIGURE;

ALTER SYSTEM ALTER CONFIGURATION ('global.ini', 'DATABASE') SET ('backup', 'log_backup_using_backint') = 'false' WITH RECONFIGURE;

3.2、恢复时数据文件名称写错导致报错

错误原因:文件名多写了下划线!

真实名称

报错截图

解决方案:恢复命令 只写前缀,不要加下划线

相关推荐
weixin_511255211 小时前
MySQL升级记录
数据库·mysql
程序猿乐锅2 小时前
【黑马点评 | 第八篇】Redisson分布式锁
java·数据库·spring boot·redis·分布式·spring·缓存
Leo.yuan2 小时前
2026年本地化Data Agent优质厂商盘点:哪些产品更适合企业生产环境
大数据·数据库·人工智能
做运维的阿瑞2 小时前
数据库增删改的安全写法
数据库·sql·mysql
程序边界3 小时前
迁移评估不再拍脑袋,这个数据迁移工具的量化报告把我救了(上)
数据库
阿狗童鞋3 小时前
Redis实战指南
数据库·redis·缓存
lupai4 小时前
维修保养记录精准版 API 对接实战指南
数据库·python
2601_952196367 小时前
计算机科学与技术专业应届生投商业分析岗,需要哪些额外能力?
数据库·oracle
皮皮学姐分享-ppx7 小时前
地级市、省级人才政策强度测算(2000-2025)
大数据·数据库·人工智能·百度·高考
晚安日记wanna7 小时前
大厂禁 JOIN 的真正原因,拆到第四层才清楚
数据库·后端·面试