centos7内核kernel升级

centos7内核kernel升级

背景:最近部署k8s高版本v1.28.8时发现需要操作系统内核等级至少为5版本,因此整理了一下升级系统内核的一些操作和细节。

离线内核包rpm下载地址:

http://mirrors.coreix.net/elrepo-archive-archive/kernel/el7/x86_64/RPMS/

下载包列表:

bash 复制代码
kernel-lt-5.4.203-1.el7.elrepo.x86_64.rpm
kernel-lt-headers-5.4.203-1.el7.elrepo.x86_64.rpm
kernel-lt-devel-5.4.203-1.el7.elrepo.x86_64.rpm

升级操作:

bash 复制代码
[root@master ~]# rpm -ivh kernel-lt-5.4.203-1.el7.elrepo.x86_64.rpm
[root@master ~]# rpm -ivh kernel-lt-headers-5.4.203-1.el7.elrepo.x86_64.rpm
安装headers时一般会报错,应该是老版本的headers冲突了
[root@master ~]# rpm -q |grep kernel
[root@master ~]# rpm -qa |grep kernel
kernel-tools-libs-3.10.0-1062.el7.x86_64
kernel-ml-5.15.8-1.el7.elrepo.x86_64
kernel-headers-3.10.0-1160.49.1.el7.x86_64
kernel-debug-devel-3.10.0-1160.49.1.el7.x86_64
kernel-3.10.0-1062.el7.x86_64
kernel-tools-3.10.0-1062.el7.x86_64
[root@master ~]# 
卸载老版本再执行rpm -ivh 即可
[root@master ~]# rpm -e --nodeps kernel-headers-3.10.0-1160.49.1.el7.x86_64

[root@master ~]# rpm -ivh kernel-lt-devel-5.4.203-1.el7.elrepo.x86_64.rpm

# 检查当前启动内核列表
[root@k8s-node1 kernel]# awk -F\' '$1=="menuentry " {print $2}' /etc/grub2.cfg
CentOS Linux (5.4.203-1.el7.elrepo.x86_64) 7 (Core)
CentOS Linux (3.10.0-957.27.2.el7.x86_64) 7 (Core)
CentOS Linux (0-rescue-65113b1a0d2f6087d515e6a8cd0ee7ef) 7 (Core)
可以看到刚刚装的5.4在0号位。

设置默认启动内核为0号位的5.4:
[root@k8s-node1 kernel]# grub2-set-default 0

[root@k8s-node1 kernel]# reboot
重启生效:
[root@master kernel]# uname -r
5.4.203-1.el7.elrepo.x86_64
[root@master kernel]# 
相关推荐
KING-WU51219 分钟前
Linux 工具之Make 与 Makefile
java·linux·服务器
Lsetea37 分钟前
OpenSSL报certificate is not yet valid:error 9与notBefore时间排查
linux·运维·https·ssl证书·openssl
魔法阵维护师37 分钟前
Linux 命令行入门踩坑记录:从 VMware 装系统到文件管理
linux·运维·服务器
Apipi*1 小时前
30天速通Linux 第七章进程间通信
linux·运维·服务器
emo_2b1 小时前
Pycharm配置conda解释器时遇到的问题及解决方法
linux·pycharm·conda
人生百态,人生如梦2 小时前
Ubuntu在低版本下使用ccswitch+claudecode(CCSwitch+Docker+Claude)连调教程
linux·ubuntu·docker·claudecode·ccswitch
byte轻骑兵2 小时前
【BlueZ】hciconfig 工具:蓝牙适配器管理实操 + 源码实现基础
linux·bluez·电脑蓝牙·嵌入式蓝牙
SKH.2 小时前
Linux驱动-系统移植
linux·服务器
根目录下的猫2 小时前
虚拟机复制过来运行时:“虚拟机使用的此版本,VMware Workstation 不支持的硬件版本。”错误解决办法,亲测可用
linux·运维·服务器·后端
yunwei372 小时前
eBPF 入门实践教程十七:编写 eBPF 程序统计随机/顺序磁盘 I/O
linux·后端·性能优化