reset Offset 与connection reset by peer

问题1 reset Offset

某次生产线上,从KafkaManager监控页面,发现还剩几十万未消费数据量,过了几分钟之后,监控页面发现未消费数据量达到了几千万。

排查分析

定位生产日志,发现消费端 出现日志 reset offset, 结合上下文日志,发现在切换broker leader之后,提交的偏移量在新leader上面找不到,之后根据消费端配置的auto offset reset 由于我们配置的是earliest,所以从最早消费

问题原因

切换时候,broker是接入某云的kafka,当时后台发生OOM,造成broker切换,由于ack设置,导致新切换的broker 没有提交的偏移量,从而导致整个现象发生


问题2 connection reset by peer

某次请求某服务,偶然频繁出现请求错误,但刷新错误之后,又可以重新打开请求链接

排查分析

根据traceId,定位到服务链调用,网关服务出现connection reset by peer,说明调用我们的业务微服务出现问题, 日志上下文 观察调用IP有多个,可实际情况后台docker 的pod数量为1

问题原因

由于eureka段配置不合理,导致未将失效的服务实例杀死,通过eureka注册中心可以管道有一个未清除的实例,从而导致该现象产生。
解决措施:先手动下线微服务实例,后修改配置

相关推荐
Nebula_g44 分钟前
JavaSE加强:IO流
java·开发语言·windows·stream·javase
rannn_1111 小时前
JVM 面试题:类加载过程详解(附高频考点)
java·jvm·后端
程序猿乐锅4 小时前
从0-1一文详解RabbitMQ
java·分布式·后端·中间件·rabbitmq·ruby
考虑考虑8 小时前
JDK26中的List.ofLazy()
java·后端·java ee
小蒜学长8 小时前
基于SpringBoot的公寓报修管理系统的设计与实现(代码+数据库+LW)
java·spring boot·后端·公寓报修管理系统·多角色协同
for_ever_love__8 小时前
MySQL 主从复制讲透:binlog 原理、搭建步骤与读写分离
java·数据库·mysql·binlog·读写分离·原理·主从复制
小π军10 小时前
操作系统面试题
java·linux·服务器
倔强的石头10611 小时前
应用账号最小权限实践:读写账号、报表账号、运维账号分层
java·运维·开发语言
Shaoshing11 小时前
ThreadLocal
java·jvm·threadlocal