task oracle_110944_k:110944 blocked for more than 120 seconds

Jul 14 09:21:38 db systemd-logind: Failed to abandon session scope: Connection timed out

Jul 14 09:26:38 db systemd-logind: Failed to start session scope session-2283.scope: Connection timed out

Jul 14 09:28:45 db systemd: Failed to start Session 2283 of user root.

Jul 14 09:29:52 db systemd-logind: Failed to start session scope session-2285.scope: Connection timed out

Jul 14 09:31:08 db systemd: Failed to start Session 2285 of user root.

Jul 14 09:32:04 db systemd-logind: Failed to start session scope session-2286.scope: Connection timed out

Jul 14 09:32:46 db kernel: INFO: task oracle_110944_k:110944 blocked for more than 120 seconds.

Jul 14 09:33:38 db kernel: "echo 0 > /proc/sys/kernel/hung_task_timeout_secs" disables this message.

Jul 14 09:33:38 db kernel: oracle_110944_k D ffff94e117266eb0 0 110944 1 0x00000080

Jul 14 09:33:58 db kernel: Call Trace:

Jul 14 09:34:29 db kernel: \ schedule_preempt_disabled+0x29/0x70

Jul 14 09:35:44 db kernel: \ __mutex_lock_slowpath+0xc7/0x1d0

Jul 14 09:35:44 db kernel: \ mutex_lock+0x1f/0x2f

Jul 14 09:35:44 db kernel: \ do_last+0x28f/0x12c0

Jul 14 09:35:44 db kernel: \ path_openat+0xd7/0x640

Jul 14 09:35:44 db kernel: \ ? __do_fault.isra.58+0x8a/0x100

Jul 14 09:35:44 db kernel: \ do_filp_open+0x4d/0xb0

Jul 14 09:48:14 db systemd: Started Session 2299 of user root.

Jul 14 09:50:32 db systemd-logind: Failed to start session scope session-2300.scope: Connection timed out

Jul 14 09:52:34 db systemd-logind: Failed to start session scope session-2301.scope: Connection timed out

Jul 14 09:52:48 db su: (to oracle) root on tty1

Jul 14 09:53:12 db systemd-logind: Failed to start session scope session-2302.scope: Connection timed out

Jul 14 09:53:36 db kernel: drm:vmw_kms_update_layout_ioctl \[vmwgfx] *ERROR* Topology is beyond supported limits.

Jul 14 17:54:46 db kernel: Initializing cgroup subsys cpuset

Jul 14 17:54:46 db kernel: Initializing cgroup subsys cpu

Jul 14 17:54:46 db kernel: Initializing cgroup subsys cpuacct

Jul 14 17:54:46 db kernel: Linux version 3.10.0-862.el7.x86_64 (builder@kbuilder.dev.centos.org) (gcc version 4.8.5 20150623 (Red Hat 4.8.5-28) (GCC) ) #1 SMP Fri Apr 20 16:44:24 UTC 2018

Jul 14 17:54:46 db kernel: Command line: BOOT_IMAGE=/vmlinuz-3.10.0-862.el7.x86_64 root=/dev/mapper/centos-root ro crashkernel=auto rd.lvm.lv=centos/root rd.lvm.lv=centos/swap rhgb quiet LANG=en_US.UTF-8

Jul 14 09:20:07 db systemd: Started Session 2280 of user root.

Jul 14 09:20:07 db systemd: Started Session 2281 of user root.

Jul 14 09:21:38 db systemd-logind: Failed to abandon session scope: Connection timed out

Jul 14 09:26:38 db systemd-logind: Failed to start session scope session-2283.scope: Connection timed out

Jul 14 09:28:45 db systemd: Failed to start Session 2283 of user root.

Jul 14 09:29:52 db systemd-logind: Failed to start session scope session-2285.scope: Connection timed out

Jul 14 09:31:08 db systemd: Failed to start Session 2285 of user root.

Jul 14 09:32:04 db systemd-logind: Failed to start session scope session-2286.scope: Connection timed out

Jul 14 09:32:46 db kernel: INFO: task oracle_110944_k:110944 blocked for more than 120 seconds.

Jul 14 09:33:38 db kernel: "echo 0 > /proc/sys/kernel/hung_task_timeout_secs" disables this message.

Jul 14 09:33:38 db kernel: oracle_110944_k D ffff94e117266eb0 0 110944 1 0x00000080

Jul 14 09:33:58 db kernel: Call Trace:

Jul 14 09:34:29 db kernel: \ schedule_preempt_disabled+0x29/0x70

Jul 14 09:35:44 db kernel: \ __mutex_lock_slowpath+0xc7/0x1d0

Jul 14 09:35:44 db kernel: \ mutex_lock+0x1f/0x2f

Jul 14 09:35:44 db kernel: \ do_last+0x28f/0x12c0

Jul 14 09:35:44 db kernel: \ path_openat+0xd7/0x640

Jul 14 09:35:44 db kernel: \ ? __do_fault.isra.58+0x8a/0x100

处理办法

1、首先操作 # echo 0 > /proc/sys/kernel/hung_task_timeout_secs

2、根据mos:Linux: Node Reboots After "kernel: INFO: task ocssd.bin:<pid> blocked for more than 120 seconds." in /var/log/messages (Doc ID 1423693.1)

做如下操作:

echo 'vm.min_free_kbytes = 262144' >> /etc/sysctl.conf

echo 'vm.swappiness=100' >> /etc/sysctl.conf

sysctl -p

3、配置hugepage并禁用Auto Memory Management (AMM)

相关推荐
笃行3504 小时前
KingbaseES KSQL Developer 的连接管理、数据处理与对象管理
数据库
ha_lydms4 小时前
MaxCompute中加密与解密函数
大数据·数据库·数据仓库·hadoop·dataworks·maxcompute·odps
Shadow(⊙o⊙)5 小时前
MySQL内置函数
数据库·mysql
笃行3505 小时前
金仓 KingbaseES PL/SQL 开发全攻略:异常处理、数据类型、调试优化与过程语句
数据库
快乐的木子李6 小时前
mysql-26.7.0-linux26.7.0下载安装
数据库·mysql
excel7 小时前
prisma 如何处理数据库竞态
前端·数据库·后端
知行产研7 小时前
易控智驾:毛利率跃升17.2个百分点,矿山无人驾驶从“规模换增长“迈入“盈利拐点“
数据库·mysql
千里码aicood7 小时前
基于CART算法的图书分类系统设计与实现
数据库·算法·分类
饺子大魔王的男人8 小时前
Redis 内存和连接异常怎么排查?用 redis_exporter 搭一套可远程抓取的监控链路
数据库·redis·bootstrap
可涵不会debug8 小时前
第一次学 LangGraph:用一个快递案例搞懂 State、Node、Edge 和 compile
服务器·数据库·mysql