使用frp实现公网使用https访问exsi控制台

目录


背景

esxi控制台默认是通过https登陆的,但是因为它默认的证书是自签名的,所以在浏览器会标记为红色的叉;同时这对于配置安全的公网访问来说也是必须要解决的事情。这段时间碰巧遇到这个问题,上网找了好久没有找到合适的解决方案,不过经过我的尝试,终于找到了简单可行的方法。

方法

esxi配置

上传替换证书

这里略过ssl证书申请过程,将申请好的证书crt文件和key文件通过ssh上传到esxi的/etc/vmware/ssl/目录下,这里假设上传的文件是a.key和a.crt,

bash 复制代码
$ cd /etc/vmware/ssl/
$ mv rui.key rui.key.bak
$ mv rui.crt rui.crt.bak
$ mv a.key rui.key
$ mv a.crt rui.crt

重启相关服务

bash 复制代码
$ /etc/init.d/hostd restart
$ /etc/init.d/vpxa restart

frp配置

frps配置

ini 复制代码
# frps.ini
[common]
bind_addr = 0.0.0.0
bind_port = 7000
vhost_https_port = 8080

frpc配置

ini 复制代码
# frpc.ini
[common]
server_addr = x.x.x.x
server_port = 7000

[esxi_web]
type = https
local_ip = x.x.x.x # 这里替换为你本地esxi机器的ip
local_port = 443
custom_domains = www.example.com # 这里替换为你的域名,需要和ssl证书对应的域名一致

重启服务

在frpc客户端和frps服务端上分别重启对应服务

完成

在浏览器上输入https://www.example.com:8080 (注意这里替换成你的域名和端口) 即可访问esxi客户端,可以看到ssl证书也是正常的。

相关推荐
Zelman11 小时前
协议栈数据流全景分析
网络协议·tcp/ip·https
Lsetea17 小时前
OpenSSL报path length constraint exceeded:CA层级与pathlen排查
运维·https·ssl证书·openssl·证书链
Lsetea19 小时前
OpenSSL s_client退出码为0却证书验证失败:严格校验与Shell管道排查
https·shell·ssl证书·openssl·tls
Lsetea21 小时前
OpenSSL报permitted subtree violation:证书SAN与CA名称约束排查
运维·https·ssl证书·openssl·证书链
2501_916007472 天前
苹果应用商店App Store上架费用标准及原因解析
android·ios·小程序·https·uni-app·iphone·webview
zxanz12 天前
https 的基本原理是什么样的?
网络协议·http·https
Lsetea2 天前
OpenSSL verify报error 20:CAfile、fullchain与本地信任链分层排查
nginx·https·ssl证书·openssl·证书链
00后程序员张3 天前
苹果App Store上架指南:费用、原理与步骤详解
android·ios·小程序·https·uni-app·iphone·webview
春天花会开1314 天前
内网 HTTPS 部署实战:私有 CA + Nginx 反向代理全流程复盘
运维·nginx·https
SoStraw10 天前
无公网IP远程访问设备,不用frp也能实现99.9%连通率
frp·内网穿透·p2p·远程访问·webrpc·无公网ip·file2file