CentOS 8 服务器安装 MySQL 报错:no match mysql-community-server

参考 MySQL 官方文档:

报错如下:

bash 复制代码
1.No match for argument: mysql-community-server
2.Error: Unable to find a match: mysql-community-server

上面的错误都提示找不到 mysql-community-server。

【注】出现问题的核心原因为:基于RHEL 8和Oracle Linux 8的基于EL8的系统,在默认情况下附带了一个名为mysql的yum模块。 除非禁用此模块,否则它将屏蔽MySQL存储库提供的软件包。只要是 EL8 系统安装任何版本的 MySQL 都会有这样的问题。

官方原话:

(EL8 systems only) EL8-based systems such as RHEL8 and Oracle Linux 8 include a MySQL module that is enabled by default. Unless this module is disabled, it masks packages provided by MySQL repositories. To disable the included module and make the MySQL repository packages visible, use the following command (for dnf-enabled systems, replace yum in the command with dnf)。

禁用方法如下:

bash 复制代码
yum module disable mysql

# 如果是 dnf,命令如下:
dnf module disable mysql

然后继续安装 MySQL Server:

bash 复制代码
sudo yum install mysql-community-server

接下来就可以愉快的安装 MySQL 8.0 了。

个人博客:Roc's Blog

相关推荐
做运维的阿瑞9 分钟前
mysql数据库分组查询:GROUP BY 与 HAVING 的执行逻辑
数据库·sql·mysql
小小、码农33 分钟前
〖Linux进程间通信〗IPC全家桶:匿名管道、FIFO、共享内存、消息队列与信号量一篇打通
linux·运维·服务器
掉进电商坑三年没爬出来的东叔39 分钟前
2026最新:青龙面板搭建全自动薅羊毛脚本,云服务器24小时挂机教程
运维·服务器·pygame
沐欣工作室_lvyiyi1 小时前
基于物联网的智能商业零售管理系统设计与实现(论文+源码)
物联网·mysql·mysql数据库·零售
0+1111 小时前
Linux --应用层自定义协议与序列化
linux·运维·服务器·网络·tcp
dyxal1 小时前
Linux Crontab 防重复执行利器:flock 文件锁实战详解(脱敏版)
linux·运维·服务器
细嗅蔷薇@1 小时前
DML常见操作
数据库·mysql
niuTaylor1 小时前
RK3568 Linux SDK 详解:SDK 是什么、板级差异与完整构建流程
linux·运维·服务器
wdfk_prog2 小时前
Wi-Fi Direct 教程 07:第一次 P2P Scan 如何真正发出——WPS/P2P IE、radio work 与 driver request
运维·服务器·ubuntu·wifi-direct
谷哥的小弟2 小时前
CentOS寿终正寝
linux·运维·centos