bug篇之基于docker安装nacos(2.1.1)使用dubbo连接不上的问题

说明:首先我的nacos安装是2.1.1 版本,请注意版本问题。另外启动时用dubbo的话必须先启动服务提供者再启动服务使用者,否则会报错,同时也必须开放三个端口:8848,9848,9849

java.lang.IllegalStateException: Failed to check the status of the service com.laoyang.Interface.IUserRpc. No provider available for the service com.laoyang.Interface.IUserRpc from the url consumer://192.168.1.104...

cs 复制代码
#安装命令
docker pull nacos/nacos-server:v2.1.1


docker run -d --name nacos --restart=always --network=host -e MODE=standalone -e JVM_XMS=256m -e JVM_XMX=256m -e SPRING_DATASOURCE_PLATFORM=mysql -e MYSQL_SERVICE_HOST=127.0.0.1 -e MYSQL_SERVICE_PORT=8808 -e MYSQL_SERVICE_DB_NAME=nacos -e MYSQL_SERVICE_USER=root -e MYSQL_SERVICE_PASSWORD=root -e MYSQL_DATABASE_NUM=1 -p 9848:9848 -p 9849:9849  -v /home/nacos/init.d/custom.properties:/home/nacos/init.d/custom.properties -v /home/nacos/logs:/home/nacos/logs nacos/nacos-server:v2.1.1


注:这里三个端口一个要对应,不然可能会出现连接不上的问题(我这里使用的是 dubbo 测试)
#返回success代表端口已开放
firewall-cmd --query-port=9848/tcp
firewall-cmd --query-port=8848/tcp
firewall-cmd --query-port=9849/tcp

#开放端口
firewall-cmd --add-port=8848/tcp --permanent
firewall-cmd --add-port=9848/tcp --permanent
firewall-cmd --add-port=9849/tcp --permanent

#重新加载
firewall-cmd --reload
相关推荐
光依旧4 小时前
PageIndex没翻车,翻车的是我的解析器
docker·langchain·大模型·向量数据库·pdf解析·rag·pageindex
谢亮_vipxieliang7 小时前
容器排障实战手册:从日志到内核的分层排障
docker·云原生·容器·eureka
梦想不只是梦与想9 小时前
Docker 常用命令
docker
小白的码BUG之路12 小时前
Docker -- 构建ruoyi-gateway镜像
docker·容器·gateway
小白的码BUG之路12 小时前
Docker -- 构建ruoyi-system镜像
运维·docker·容器
小白的码BUG之路12 小时前
Docker -- 构建redis镜像
运维·docker·容器
江湖有缘13 小时前
Docker实战 | 使用Docker部署EspoCRM开源客户关系管理平台
docker·容器·开源
小白的码BUG之路13 小时前
Docker -- 构建ruoyi-auth镜像
运维·docker·容器
小白的码BUG之路1 天前
Docker -- 构建nacos镜像
运维·docker·容器
天衍四九-1 天前
【无标题】
前端·spring boot·mysql·nginx·docker