MongoDB-yum安装修改数据目录后启动失败

# 问题

mongodb 进程权限默认会被 SELinux 管理,修改配置中默认 storage.dbPath 、systemLog.path 造成启动失败。

# 解决方案

复制代码
① 修改为默认路径或重新安装
/var/lib/mongo
/var/log/mongodb/mongod.log

② 临时关闭 SELINUX 权限控制
setenforce 0

③ 永久关闭 SELINUX 权限控制
vim /etc/selinux/config
```
SELINUX=enforcing 修改为 SELINUX=permissive 或 SELINUX=disabled
```

# 拓展

SELinux 全称是 Security-Enhanced Linux,是一个内核级别的安全机制,从 Linux2.6 内核之后就将 SELinux 集成在了内核当中。SELinux 所采用委任式(MAC: Mandatory Access Control)存取权限控制系统资源,可针对特定程序与特定文件来进行权限的控制,即使是 root,在使用不同程序进程所取到的权限也不一样。Linux 默认访问控制标准是基于用户的自主访问控制(DAC: Discretionary Access Control)。

相关推荐
快乐的木子李22 分钟前
mysql-26.7.0-linux26.7.0下载安装
数据库·mysql
excel1 小时前
prisma 如何处理数据库竞态
前端·数据库·后端
智能运维指南1 小时前
研发效能平台建设路径:从工具堆砌到价值流驱动的效能革命
devops·研发效能度量·嘉为蓝鲸·研发效能平台
知行产研2 小时前
易控智驾:毛利率跃升17.2个百分点,矿山无人驾驶从“规模换增长“迈入“盈利拐点“
数据库·mysql
千里码aicood2 小时前
基于CART算法的图书分类系统设计与实现
数据库·算法·分类
饺子大魔王的男人2 小时前
Redis 内存和连接异常怎么排查?用 redis_exporter 搭一套可远程抓取的监控链路
数据库·redis·bootstrap
可涵不会debug2 小时前
第一次学 LangGraph:用一个快递案例搞懂 State、Node、Edge 和 compile
服务器·数据库·mysql
IvorySQL3 小时前
PostgreSQL 日报 |RLS 机密性绕过漏洞(9 月 27 日)
数据库·postgresql
夕除3 小时前
redis--RDB AOF
数据库·redis·缓存
数据工匠老o4 小时前
"能用应用层解决的不用存储过程",十年数据库经验总结
数据库·架构