【无标题】mysql 普通用户连接报错: MySql server has gone away

1、mysql 普通用户连接报错: MySql server has gone away

2、进入mysql错误日志位置查看输出日志显示错误为:

Warning MY-013130 Server Aborted connection 47 to db: 'unconnected' user: 'tjcx' host: '10.195.11.4' (init_connect command failed; diagnostics area: MY-001273 - Unknown collation: 'server')

错误原因: cd /etc/my.cnf:

数据库配置文件中参数配置错误:

应该将配置改成 init_connect = "SET NAMES utf8mb4 COLLATE utf8mb4_general_ci"

关于MySQL的初始化连接设置。SET NAMES utf8mb4 COLLATE server=utf8mb4_general_ci这一句是用于设置MySQL连接的字符集和排序规则。

在正常情况下,这个语句应该在连接MySQL数据库后执行。它告诉MySQL你希望使用的字符集和排序规则。utf8mb4是字符集的名字,utf8mb4_general_ci是排序规则的名字。

但是,这个语句中有一个小错误。在指定排序规则时,server=utf8mb4_general_ci是不正确的。你可能想要使用COLLATE utf8mb4_general_ci来指定排序规则。因此,正确的语句应该是:

复制代码
复制代码
sql`SET NAMES 'utf8mb4' COLLATE 'utf8mb4_general_ci';`

你可以在连接到MySQL后,直接运行这条语句来设置字符集和排序规则。如果你是在一个脚本中设置这个,那么应该在你的脚本开始处运行这个语句。如果你是在命令行中设置这个,那么应该在连接MySQL后,立即运行这个语句。

相关推荐
小白男神2 小时前
MySQL进阶学习四(存储过程、游标、触发器)
mysql
这个DBA有点耶3 小时前
MVCC深入:Read View、版本链与快照读——InnoDB并发控制的内核
数据库·mysql·架构
DBA_G3 小时前
从地面到云霄:GBase数据库在民航三大场景的落地实践
数据库
自由能燃气设备3 小时前
商用全预混低氮冷凝锅炉免费方案vs付费方案对比+选型避坑指南
大数据·数据库·人工智能
科创致远3 小时前
科创致远 ESOP 系统核心效能与实战价值展示
大数据·数据库·人工智能·精益工程
kybs19915 小时前
全球灾害数据分析可视化 毕业设计-附源码66794
vue.js·spring boot·mysql·安全·django·c#·asp.net
2601_962218615 小时前
万象生鲜系统称重自动多退少补算法解决生鲜非标品痛点
大数据·数据库·人工智能·python·算法
程序猿_极客5 小时前
【免费】分享一套优质的基于SSM的校园失物招领系统的设计与实现,源码+文档+视频详解(讲解)
java·mysql·ssm·课程设计·失物招领系统
张洛闻Eren5 小时前
k8s云原生【第十课】:水平 Pod 自动扩缩容
运维·数据库·云原生·kubernetes·github
于平安6 小时前
MySQL-触发器
数据库·mysql