linux下解决tomcat错误问题

错误一:

Linux下Tomcat启动报错:Neither the JAVA_HOME nor the JRE_HOME environment variable is defined

原因:可能是Linux环境变了,需要在catalina.sh文件里指定JDK路径

解决方式:

在/bin/catalina.sh配置文件中加入下面两行代码

export JAVA_HOME=/home/wzdinfo/jdk1.8.0_121(JDK安装在Linux的路径)

export JRE_HOME=/home/wzdinfo/jdk1.8.0_121/jre

保存退出,重启Tomcat即可

错误二:

Linux下Tomcat报错:java.lang.OutOfMemoryError: unable to create new native thread

原因:Java运行内存不够

解决方式:

在/bin/catalina.sh配置文件中加入下面一行代码

JAVA_OPTS="-server -Xms256m -Xmx1024m -XX:PermSize=128M -XX:MaxPermSize=256m"

保存退出,重启Tomcat即可

(未完待续)

相关推荐
姜鱼问生1 小时前
Nginx 缓存命中率监控:从 X-Cache-Status 到实时统计
运维·nginx·缓存
Apipi*2 小时前
30天速通Linux 第六章信号及信号处理
linux·运维·信号处理
天启HTTP3 小时前
爬虫防封核心原理:IP轮换机制与风控规避逻辑
linux·服务器·网络·爬虫·tcp/ip
运维行者_3 小时前
网络性能监控怎么做?从自动发现到根因分析的4个环节
运维·服务器·网络·人工智能·支持向量机
此时不提桶,更待何时4 小时前
06-14-A-Kafka集群运维与迁移实战详解
运维·kafka
广州浮点FLOATLIC5 小时前
许可证服务器迁移后软件打不开:研发 IT 怎样定位连接问题
linux·服务器·数据库
IT研究所5 小时前
AI-ITR平台如何减少客户问题反复升级?
大数据·运维·人工智能·低代码·自然语言处理·安全架构·企微
BLUcoding5 小时前
接口服务公网超时排查记录:SecureRandom 阻塞问题分析与解决
java·linux·springboot·aes·securerandom
AIgorithmGEEK6 小时前
[Linux]从手写报头到内核套路:序列化、反序列化与自定义协议全链路
linux·运维·服务器·网络·序列化·反序列化
Nil2086 小时前
leetcode 139单词拆分
linux·运维·服务器