如何设置远程服务器对本地服务器免密登录

背景

目前需要使用多台服务器进行完全分布式hadoop部署,所以先使用云服务器来记录一下服务器的免密登录

说明

A服务器:本机(10.6.3.226)

B服务器:云服务器(47.113.229.18)

实施步骤

1.本地生成密钥(公钥和私钥)

复制代码
ssh-keygen -t rsa

2.在A服务器拷贝公钥到B服务器

复制代码
scp ~/.ssh/id_rsa.pub username@B服务器IP:/tmp

3.登入B服务器,将公钥添加到授权密钥列表

注意:如果没有目标文件夹文件,请创建对应文件

复制代码
cat /tmp/id_rsa.pub >> ~/.ssh/authorized_keys

4.查看密钥列表

复制代码
cat ~/.ssh/authorized_keys

5.退出重新登录

复制代码
exit
ssh root@47.113.229.18
相关推荐
Zhou14113612 小时前
Docker_03_DockerCompose多容器编排
运维·docker·容器
北京中科新远科技12 小时前
AI网卡五层检查法:协议、PCIe、NUMA、端口与验收
服务器·网络·人工智能
shdkfbbv12 小时前
【无标题】
linux·运维·服务器
wp123_112 小时前
TLVR 电感在 AI 服务器电源中的应用与市场前景分析
服务器·人工智能·科技·ai·硬件工程
ycvv13 小时前
手机启动失败后的数据提取评估:系统状态、加密条件与文件验收
服务器·数据库·智能手机
_upupup13 小时前
包管理器和vim
linux·服务器
ESDWAN14 小时前
SD-WAN 企业选型与落地指南:从链路测试到网络架构设计
运维·网络·架构
一颗小树x14 小时前
NVIDIA 驱动故障排查实录:内核升级导致 nvidia-smi 失效
linux·服务器·nvidia驱动·启动失败·内核升级
啊哈一半醒14 小时前
Docker 底层知识:从 Namespace 到 UnionFS
运维·docker·容器
_smart_boy__14 小时前
I.MX6U开发板Uboot无法ping Ubuntu问题解决方案(二)
linux·运维·ubuntu