Failed to start The nginx HTTP and reverse proxy server.

本章教程主要分享一下,当nginx 启动时,遇到报这个错误时的一个解决问题思路。

目录

1、观察报错信息

2、尝试性解决


1、观察报错信息

根据日志的信息,我们至少可以知道2个比较信息。

1、操作用户执行命令是在非root权限下进行操作的。

2、Address already in use 这个很明显:意思就是当前端口已被使用。

2、尝试性解决

首先解决,第二个问题,端口被占用了,怎么办?

端口被占用,我们可以通过以下步骤进行结束相关进程。

执行以下命令,查找占用80端口的Nginx进程的PID

bash 复制代码
sudo lsof -i :80

执行以下命令,使用PID结束Nginx进程:

bash 复制代码
sudo kill -9 <PID>

然后,第一个问题,在非root权限下执行某些操作,很有可能会出现权限不足的情况。

所以,我们在执行操作的时候,尽量使用root权限进行操作,当然在root权限下执行操作时候需要额外谨慎,以免造成不必要的损失。

切换root用户命令:

bash 复制代码
su - root

# 然后输入你的root密码

通过以上步骤进行排查并操作,大概率就可以解决这个问题了。

相关推荐
网硕互联的小客服5 小时前
Linux服务器磁盘应该如何合理分区?
linux·运维·服务器
lisanmengmeng6 小时前
nacos nrpe 监控机及被监控机部署
服务器·nacos·nagios·nrpe
Lsetea6 小时前
OpenSSL verify报error 20:CAfile、fullchain与本地信任链分层排查
nginx·https·ssl证书·openssl·证书链
贵沫末6 小时前
Ubuntu——常用软件安装
linux·运维·ubuntu
Doraemomo7 小时前
Linux内核驱动开发——中断与定时器
linux·运维·驱动开发
2301_808414387 小时前
Linux中动静态库的理解
linux·运维·服务器
M78佐菲8 小时前
ARM学习笔记(11)
linux·arm开发·笔记·嵌入式硬件·学习
M78佐菲8 小时前
ARM学习笔记(10)
linux·arm开发·笔记·嵌入式硬件·学习
半仙白桑8 小时前
内核篇第十五讲:system-V共享内存
linux·共享内存·shmget·shmat·shmdt·shmctl
一条破秋裤9 小时前
Linux 线程创建:pthread_create 与基本回收
java·linux·运维