Failed to start The nginx HTTP and reverse proxy server.

本章教程主要分享一下,当nginx 启动时,遇到报这个错误时的一个解决问题思路。

目录

1、观察报错信息

2、尝试性解决


1、观察报错信息

根据日志的信息,我们至少可以知道2个比较信息。

1、操作用户执行命令是在非root权限下进行操作的。

2、Address already in use 这个很明显:意思就是当前端口已被使用。

2、尝试性解决

首先解决,第二个问题,端口被占用了,怎么办?

端口被占用,我们可以通过以下步骤进行结束相关进程。

执行以下命令,查找占用80端口的Nginx进程的PID

bash 复制代码
sudo lsof -i :80

执行以下命令,使用PID结束Nginx进程:

bash 复制代码
sudo kill -9 <PID>

然后,第一个问题,在非root权限下执行某些操作,很有可能会出现权限不足的情况。

所以,我们在执行操作的时候,尽量使用root权限进行操作,当然在root权限下执行操作时候需要额外谨慎,以免造成不必要的损失。

切换root用户命令:

bash 复制代码
su - root

# 然后输入你的root密码

通过以上步骤进行排查并操作,大概率就可以解决这个问题了。

相关推荐
咖丨喱9 分钟前
【MMC Core + hc16 Host(WiFi SDIO 如何落到控制器)】
linux
等我调个Bug17 分钟前
【Linux系统篇】权限
linux·服务器
~光~~1 小时前
【嵌入式linux学习】Cache 策略:Write-Through / Write-Back + Allocation
linux·学习·spring
峥无1 小时前
Linux NPTL线程:创建/终止/等待/分离/栈布局内核原理|线程下篇
linux·运维·线程
是jin奥2 小时前
Ubuntu 访问 Windows 共享目录
linux·运维·ubuntu
Gauss松鼠会2 小时前
【GaussDB】破除gaussdb ugin索引支持中文模糊查询的迷思-字符序
java·运维·服务器·网络·数据库·gaussdb·经验总结
Bruce_Liuxiaowei3 小时前
内网“影子资产“:串口服务器安全盲区剖析
服务器·网络·安全·iot
星恒随风3 小时前
Linux基础IO万字详解:从文件描述符fd到重定向、FILE缓冲机制及MiniShell升级
linux·运维·笔记·学习·状态模式
yunwei373 小时前
eBPF 入门开发实践教程一:Hello World,基本框架和开发流程
linux·后端·性能优化
小雪崩3 小时前
嵌入式学习 day65:Linux驱动进阶——pinctrl 子系统和 platform 驱动框架
linux·学习·驱动