Failed to start The nginx HTTP and reverse proxy server.

本章教程主要分享一下,当nginx 启动时,遇到报这个错误时的一个解决问题思路。

目录

1、观察报错信息

2、尝试性解决


1、观察报错信息

根据日志的信息,我们至少可以知道2个比较信息。

1、操作用户执行命令是在非root权限下进行操作的。

2、Address already in use 这个很明显:意思就是当前端口已被使用。

2、尝试性解决

首先解决,第二个问题,端口被占用了,怎么办?

端口被占用,我们可以通过以下步骤进行结束相关进程。

执行以下命令,查找占用80端口的Nginx进程的PID

bash 复制代码
sudo lsof -i :80

执行以下命令,使用PID结束Nginx进程:

bash 复制代码
sudo kill -9 <PID>

然后,第一个问题,在非root权限下执行某些操作,很有可能会出现权限不足的情况。

所以,我们在执行操作的时候,尽量使用root权限进行操作,当然在root权限下执行操作时候需要额外谨慎,以免造成不必要的损失。

切换root用户命令:

bash 复制代码
su - root

# 然后输入你的root密码

通过以上步骤进行排查并操作,大概率就可以解决这个问题了。

相关推荐
未济13 小时前
linux 配置环境变量
linux
傲世仙尊13 小时前
目录即文件-Ext文件系统收尾篇
linux·c语言
虎头金猫13 小时前
4K 视频总卡在公网带宽?用 N1 + OpenList 把网盘播放链路重新理顺
运维·服务器·网络·python·容器·beautifulsoup·pandas
还是大剑师兰特14 小时前
解决nginx错误:http://localhost:7000正常,http://localhost:7000/map 报错404
nginx·大剑师
_艾伦 耶格尔.15 小时前
进程间通信
linux
Liuqy-0515 小时前
Linux IO编程——静态库、动态库
linux
彧azz16 小时前
Linux 环境下 Redis 学习总结:数据类型、持久化、锁、事务、主从与缓存问题
linux·redis·笔记·学习·面试
xing-xing16 小时前
Docker容器中Nginx站点根目录网页配置访问
nginx·docker
-梅16 小时前
linux(8) 软硬链接
linux·运维·服务器
Wang's Blog17 小时前
Java 项目实战: 外卖平台-文件下载与ServletOutputStream回写浏览器
服务器·项目开发