Failed to start The nginx HTTP and reverse proxy server.

本章教程主要分享一下,当nginx 启动时,遇到报这个错误时的一个解决问题思路。

目录

1、观察报错信息

2、尝试性解决


1、观察报错信息

根据日志的信息,我们至少可以知道2个比较信息。

1、操作用户执行命令是在非root权限下进行操作的。

2、Address already in use 这个很明显:意思就是当前端口已被使用。

2、尝试性解决

首先解决,第二个问题,端口被占用了,怎么办?

端口被占用,我们可以通过以下步骤进行结束相关进程。

执行以下命令,查找占用80端口的Nginx进程的PID

bash 复制代码
sudo lsof -i :80

执行以下命令,使用PID结束Nginx进程:

bash 复制代码
sudo kill -9 <PID>

然后,第一个问题,在非root权限下执行某些操作,很有可能会出现权限不足的情况。

所以,我们在执行操作的时候,尽量使用root权限进行操作,当然在root权限下执行操作时候需要额外谨慎,以免造成不必要的损失。

切换root用户命令:

bash 复制代码
su - root

# 然后输入你的root密码

通过以上步骤进行排查并操作,大概率就可以解决这个问题了。

相关推荐
筝筝ba3 小时前
openBMC功耗封顶GUI测试
服务器
顺顺 尼4 小时前
linux 进程信号(上)
linux·c++·算法
niuTaylor4 小时前
飞腾 FT-2000/4 Ubuntu 内存卡 / NVMe SSD 系统制作完整指南
linux·服务器·人工智能·驱动开发·单片机
傲世仙尊5 小时前
信号量环形队列与线程池起步-把临界资源拆成很多份
linux
Huangjin007_5 小时前
【Linux 系统篇(二十五)】文件(二) 系统文件I/O详解
linux·运维·服务器
2601_962381135 小时前
历史视频朝代更替动效怎么做?把 AE 关键帧换成 AI 分镜动画的实战拆解
人工智能·nginx·音视频
ShineWinsu6 小时前
对于ProtoBuffer:ProtoBuffer的介绍以及安装
linux·网络·google·协议·序列化·反序列化·protobuffer
云表无代码开发6 小时前
日本开发者彻底破防:中文太强了!换成英文直接裂开
大数据·服务器·人工智能·microsoft·信息可视化
FlightYe6 小时前
视界原理之2D视频(二):视频文件里有什么
android·linux·网络·c++·ffmpeg·音视频·aac
LBL12207 小时前
内网容器部署FTP日志监控服务
运维·服务器·容器