Failed to start The nginx HTTP and reverse proxy server.

本章教程主要分享一下,当nginx 启动时,遇到报这个错误时的一个解决问题思路。

目录

1、观察报错信息

2、尝试性解决


1、观察报错信息

根据日志的信息,我们至少可以知道2个比较信息。

1、操作用户执行命令是在非root权限下进行操作的。

2、Address already in use 这个很明显:意思就是当前端口已被使用。

2、尝试性解决

首先解决,第二个问题,端口被占用了,怎么办?

端口被占用,我们可以通过以下步骤进行结束相关进程。

执行以下命令,查找占用80端口的Nginx进程的PID

bash 复制代码
sudo lsof -i :80

执行以下命令,使用PID结束Nginx进程:

bash 复制代码
sudo kill -9 <PID>

然后,第一个问题,在非root权限下执行某些操作,很有可能会出现权限不足的情况。

所以,我们在执行操作的时候,尽量使用root权限进行操作,当然在root权限下执行操作时候需要额外谨慎,以免造成不必要的损失。

切换root用户命令:

bash 复制代码
su - root

# 然后输入你的root密码

通过以上步骤进行排查并操作,大概率就可以解决这个问题了。

相关推荐
树下水月25 分钟前
Typora破解
linux·服务器·前端
沫璃染墨1 小时前
《从零入门Linux系统篇(五十七):线程篇·十——生产者消费者模型进阶:从环形缓冲区到POSIX信号量》
linux·运维·服务器·开发语言·c++·系统架构·信号处理
wuminyu1 小时前
LockStack在虚拟线程Mount和Unmount拷贝过程剖析
java·linux·c语言·jvm·c++
深念Y1 小时前
rime-雾凇拼音-配置记录
linux·junit·软件·拼音·kde
星夜夏空992 小时前
网络编程(5)—— Reactor实现(v3)
服务器·网络·php
程序猿老A3 小时前
从入门型到企业型:云服务器开放共享型到独享型规格升级
运维·服务器
殷色玫瑰3 小时前
C++ string类详解:常用接口、字符串操作与模拟实现
java·linux·c语言·开发语言·数据结构·c++
忆挽篱笙歌3 小时前
gcc,g++
linux
Wang's Blog3 小时前
Java 项目实战: 外卖平台优化-Nginx六种负载均衡策略对比与选型
java·nginx·负载均衡
l1t4 小时前
修复WSL CreateInstance/E_UNEXPECTED和 mounted read-only 错误
linux·windows·wsl