wordpress数据库迁移Invalid default value for ‘comment_date‘

问题说明

最近在往新的电脑上迁移一个wordpress网站,在往新电脑上的mysql数据库中导入数据时,报错:1067 - Invalid default value for 'comment_date'。

异常分析

这个错误的字面意思就是字段'comment_date'的默认值是无效的,于是查了一下我的导入sql文件,在里面的表wp_comments中找到了字段comment_date,它的默认值是:'0000-00-00 00:00:00',我电脑上装的mysql是5.7.x版本的,而在mysql5.7版本中mysql的sql_mode添加了两个参数:NO_ZERO_IN_DATE和NO_ZERO_DATE,其中NO_ZERO_IN_DATE表示mysql中插入的时间字段值(包括字段的默认值),不允许日期和月份为0;NO_ZERO_DATE表示mysql中插入的时间字段值(包括字段的默认值),不允许日期为0。

异常解决

原因是mysql的版本升级之后,字段comment_date的默认值不能是0

解决办法:导出数据库为sql文件,然后全文本进行替换

sql 复制代码
//1  comment_date默认内容进行替换
0000-00-00 00:00:00 替换为1970-01-01 08:00:01
//2  建表时utf8 5.7的排序规则选择你sql文件中的排序规则,一般都是以utf8mb4开头的字段
utf8mb4_unicode_520_ci 替换为  utf8mb4_0900_ai_ci

或者创建数据库的时候,就指定排序规则:

相关推荐
这个DBA有点耶21 小时前
MVCC深入:Read View、版本链与快照读——InnoDB并发控制的内核
数据库·mysql·架构
DBA_G21 小时前
从地面到云霄:GBase数据库在民航三大场景的落地实践
数据库
自由能燃气设备21 小时前
商用全预混低氮冷凝锅炉免费方案vs付费方案对比+选型避坑指南
大数据·数据库·人工智能
科创致远1 天前
科创致远 ESOP 系统核心效能与实战价值展示
大数据·数据库·人工智能·精益工程
2601_962218611 天前
万象生鲜系统称重自动多退少补算法解决生鲜非标品痛点
大数据·数据库·人工智能·python·算法
张洛闻Eren1 天前
k8s云原生【第十课】:水平 Pod 自动扩缩容
运维·数据库·云原生·kubernetes·github
于平安1 天前
MySQL-触发器
数据库·mysql
白远山1 天前
上海24小时自助健身房解决方案实战指南与经验分享
java·数据库·架构·需求分析
Omics Pro1 天前
斯坦福Nature+Science|广义虚拟细胞基础大模型
数据库·人工智能·算法·机器学习·自然语言处理
2603_965148111 天前
AI+API选品:下一代智能商务助手雏形已现
java·大数据·数据库·人工智能·数据挖掘