wordpress数据库迁移Invalid default value for ‘comment_date‘

问题说明

最近在往新的电脑上迁移一个wordpress网站,在往新电脑上的mysql数据库中导入数据时,报错:1067 - Invalid default value for 'comment_date'。

异常分析

这个错误的字面意思就是字段'comment_date'的默认值是无效的,于是查了一下我的导入sql文件,在里面的表wp_comments中找到了字段comment_date,它的默认值是:'0000-00-00 00:00:00',我电脑上装的mysql是5.7.x版本的,而在mysql5.7版本中mysql的sql_mode添加了两个参数:NO_ZERO_IN_DATE和NO_ZERO_DATE,其中NO_ZERO_IN_DATE表示mysql中插入的时间字段值(包括字段的默认值),不允许日期和月份为0;NO_ZERO_DATE表示mysql中插入的时间字段值(包括字段的默认值),不允许日期为0。

异常解决

原因是mysql的版本升级之后,字段comment_date的默认值不能是0

解决办法:导出数据库为sql文件,然后全文本进行替换

sql 复制代码
//1  comment_date默认内容进行替换
0000-00-00 00:00:00 替换为1970-01-01 08:00:01
//2  建表时utf8 5.7的排序规则选择你sql文件中的排序规则,一般都是以utf8mb4开头的字段
utf8mb4_unicode_520_ci 替换为  utf8mb4_0900_ai_ci

或者创建数据库的时候,就指定排序规则:

相关推荐
仍然.6 分钟前
Redis---集群
数据库·redis·缓存
Allstar_438 分钟前
DV/PV 验证管理:为量产放行提供完整证据链——全星研发项目管理 APQP 软件系统汽车电子行业专业级研发项目管理平台
数据库·汽车
小范的技术工坊30 分钟前
向量数据库解决了什么问题?
数据库
小蒜学长33 分钟前
在线保险服务与管理平台的设计与实现(代码+数据库+LW)
java·数据库·spring boot·后端·服务平台·在线保险
做运维的阿瑞1 小时前
SQL 面试高频:用户、商品、订单三表查询全解析
数据库·sql·mysql
CJi0NG2 小时前
【自用】MySQL - 语法:DDL、DML、DQL、DCL
数据库·mysql
姜鱼问生3 小时前
数据库备份 + 灾难恢复演练:从 dump 恢复全库
运维·数据库
ao-weilai3 小时前
MySQL数据库:表约束
数据库·mysql·adb
ly76894 小时前
Redis 分布式锁的边界条件:Redlock 争议、锁续期与客户端崩溃后的互斥失效
数据库·redis·分布式·分布式锁·watchdog·redlock
kaixin_learn_qt_ing4 小时前
qgeoview-samples-basic
数据库