wordpress数据库迁移Invalid default value for ‘comment_date‘

问题说明

最近在往新的电脑上迁移一个wordpress网站,在往新电脑上的mysql数据库中导入数据时,报错:1067 - Invalid default value for 'comment_date'。

异常分析

这个错误的字面意思就是字段'comment_date'的默认值是无效的,于是查了一下我的导入sql文件,在里面的表wp_comments中找到了字段comment_date,它的默认值是:'0000-00-00 00:00:00',我电脑上装的mysql是5.7.x版本的,而在mysql5.7版本中mysql的sql_mode添加了两个参数:NO_ZERO_IN_DATE和NO_ZERO_DATE,其中NO_ZERO_IN_DATE表示mysql中插入的时间字段值(包括字段的默认值),不允许日期和月份为0;NO_ZERO_DATE表示mysql中插入的时间字段值(包括字段的默认值),不允许日期为0。

异常解决

原因是mysql的版本升级之后,字段comment_date的默认值不能是0

解决办法:导出数据库为sql文件,然后全文本进行替换

sql 复制代码
//1  comment_date默认内容进行替换
0000-00-00 00:00:00 替换为1970-01-01 08:00:01
//2  建表时utf8 5.7的排序规则选择你sql文件中的排序规则,一般都是以utf8mb4开头的字段
utf8mb4_unicode_520_ci 替换为  utf8mb4_0900_ai_ci

或者创建数据库的时候,就指定排序规则:

相关推荐
ToddyBear11 分钟前
云厂商技术支持部门的原话:元数据库删了,我们也恢复不了[特殊字符]
数据库·产品运营
IanSkunk1 小时前
从检查设备到训练方案:眼科与视光中心设备联动的数据通路、字段口径与校验规则
服务器·数据库·负载均衡
ShineWinsu1 小时前
对于Redis:事务的解析
数据库·redis·mysql·缓存·面试·事务·acid
ao-weilai2 小时前
MySQL数据库:内置函数
android·数据库·mysql
LaughingZhu2 小时前
Product Hunt 每日热榜 | 2026-10-02
数据库·人工智能·深度学习·神经网络·搜索引擎
天疆说3 小时前
腾讯会议 Linux 版在 NVIDIA 显卡上看不到画面:EGL 像素配置与窗口视觉不匹配的排查与修复
linux·数据库·腾讯会议
2603_969579284 小时前
中小团队数据库选型:MySQL vs PostgreSQL,业务场景怎么选
数据库·mysql·postgresql
IT大白鼠4 小时前
图数据库系列 · 第 06 篇——避坑汇总:经典生产问题
数据库·nosql·图库数据库
江湖有缘4 小时前
3开源Sqlite数据库管理工具整理合集,可Docker一键部署!
数据库·sqlite·开源